summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2024-03-28 08:44:42 -0300
committerGitHub <noreply@github.com>2024-03-28 08:44:42 -0300
commit84be484645cdcc12bc12591874bfebd24cc0c9a6 (patch)
treecab4ac06027ec4599ebdfb432e956a1b978ff3c3
parentda46cb6c07ff25a000840b695627a326b0d4085a (diff)
parent10c814f2273940604d6c3c7853e8475959b6eb5d (diff)
downloadmeta-freescale-84be484645cdcc12bc12591874bfebd24cc0c9a6.tar.gz
Merge pull request #1773 from sapiippo/master
gstreamer1.0-plugins-base: Don't always enable viv-fb
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend3
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.5.imx.bb6
2 files changed, 2 insertions, 7 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend
index 761189af..ca6636b8 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.%.bbappend
@@ -6,7 +6,7 @@ PACKAGECONFIG_GL:use-mainline-bsp = \
6 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}" 6 "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl gbm', '', d)}"
7 7
8# The i.MX8 uses KMS instead of the Vivante specific framebuffer API. 8# The i.MX8 uses KMS instead of the Vivante specific framebuffer API.
9# The i.MX7 does not have a GPU. 9# The i.MX7 does not have a GPU, except for ULP.
10# This leaves the i.MX6 - with the vendor BSP - as the remaining use case for viv-fb. 10# This leaves the i.MX6 - with the vendor BSP - as the remaining use case for viv-fb.
11# 11#
12# (Note that viv-fb is about the _windowing system_. Vivante direct texture support 12# (Note that viv-fb is about the _windowing system_. Vivante direct texture support
@@ -14,3 +14,4 @@ PACKAGECONFIG_GL:use-mainline-bsp = \
14# which was fixed in GStreamer 1.22.5. Since then, the direct texture support is 14# which was fixed in GStreamer 1.22.5. Since then, the direct texture support is
15# detected by Meson by checking for direct texture symbols like "glTexDirectVIV".) 15# detected by Meson by checking for direct texture symbols like "glTexDirectVIV".)
16PACKAGECONFIG_GL:append:mx6-nxp-bsp = " viv-fb " 16PACKAGECONFIG_GL:append:mx6-nxp-bsp = " viv-fb "
17PACKAGECONFIG_GL:append:mx7ulp-nxp-bsp = " viv-fb "
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.5.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.5.imx.bb
index 366314bd..29347f21 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.5.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.22.5.imx.bb
@@ -125,12 +125,6 @@ S = "${WORKDIR}/git"
125 125
126inherit use-imx-headers 126inherit use-imx-headers
127 127
128# Prior to version 1.22.5, viv-fb is coupled with the Vivante direct texture feature.
129# For this reason, in these older versions, viv-fb must be enabled always, even when
130# building for SoCs like the i.MX8 that do not support the viv-fb windowing system.
131# TODO: Once this .imx recipe is upgraded to 1.22.5 or newer, drop this line.
132PACKAGECONFIG_GL:append = " viv-fb "
133
134PACKAGECONFIG_REMOVE ?= "jpeg" 128PACKAGECONFIG_REMOVE ?= "jpeg"
135PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}" 129PACKAGECONFIG:remove = "${PACKAGECONFIG_REMOVE}"
136PACKAGECONFIG:append:imxgpu2d = " g2d" 130PACKAGECONFIG:append:imxgpu2d = " g2d"