summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlban Bedel <alban.bedel@avionic-design.de>2019-06-25 11:44:57 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-06-27 16:53:58 -0300
commit82adb4390a070b9250989c1e70ba516a29971b2d (patch)
treefa6a62faf94b12735439b7a2004e484fa2720e3c
parentdef3b746cebf31838d29cbae4de9e72ed7ae9f9f (diff)
downloadmeta-freescale-82adb4390a070b9250989c1e70ba516a29971b2d.tar.gz
atf: Fix the build on machines that don't support UEFI
The uefi package silently build nothing on machines that are not supported. On machines without UEFI support this lead to a build failure in atf as it always try to build fip_uefi.bin. Fix the compile step to only build fip_uefi.bin if there is an UEFI image. Signed-off-by: Alban Bedel <alban.bedel@avionic-design.de>
-rw-r--r--recipes-bsp/atf/atf_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index 6583be84..2f8a38a0 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -125,7 +125,7 @@ do_compile() {
125 cp -r ${S}/build/ls1012afrwy_512mb/release/fuse_fip.bin ${S}/fuse_fip_512mb.bin 125 cp -r ${S}/build/ls1012afrwy_512mb/release/fuse_fip.bin ${S}/fuse_fip_512mb.bin
126 fi 126 fi
127 fi 127 fi
128 if [ -n "${uefiboot}" ]; then 128 if [ -n "${uefiboot}" -a -f "${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot}" ]; then
129 oe_runmake V=1 -C ${S} realclean 129 oe_runmake V=1 -C ${S} realclean
130 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} 130 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt}
131 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin 131 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin