summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2019-12-22 15:22:37 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-22 20:15:05 -0300
commit7c5a040fb85512bfbf4db253240cda5617c238c0 (patch)
tree24619a3ca0346c291fd815e96910c850a19c5899
parent12ebeeba3d9cbf00c8614441111d5e1a7a1ea419 (diff)
downloadmeta-freescale-7c5a040fb85512bfbf4db253240cda5617c238c0.tar.gz
gstreamer1.0-plugins-bad: fix recipe and add patches from oe-core
Fix absolute search paths in the recipe, which attemped to use patches directly from oe-core and keep those patches in this layer. This would allow ease of tracking (patches could be dropped once version is upgraded) and resolves the dependency from oe-core layer (no direct inclusion necessary via env variables which is not present at every build system setup). Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch30
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch61
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch85
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch28
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb3
5 files changed, 204 insertions, 3 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch
new file mode 100644
index 00000000..32261279
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/avoid-including-sys-poll.h-directly.patch
@@ -0,0 +1,30 @@
1From 72561a0fca562d03567ace7b4cfc94992cd6525c Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Wed, 3 Feb 2016 18:05:41 -0800
4Subject: [PATCH] avoid including <sys/poll.h> directly
5
6musl libc generates warnings if <sys/poll.h> is included directly.
7
8Upstream-Status: Pending
9
10Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
11---
12 sys/dvb/gstdvbsrc.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15diff --git a/sys/dvb/gstdvbsrc.c b/sys/dvb/gstdvbsrc.c
16index b93255f..49f145a 100644
17--- a/sys/dvb/gstdvbsrc.c
18+++ b/sys/dvb/gstdvbsrc.c
19@@ -97,7 +97,7 @@
20 #include <gst/gst.h>
21 #include <gst/glib-compat-private.h>
22 #include <sys/ioctl.h>
23-#include <sys/poll.h>
24+#include <poll.h>
25 #include <fcntl.h>
26 #include <errno.h>
27 #include <stdio.h>
28--
291.9.1
30
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch
new file mode 100644
index 00000000..25861b6b
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/configure-allow-to-disable-libssh2.patch
@@ -0,0 +1,61 @@
1From f59c5269f92d59a5296cbfeeb682d42095cd88ad Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Thu, 18 Sep 2014 02:24:07 -0400
4Subject: [PATCH] gstreamer1.0-plugins-bad: allow to disable libssh2
5
6libssh2 is automatically linked to if present, this undetermined
7dependency may cause build errors like:
8
9 .../x86_64-poky-linux/4.9.0/ld: cannot find -lssh2
10
11libssh2 isn't an oe-core recipe, so allow to disable it from
12configure.
13
14Upstream-Status: Pending
15
16Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
17---
18 configure.ac | 23 +++++++++++++++++------
19 1 file changed, 17 insertions(+), 6 deletions(-)
20
21Index: gst-plugins-bad-1.12.3/configure.ac
22===================================================================
23--- gst-plugins-bad-1.12.3.orig/configure.ac
24+++ gst-plugins-bad-1.12.3/configure.ac
25@@ -1202,6 +1202,15 @@ AG_GST_CHECK_FEATURE(CHROMAPRINT, [chrom
26 ])
27
28 dnl *** Curl ***
29+AC_ARG_ENABLE([libssh2],
30+ [ --enable-libssh2 enable LIBSSH2 support @<:@default=auto@:>@],
31+ [case "${enableval}" in
32+ yes) NEED_SSH2=yes ;;
33+ no) NEED_SSH2=no ;;
34+ auto) NEED_SSH2=auto ;;
35+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-libssh2]) ;;
36+ esac],[NEED_SSH2=auto])
37+
38 translit(dnm, m, l) AM_CONDITIONAL(USE_CURL, true)
39 AG_GST_CHECK_FEATURE(CURL, [Curl plugin], curl, [
40 PKG_CHECK_MODULES(CURL, libcurl >= 7.35.0, [
41@@ -1224,12 +1233,14 @@ AG_GST_CHECK_FEATURE(CURL, [Curl plugin]
42 ])
43 AC_SUBST(CURL_CFLAGS)
44 AC_SUBST(CURL_LIBS)
45- PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
46- HAVE_SSH2="yes"
47- AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
48- ], [
49- HAVE_SSH2="no"
50- ])
51+ if test "x$NEED_SSH2" != "xno"; then
52+ PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
53+ HAVE_SSH2="yes"
54+ AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
55+ ], [
56+ HAVE_SSH2="no"
57+ ])
58+ fi
59 AM_CONDITIONAL(USE_SSH2, test "x$HAVE_SSH2" = "xyes")
60 AC_SUBST(SSH2_CFLAGS)
61 AC_SUBST(SSH2_LIBS)
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch
new file mode 100644
index 00000000..2d5389d9
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/ensure-valid-sentinels-for-gst_structure_get-etc.patch
@@ -0,0 +1,85 @@
1From 2262ba4b686d5cc0d3e894707fe1d31619a3a8f1 Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Tue, 9 Feb 2016 14:00:00 -0800
4Subject: [PATCH] ensure valid sentinals for gst_structure_get() etc
5
6For GStreamer functions declared with G_GNUC_NULL_TERMINATED,
7ie __attribute__((__sentinel__)), gcc will generate a warning if the
8last parameter passed to the function is not NULL (where a valid NULL
9in this context is defined as zero with any pointer type).
10
11The C callers to such functions within gst-plugins-bad use the C NULL
12definition (ie ((void*)0)), which is a valid sentinel.
13
14However the C++ NULL definition (ie 0L), is not a valid sentinel
15without an explicit cast to a pointer type.
16
17Upstream-Status: Pending
18
19Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
20---
21 sys/decklink/gstdecklink.cpp | 10 +++++-----
22 sys/decklink/gstdecklinkaudiosrc.cpp | 2 +-
23 sys/decklink/gstdecklinkvideosink.cpp | 2 +-
24 3 files changed, 7 insertions(+), 7 deletions(-)
25
26Index: gst-plugins-bad-1.10.2/sys/decklink/gstdecklink.cpp
27===================================================================
28--- gst-plugins-bad-1.10.2.orig/sys/decklink/gstdecklink.cpp
29+++ gst-plugins-bad-1.10.2/sys/decklink/gstdecklink.cpp
30@@ -617,7 +617,7 @@ gst_decklink_mode_get_structure (GstDeck
31 "pixel-aspect-ratio", GST_TYPE_FRACTION, mode->par_n, mode->par_d,
32 "interlace-mode", G_TYPE_STRING,
33 mode->interlaced ? "interleaved" : "progressive",
34- "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, NULL);
35+ "framerate", GST_TYPE_FRACTION, mode->fps_n, mode->fps_d, (void*)NULL);
36
37 if (input && mode->interlaced) {
38 if (mode->tff)
39@@ -632,16 +632,16 @@ gst_decklink_mode_get_structure (GstDeck
40 case bmdFormat8BitYUV: /* '2vuy' */
41 gst_structure_set (s, "format", G_TYPE_STRING, "UYVY",
42 "colorimetry", G_TYPE_STRING, mode->colorimetry,
43- "chroma-site", G_TYPE_STRING, "mpeg2", NULL);
44+ "chroma-site", G_TYPE_STRING, "mpeg2", (void*)NULL);
45 break;
46 case bmdFormat10BitYUV: /* 'v210' */
47- gst_structure_set (s, "format", G_TYPE_STRING, "v210", NULL);
48+ gst_structure_set (s, "format", G_TYPE_STRING, "v210", (void*)NULL);
49 break;
50 case bmdFormat8BitARGB: /* 'ARGB' */
51- gst_structure_set (s, "format", G_TYPE_STRING, "ARGB", NULL);
52+ gst_structure_set (s, "format", G_TYPE_STRING, "ARGB", (void*)NULL);
53 break;
54 case bmdFormat8BitBGRA: /* 'BGRA' */
55- gst_structure_set (s, "format", G_TYPE_STRING, "BGRA", NULL);
56+ gst_structure_set (s, "format", G_TYPE_STRING, "BGRA", (void*)NULL);
57 break;
58 case bmdFormat10BitRGB: /* 'r210' Big-endian RGB 10-bit per component with SMPTE video levels (64-960). Packed as 2:10:10:10 */
59 case bmdFormat12BitRGB: /* 'R12B' Big-endian RGB 12-bit per component with full range (0-4095). Packed as 12-bit per component */
60Index: gst-plugins-bad-1.10.2/sys/decklink/gstdecklinkaudiosrc.cpp
61===================================================================
62--- gst-plugins-bad-1.10.2.orig/sys/decklink/gstdecklinkaudiosrc.cpp
63+++ gst-plugins-bad-1.10.2/sys/decklink/gstdecklinkaudiosrc.cpp
64@@ -387,7 +387,7 @@ gst_decklink_audio_src_set_caps (GstBase
65 g_mutex_unlock (&self->input->lock);
66
67 if (videosrc) {
68- g_object_get (videosrc, "connection", &vconn, NULL);
69+ g_object_get (videosrc, "connection", &vconn, (void *) NULL);
70 gst_object_unref (videosrc);
71
72 switch (vconn) {
73Index: gst-plugins-bad-1.10.2/sys/decklink/gstdecklinkvideosink.cpp
74===================================================================
75--- gst-plugins-bad-1.10.2.orig/sys/decklink/gstdecklinkvideosink.cpp
76+++ gst-plugins-bad-1.10.2/sys/decklink/gstdecklinkvideosink.cpp
77@@ -285,7 +285,7 @@ reset_framerate (GstCapsFeatures * featu
78 gpointer user_data)
79 {
80 gst_structure_set (structure, "framerate", GST_TYPE_FRACTION_RANGE, 0, 1,
81- G_MAXINT, 1, NULL);
82+ G_MAXINT, 1, (void *) NULL);
83
84 return TRUE;
85 }
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch
new file mode 100644
index 00000000..73681f10
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch
@@ -0,0 +1,28 @@
1From a67781000e82bd9ae3813da29401e8c0c852328a Mon Sep 17 00:00:00 2001
2From: Andre McCurdy <armccurdy@gmail.com>
3Date: Tue, 26 Jan 2016 15:16:01 -0800
4Subject: [PATCH] fix maybe-uninitialized warnings when compiling with -Os
5
6Upstream-Status: Pending
7
8Signed-off-by: Andre McCurdy <armccurdy@gmail.com>
9---
10 gst-libs/gst/codecparsers/gstvc1parser.c | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/gst-libs/gst/codecparsers/gstvc1parser.c b/gst-libs/gst/codecparsers/gstvc1parser.c
14index fd16ee0..ddb890c 100644
15--- a/gst-libs/gst/codecparsers/gstvc1parser.c
16+++ b/gst-libs/gst/codecparsers/gstvc1parser.c
17@@ -1730,7 +1730,7 @@ gst_vc1_parse_sequence_layer (const guint8 * data, gsize size,
18 GstVC1SeqLayer * seqlayer)
19 {
20 guint32 tmp;
21- guint8 tmp8;
22+ guint8 tmp8 = 0;
23 guint8 structA[8] = { 0, };
24 guint8 structB[12] = { 0, };
25 GstBitReader br;
26--
271.9.1
28
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
index 3cf0c7af..2b037e94 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
@@ -10,9 +10,6 @@ PACKAGECONFIG_append_mx6q = " opencv"
10PACKAGECONFIG_append_mx6qp = " opencv" 10PACKAGECONFIG_append_mx6qp = " opencv"
11PACKAGECONFIG_append_mx8 = " opencv kms" 11PACKAGECONFIG_append_mx8 = " opencv kms"
12 12
13FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/poky/meta/recipes-multimedia/gstreamer/${PN}:"
14FILESEXTRAPATHS_prepend := "${BSPDIR}/sources/poky/meta/recipes-multimedia/gstreamer/files:"
15
16GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https" 13GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https"
17SRCBRANCH = "MM_04.05.01_1909_L4.19.35" 14SRCBRANCH = "MM_04.05.01_1909_L4.19.35"
18 15