diff options
author | Tom Hochstein <tom.hochstein@nxp.com> | 2022-02-16 11:54:14 -0600 |
---|---|---|
committer | Tom Hochstein <tom.hochstein@nxp.com> | 2022-02-24 13:32:53 -0600 |
commit | 767e567cfb0152311ee8ab90c817e37763fde303 (patch) | |
tree | aecb607250a15f329b15c4a689b45ca70fad9b01 | |
parent | 81b0be2a35572af796126b4b532e1610f2bffc71 (diff) | |
download | meta-freescale-767e567cfb0152311ee8ab90c817e37763fde303.tar.gz |
optee-client: Upgrade 3.10.0.imx -> 3.15.0.imx
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r-- | conf/machine/include/imx-base.inc | 2 | ||||
-rw-r--r-- | recipes-security/optee-imx/optee-client_3.15.0.imx.bb (renamed from recipes-security/optee-imx/optee-client_3.10.0.imx.bb) | 16 |
2 files changed, 11 insertions, 7 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc index 471300ca..aa59daba 100644 --- a/conf/machine/include/imx-base.inc +++ b/conf/machine/include/imx-base.inc | |||
@@ -429,7 +429,7 @@ PREFERRED_VERSION_libdrm:mx8-nxp-bsp ?= "2.4.107.imx" | |||
429 | 429 | ||
430 | # Use i.MX optee Version | 430 | # Use i.MX optee Version |
431 | PREFERRED_VERSION_optee-os:mx8-nxp-bsp ?= "3.15.0.imx" | 431 | PREFERRED_VERSION_optee-os:mx8-nxp-bsp ?= "3.15.0.imx" |
432 | PREFERRED_VERSION_optee-client:mx8-nxp-bsp ?= "3.10.0.imx" | 432 | PREFERRED_VERSION_optee-client:mx8-nxp-bsp ?= "3.15.0.imx" |
433 | PREFERRED_VERSION_optee-test:mx8-nxp-bsp ?= "3.10.0.imx" | 433 | PREFERRED_VERSION_optee-test:mx8-nxp-bsp ?= "3.10.0.imx" |
434 | 434 | ||
435 | #Use i.MX opencv Version for mx8 | 435 | #Use i.MX opencv Version for mx8 |
diff --git a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb index 2ad55a64..dcfee307 100644 --- a/recipes-security/optee-imx/optee-client_3.10.0.imx.bb +++ b/recipes-security/optee-imx/optee-client_3.15.0.imx.bb | |||
@@ -5,13 +5,13 @@ HOMEPAGE = "http://www.optee.org/" | |||
5 | LICENSE = "BSD-2-Clause" | 5 | LICENSE = "BSD-2-Clause" |
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" | 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b" |
7 | 7 | ||
8 | SRCBRANCH = "imx_5.4.70_2.3.0" | 8 | SRCBRANCH = "lf-5.10.72_2.2.0" |
9 | SRC_URI = " \ | 9 | SRC_URI = " \ |
10 | git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https;branch=${SRCBRANCH} \ | 10 | git://source.codeaurora.org/external/imx/imx-optee-client.git;protocol=https;branch=${SRCBRANCH} \ |
11 | file://tee-supplicant.service \ | 11 | file://tee-supplicant.service \ |
12 | " | 12 | " |
13 | 13 | ||
14 | SRCREV = "2a77cf88d956c34cb4a1c191bea6113e327f5fe0" | 14 | SRCREV = "182874320395787a389e5b0f7df02b32f3c0a1b0" |
15 | 15 | ||
16 | S = "${WORKDIR}/git" | 16 | S = "${WORKDIR}/git" |
17 | B = "${WORKDIR}/build" | 17 | B = "${WORKDIR}/build" |
@@ -29,13 +29,17 @@ EXTRA_OEMAKE = "ARCH=${OPTEE_ARCH} O=${B}" | |||
29 | do_install () { | 29 | do_install () { |
30 | oe_runmake -C ${S} install | 30 | oe_runmake -C ${S} install |
31 | 31 | ||
32 | install -D -p -m0644 ${B}/export/usr/lib/libteec.so.1.0 ${D}${libdir}/libteec.so.1.0 | 32 | install -D -p -m0644 ${B}/export/usr/lib/libteec.so.1.0.0 ${D}${libdir}/libteec.so.1.0.0 |
33 | ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so | 33 | ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so.1 |
34 | ln -sf libteec.so.1.0 ${D}${libdir}/libteec.so.1 | 34 | ln -sf libteec.so.1.0.0 ${D}${libdir}/libteec.so |
35 | |||
36 | install -D -p -m0644 ${B}/export/usr/lib/libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0.1.0 | ||
37 | ln -sf libckteec.so.0.1.0 ${D}${libdir}/libckteec.so.0 | ||
38 | ln -sf libckteec.so.0.1.0 ${D}${libdir}/libckteec.so | ||
35 | 39 | ||
36 | install -D -p -m0755 ${B}/export/usr/sbin/tee-supplicant ${D}${bindir}/tee-supplicant | 40 | install -D -p -m0755 ${B}/export/usr/sbin/tee-supplicant ${D}${bindir}/tee-supplicant |
37 | 41 | ||
38 | cp -a ${B}/export/usr/include ${D}/usr/ | 42 | cp -a ${B}/export/usr/include ${D}${includedir} |
39 | 43 | ||
40 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${WORKDIR}/tee-supplicant.service | 44 | sed -i -e s:/etc:${sysconfdir}:g -e s:/usr/bin:${bindir}:g ${WORKDIR}/tee-supplicant.service |
41 | install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service | 45 | install -D -p -m0644 ${WORKDIR}/tee-supplicant.service ${D}${systemd_system_unitdir}/tee-supplicant.service |