summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2019-01-11 03:14:12 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2019-01-14 16:23:38 -0200
commit761b4daf4e5fa672d044d359f6aeba03da9b94f9 (patch)
treed4762d3594e5630a5a6d1811f87d2a1ea0d436db
parentf25c74590cde9dc91198384e1c1a9d64ccbdc940 (diff)
downloadmeta-freescale-761b4daf4e5fa672d044d359f6aeba03da9b94f9.tar.gz
u-boot-qoriq: Upgrade version to 2018.09
*update to lsdk 1812 tag include the following changes c08de7c - SecureBoot_LX2160A: Correct the kernel header offset. 619d0d3 - ls2080ardb: check enablement of QSPI using DCFG_RCWSR15 0dfcc1f - ls1088a: Update the device tree for IFC/QSPI 8875034 - net/phy: Cortina CS4223 driver updates & bugfixes 88fa585 - mmc: fsl_esdhc: make get_cd work well in dm_mmc_ops 2211378 - Revert "pci: layerscape: Add the dts fixup for EP and RC" f8358cf - armv8: fsl-layerscape: properly configure qdma ICID f24e259 - lx2160: Enable support of EMC2305 1a858e3 - armv8: emc2305: add support for fan controller f37025a - fsl-ls2088ardb: dts: enabling SATA node ff3e128 - board/ls1046aqds: Bypass xfi port fixup for KR mode on LS1046AQDS 2c3c67e - armv8: ls2088ardb: change default device tree in defconfig for TFABOOT 7f79b25 - armv8: ls1088aqds: add support for ifc-nor boot for TFABOOT c1b55a8 - detect ifc-nor flash at run-time 6c99ca4 - pci: layerscape: Add the dts fixup for EP and RC ccfc35d - pci: layerscape: Do not scan when PEX work in EP mode dd167bc - pci: layerscape: Modify the EP and RC mode judge method 26defec - armv8,lx2160a: Initialize ethernet array in serdes_init 2851185 - armv8: lx2160a: Update CONFIG_SYS_FSL_PEBUF_BASE cce8348 - board/ls2088ardb: Update the device tree for IFC/QSPI 830ac80 - Correct QSPI bootcommand for LS2088 TFA boot 899e696 - ls2088ardb: add QSPI support for TFA-BOOT a9fb32b - ls1043a: add support for nand-boot cmd for TFA c2b3374 - arm64: lx2160ardb: enable DM support for sata 0f80b76 - armv8: dts: fsl-lx2160a: add sata node support a10b3fc - board/lx2160a: Update xspi_bootcmd, sd_bootcmd env ee09465 - armv8:LX2160: Adds distro secure boot support. 9a7d1e0 - drivers/spi: Disable hybrid mode for SPANSION S25FS-S family 6b04587 - drivers/spi: Introduce functions to read/write any register a748abd - fsl_qspi: Modify handling of RDAR, WRAR, 4K_ERASE commands 2af4cbd - armv8: lx2160a: Modify dspi1 controller intrrupts property 612bc35 - Enable sata configs to Kconfig for all LayerScape boards 358229b - armv8: ls1043aqds: modify the qspi_bootcmd definition Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq-common_2018.09.inc19
-rw-r--r--recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb (renamed from recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb)2
2 files changed, 20 insertions, 1 deletions
diff --git a/recipes-bsp/u-boot/u-boot-qoriq-common_2018.09.inc b/recipes-bsp/u-boot/u-boot-qoriq-common_2018.09.inc
new file mode 100644
index 00000000..a3a554cc
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-qoriq-common_2018.09.inc
@@ -0,0 +1,19 @@
1
2inherit fsl-u-boot-localversion
3
4LICENSE = "GPLv2 & BSD-3-Clause & BSD-2-Clause & LGPL-2.0 & LGPL-2.1"
5LIC_FILES_CHKSUM = " \
6 file://Licenses/gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://Licenses/bsd-2-clause.txt;md5=6a31f076f5773aabd8ff86191ad6fdd5 \
8 file://Licenses/bsd-3-clause.txt;md5=4a1190eac56a9db675d58ebe86eaf50c \
9 file://Licenses/lgpl-2.0.txt;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
10 file://Licenses/lgpl-2.1.txt;md5=4fbd65380cdd255951079008b364516c \
11"
12
13SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/u-boot;nobranch=1 \
14"
15SRCREV= "c08de7c3c92d45a824500ad936f4d72465c181ec"
16
17S = "${WORKDIR}/git"
18PV_append = "+fslgit"
19LOCALVERSION = "+fsl"
diff --git a/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
index 0ad754f7..d01efdd5 100644
--- a/recipes-bsp/u-boot/u-boot-qoriq_2018.03.bb
+++ b/recipes-bsp/u-boot/u-boot-qoriq_2018.09.bb
@@ -5,7 +5,7 @@ DESCRIPTION = "U-Boot provided by Freescale with focus on QorIQ boards"
5PROVIDES += "u-boot" 5PROVIDES += "u-boot"
6 6
7INHIBIT_DEFAULT_DEPS = "1" 7INHIBIT_DEFAULT_DEPS = "1"
8DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc" 8DEPENDS = "libgcc virtual/${TARGET_PREFIX}gcc bison-native bc-native swig-native python-native"
9DEPENDS_append_qoriq-arm64 = " change-file-endianess-native dtc-native tcl-native" 9DEPENDS_append_qoriq-arm64 = " change-file-endianess-native dtc-native tcl-native"
10DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native" 10DEPENDS_append_qoriq-arm = " change-file-endianess-native dtc-native tcl-native"
11DEPENDS_append_qoriq-ppc = " boot-format-native" 11DEPENDS_append_qoriq-ppc = " boot-format-native"