summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-08-12 12:33:04 -0300
committerGitHub <noreply@github.com>2021-08-12 12:33:04 -0300
commit72f59d35816cd2be6159013e4d96d03abf7f1c4b (patch)
tree25a8d09423efae95eba9000e7393e5b8d8dc1f6b
parentf1eae1b9151ec12fd4e92edb29a04acf9f6c9ce4 (diff)
parent98797c540ffd7221b9919316aaf5691df67acc40 (diff)
downloadmeta-freescale-72f59d35816cd2be6159013e4d96d03abf7f1c4b.tar.gz
Merge pull request #842 from tprrt/tprrt/imx-cst
imx-cst: introduce the recipe for the version 3.3.1
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb
new file mode 100644
index 00000000..004eea96
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "i.MX code signing tool"
2DESCRIPTION = "Provides software code signing support designed that integrate the HABv4 and AHAB library"
3SECTION = "cst"
4LICENSE = "BSD"
5
6LIC_FILES_CHKSUM = "file://LICENSE.bsd3;md5=1fbcd66ae51447aa94da10cbf6271530"
7
8DEPENDS = "byacc-native flex-native openssl"
9
10SRC_URI = "git://gitlab.apertis.org/pkg/imx-code-signing-tool.git;protocol=https;tag=debian/3.3.1+dfsg-2;nobranch=1"
11
12S = "${WORKDIR}/git"
13
14EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" AR="${AR}" OBJCOPY="${OBJCOPY}"'
15
16do_compile() {
17 cd ${S}/code/cst
18 oe_runmake build OSTYPE=linux64 ENCRYPTION=yes COPTIONS="${CFLAGS} ${CPPFLAGS}" LDOPTIONS="${LDFLAGS}"
19 cd -
20 oe_runmake -C code/hab_csf_parser COPTS="${CFLAGS} ${CPPFLAGS} ${LDFLAGS}"
21}
22
23do_install () {
24 install -d ${D}${bindir}
25 install -m 755 ${S}/code/cst/code/obj.linux64/cst ${D}${bindir}
26 install -m 755 ${S}/code/cst/code/obj.linux64/srktool ${D}${bindir}
27 install -m 755 ${S}/code/hab_csf_parser/csf_parser ${D}${bindir}
28}
29
30BBCLASSEXTEND = "native nativesdk"