summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHiago De Franco <hiago.franco@toradex.com>2024-03-14 10:11:53 -0300
committerHiago De Franco <hiago.franco@toradex.com>2024-03-14 10:11:53 -0300
commit666c40ca1536e9cbdd7971fe8cfcf710dc6f9728 (patch)
treefaec512e3983ddc80c781d97d9023e2890ea483c
parent168962807b038af60814e985a4006fe51f266d8d (diff)
downloadmeta-freescale-666c40ca1536e9cbdd7971fe8cfcf710dc6f9728.tar.gz
imx-test: Use ROOT_HOME instead of hardcoded home directory
Hardcoding the root home directory could cause issues when the ROOT_HOME is not set to '/home/root'. As example, the ROOT_HOME can be changed to '/root', which makes imx-test install files in the wrong folder. Therefore, replace '/home/root' with '$ROOT_HOME'. Usually, ROOT_HOME is already set to '/home/root' [1]. [1] https://docs.yoctoproject.org/4.3.3/ref-manual/variables.html?highlight=variables#term-ROOT_HOME Signed-off-by: Hiago De Franco <hiago.franco@toradex.com>
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
index 815a77df..846941f3 100644
--- a/recipes-bsp/imx-test/imx-test_git.bb
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -73,11 +73,11 @@ do_install() {
73 if [ -e ${WORKDIR}/clocks.sh ]; then 73 if [ -e ${WORKDIR}/clocks.sh ]; then
74 install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh 74 install -m 755 ${WORKDIR}/clocks.sh ${D}/unit_tests/clocks.sh
75 fi 75 fi
76 install -d -m 0755 ${D}/home/root/ 76 install -d -m 0755 ${D}${ROOT_HOME}/
77 install -m 0644 ${WORKDIR}/memtool_profile ${D}/home/root/.profile 77 install -m 0644 ${WORKDIR}/memtool_profile ${D}${ROOT_HOME}/.profile
78} 78}
79 79
80FILES:${PN} += "/unit_tests /home/root/.profile" 80FILES:${PN} += "/unit_tests ${ROOT_HOME}/.profile"
81RDEPENDS:${PN} = "bash" 81RDEPENDS:${PN} = "bash"
82 82
83FILES:${PN}-dbg += "/unit_tests/.debug" 83FILES:${PN}-dbg += "/unit_tests/.debug"