summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzakariazh <zidouhzakaria@gmail.com>2020-12-22 00:00:18 +0100
committerOtavio Salvador <otavio@ossystems.com.br>2021-01-26 19:52:42 -0300
commit61fac5961bcfa74a06f5f5a5a1ac406d52cd4b5b (patch)
tree672892f6ee136c69d8ae9fe7bb1d97d3909df7fe
parent4472b32f67c4e293e218fb1cc5741728f98e3421 (diff)
downloadmeta-freescale-61fac5961bcfa74a06f5f5a5a1ac406d52cd4b5b.tar.gz
gstreamer1.0-plugins-bad: Let processors with pxp chose the correct Opengl API
The processors without gpu (imx6ul/imx6ull) support only opengl-es.The system must be able to chose the correct API instead of forcing it for all processors. Signed-off-by: ZIDOUH Zakaria <zakaria.zidouh@gmail.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
index 3dc7cbf8..b37c066e 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
@@ -36,12 +36,15 @@ DEPENDS += "gstreamer1.0-plugins-base"
36 36
37inherit gobject-introspection 37inherit gobject-introspection
38 38
39PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)}"
40PACKAGECONFIG_GL_imxpxp = "gles2"
41
39PACKAGECONFIG ??= " \ 42PACKAGECONFIG ??= " \
40 ${GSTREAMER_ORC} \ 43 ${GSTREAMER_ORC} \
41 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ 44 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
42 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \ 45 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
43 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ 46 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
44 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \ 47 ${PACKAGECONFIG_GL} \
45 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \ 48 bz2 closedcaption curl dash dtls hls rsvg sbc smoothstreaming sndfile \
46 ttml uvch264 webp \ 49 ttml uvch264 webp \
47" 50"
@@ -63,6 +66,7 @@ PACKAGECONFIG[hls] = "-Dhls=enabled -Dhls-crypto=nettle,-Dhls=disabl
63# to -base yet. They depend on the gstgl library in -base, so we do 66# to -base yet. They depend on the gstgl library in -base, so we do
64# not add GL dependencies here, since these are taken care of in -base. 67# not add GL dependencies here, since these are taken care of in -base.
65PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled," 68PACKAGECONFIG[gl] = "-Dgl=enabled,-Dgl=disabled,"
69PACKAGECONFIG[gles2] = ",,virtual/libgles2"
66PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm" 70PACKAGECONFIG[kms] = "-Dkms=enabled,-Dkms=disabled,libdrm"
67PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265" 71PACKAGECONFIG[libde265] = "-Dlibde265=enabled,-Dlibde265=disabled,libde265"
68PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms" 72PACKAGECONFIG[libmms] = "-Dlibmms=enabled,-Dlibmms=disabled,libmms"