summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2016-07-15 00:11:02 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2016-07-15 07:45:44 -0300
commit5c8a34a2beaf614220bc1d2317609892be34ef40 (patch)
tree3b69568af6a90aa298d4fbcfb49c97c5aef8c2f8
parent475db5fb311baef8baa713ce8bb33c6154b8ab73 (diff)
downloadmeta-freescale-5c8a34a2beaf614220bc1d2317609892be34ef40.tar.gz
ipc-ust: not use IPC_UST_SOC variable
bsc913x are not supported now. Signed-off-by: Ting Liu <ting.liu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/include/qoriq-base.inc4
-rw-r--r--recipes-extended/ipc-ust/ipc-ust_git.bb11
-rw-r--r--recipes-extended/ipc-ust/ipc.inc2
3 files changed, 2 insertions, 15 deletions
diff --git a/conf/machine/include/qoriq-base.inc b/conf/machine/include/qoriq-base.inc
index 8b2b0c7d..c5cbe299 100644
--- a/conf/machine/include/qoriq-base.inc
+++ b/conf/machine/include/qoriq-base.inc
@@ -20,8 +20,4 @@ MACHINE_EXTRA_RRECOMMENDS ?= "udev-rules-qoriq"
20 20
21EXTRA_IMAGEDEPENDS += "u-boot cst-native" 21EXTRA_IMAGEDEPENDS += "u-boot cst-native"
22 22
23IPC_UST_SOC_bsc9131 = "B913x"
24IPC_UST_SOC_bsc9132 = "B913x"
25IPC_UST_SOC_b4 = "B4860"
26
27MACHINEOVERRIDES =. "qoriq:" 23MACHINEOVERRIDES =. "qoriq:"
diff --git a/recipes-extended/ipc-ust/ipc-ust_git.bb b/recipes-extended/ipc-ust/ipc-ust_git.bb
index 23350b3c..d8ade4e6 100644
--- a/recipes-extended/ipc-ust/ipc-ust_git.bb
+++ b/recipes-extended/ipc-ust/ipc-ust_git.bb
@@ -5,21 +5,12 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=fa38cd73d71527dc6efb546474f64d10"
5 5
6require ipc.inc 6require ipc.inc
7 7
8python () {
9 if not d.getVar("IPC_UST_SOC", True):
10 raise bb.parse.SkipPackage("IPC_UST_SOC is not defined in qoriq-base.inc")
11}
12
13S = "${WORKDIR}/git" 8S = "${WORKDIR}/git"
14 9
15# workaround for issue of parallel build, required a actual fix in ipc source 10# workaround for issue of parallel build, required a actual fix in ipc source
16PARALLEL_MAKE = "" 11PARALLEL_MAKE = ""
17 12
18EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}"' 13EXTRA_OEMAKE = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC}" AR="${AR}" B4860=1'
19
20do_compile () {
21 oe_runmake ${IPC_UST_SOC}=1
22}
23 14
24do_install () { 15do_install () {
25 install -d ${D}${bindir} 16 install -d ${D}${bindir}
diff --git a/recipes-extended/ipc-ust/ipc.inc b/recipes-extended/ipc-ust/ipc.inc
index 0ccbba41..59d069bb 100644
--- a/recipes-extended/ipc-ust/ipc.inc
+++ b/recipes-extended/ipc-ust/ipc.inc
@@ -3,4 +3,4 @@ DEPENDS = "virtual/kernel"
3SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;branch=sdk-v2.0.x" 3SRC_URI = "git://git.freescale.com/ppc/sdk/ipc.git;branch=sdk-v2.0.x"
4SRCREV = "74d662707558290f070f9589177db730444bc435" 4SRCREV = "74d662707558290f070f9589177db730444bc435"
5 5
6COMPATIBLE_MACHINE = "(bsc9132qds|bsc9131rdb|b4860qds|b4420qds)" 6COMPATIBLE_MACHINE = "(b4860qds|b4420qds)"