summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-11-04 10:04:43 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-11-04 09:39:30 -0300
commit5c0fd24a5d8889690936e5b01e2cc7f527d5d575 (patch)
tree96844997069893626a8d2d957f989f9d42cce0aa
parentf064573fbe25d977271e18f93b16f2fa4bba3081 (diff)
downloadmeta-freescale-5c0fd24a5d8889690936e5b01e2cc7f527d5d575.tar.gz
gstreamer1.0-plugins-bad: fix vulkan compilation error
VK_RESULT_BEGIN_RANGE has been removed in Vulkan headers, and corresponding patch has been introduced in GStreamer. Backport patch from upstream GStreamer to NXP fork to address compilation error for Vulkan. Cc: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch51
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
new file mode 100644
index 00000000..5b8e0159
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch
@@ -0,0 +1,51 @@
1From 54c700f9721ef218188803b48acae46e885626ee Mon Sep 17 00:00:00 2001
2From: "Jan Alexander Steffens (heftig)" <jan.steffens@ltnglobal.com>
3Date: Sat, 9 May 2020 19:59:46 +0200
4Subject: [PATCH] vulkan: Drop use of VK_RESULT_BEGIN_RANGE
5
6This was removed in Vulkan 1.2.140.
7
8> Shortly after 2020-04-24, we will be removing the automatically
9> generated `VK_*_BEGIN_RANGE`, `VK_*_END_RANGE`, and `VK_*_RANGE_SIZE`
10> tokens from the Vulkan headers. These tokens are currently defined for
11> some enumerated types, but are explicitly not part of the Vulkan API.
12> They existed only to support some Vulkan implementation internals,
13> which no longer require them. We will be accepting comments on this
14> topic in [#1230], but we strongly suggest any external projects using
15> these tokens immediately migrate away from them.
16
17[#1230]: https://github.com/KhronosGroup/Vulkan-Docs/issues/1230
18
19Part-of: <https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/merge_requests/1603>
20
21Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/17850d7e87af93c6bd181d7c25903478c2254fa6]
22Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
23---
24 ext/vulkan/vkerror.c | 4 +---
25 1 file changed, 1 insertion(+), 3 deletions(-)
26
27diff --git a/ext/vulkan/vkerror.c b/ext/vulkan/vkerror.c
28index 3fec27e4d..c91589d9b 100644
29--- a/ext/vulkan/vkerror.c
30+++ b/ext/vulkan/vkerror.c
31@@ -27,7 +27,7 @@
32 #include "vkerror.h"
33
34 /* *INDENT-OFF* */
35-static const struct
36+static const struct
37 {
38 VkResult result;
39 const char *str;
40@@ -63,8 +63,6 @@ _vk_result_to_string (VkResult result)
41
42 if (result >= 0)
43 return NULL;
44- if (result < VK_RESULT_BEGIN_RANGE)
45- return "Unknown Error";
46
47 for (i = 0; i < G_N_ELEMENTS (vk_result_string_map); i++) {
48 if (result == vk_result_string_map[i].result)
49--
502.17.1
51
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
index 68689f90..25186751 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
@@ -19,6 +19,7 @@ SRC_URI = " \
19 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ 19 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
20 file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ 20 file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
21 file://0001-opencv-allow-compilation-against-4.4.x.patch \ 21 file://0001-opencv-allow-compilation-against-4.4.x.patch \
22 file://0001-vulkan-Drop-use-of-VK_RESULT_BEGIN_RANGE.patch \
22 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \ 23 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
23 file://avoid-including-sys-poll.h-directly.patch \ 24 file://avoid-including-sys-poll.h-directly.patch \
24 file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \ 25 file://ensure-valid-sentinels-for-gst_structure_get-etc.patch \