summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-11-22 16:12:08 -0800
committerOtavio Salvador <otavio@ossystems.com.br>2019-11-23 12:17:02 -0300
commit568cbe036682365dce556e1cb4b8059e907a65a6 (patch)
tree1e4c050c0a650cb98a0baf6cf7d0467eafdb3418
parent0be39721cea6e04c589a419f4bb07fabd0da6704 (diff)
downloadmeta-freescale-568cbe036682365dce556e1cb4b8059e907a65a6.tar.gz
recipes: Use features_check instead of distro_features_check
distro_features_check is now deprecated Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--classes/qoriq_build_64bit_kernel.bbclass2
-rw-r--r--recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc2
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/classes/qoriq_build_64bit_kernel.bbclass b/classes/qoriq_build_64bit_kernel.bbclass
index ffa67c8c..93b4d412 100644
--- a/classes/qoriq_build_64bit_kernel.bbclass
+++ b/classes/qoriq_build_64bit_kernel.bbclass
@@ -1,4 +1,4 @@
1inherit distro_features_check 1inherit features_check
2REQUIRED_DISTRO_FEATURES_e6500 += "multiarch" 2REQUIRED_DISTRO_FEATURES_e6500 += "multiarch"
3 3
4python () { 4python () {
diff --git a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
index 2c61c101..43d86ef2 100644
--- a/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
+++ b/recipes-graphics/imx-gpu-viv/imx-gpu-viv-6.inc
@@ -52,7 +52,7 @@ RPROVIDES_${PN}_imxgpu3d += "imx-gpu-viv"
52 52
53PE = "1" 53PE = "1"
54 54
55inherit fsl-eula-unpack distro_features_check 55inherit fsl-eula-unpack features_check
56 56
57REQUIRED_DISTRO_FEATURES_mx8 = "wayland" 57REQUIRED_DISTRO_FEATURES_mx8 = "wayland"
58 58
diff --git a/recipes-graphics/wayland/weston_5.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index 270aa2ad..a7778b41 100644
--- a/recipes-graphics/wayland/weston_5.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -21,7 +21,7 @@ S = "${WORKDIR}/git"
21 21
22UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" 22UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"
23 23
24inherit autotools pkgconfig useradd distro_features_check 24inherit autotools pkgconfig useradd features_check
25 25
26# Disable OpenGL for parts with GPU support for 2D but not 3D 26# Disable OpenGL for parts with GPU support for 2D but not 3D
27REQUIRED_DISTRO_FEATURES = "opengl" 27REQUIRED_DISTRO_FEATURES = "opengl"