summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuqing Zhu <carol.zhu@nxp.com>2018-08-06 17:23:33 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2018-09-07 17:30:35 -0300
commit5439a57ad5abb6c2b7b12db414b739cec74c2662 (patch)
tree384e3daa924917e6bbef6df0aeeabaa2dfd63b83
parent68a53a2de31bc3ecfb36d9a7fc9b935548114f0f (diff)
downloadmeta-freescale-5439a57ad5abb6c2b7b12db414b739cec74c2662.tar.gz
gstreamer1.0-plugins-bad: Upgrade to v1.14.imx
Add GST_EXPORT APIs for GST1.14 kmssink: Add HDR10 support Add hdr metadata reset when exit playback Add fps print when exit Add alignment for video src crop size for dpu waylandsink: Add fps print Support video crop meta using viewporter protocol Pass dmabuf modifier to weston Hard code scale ratio for i.mx8qxp instead of using setplane to try scale ratio as its upscale has no limitation Update patch to fix applying conflict Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.12.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch74
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch45
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch61
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb (renamed from recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.12.imx.bb)82
4 files changed, 134 insertions, 128 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.12.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.12.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
deleted file mode 100644
index 8d99dc6c..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.12.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
+++ /dev/null
@@ -1,74 +0,0 @@
1From 7592e793b3906355d76ca9a59f8fea2749ea2a4e Mon Sep 17 00:00:00 2001
2From: Alexander Kanavin <alex.kanavin@gmail.com>
3Date: Tue, 27 Oct 2015 14:36:58 +0200
4Subject: [PATCH] Makefile.am: don't hardcode libtool name when running
5 introspection tools
6
7Upstream-Status: Pending [review on oe-core list]
8Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com>
9
10%% original patch: 0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
11
12Signed-off-by: Maxin B. John <maxin.john@intel.com>
13---
14 gst-libs/gst/allocators/Makefile.am | 2 +-
15 gst-libs/gst/gl/Makefile.am | 2 +-
16 gst-libs/gst/insertbin/Makefile.am | 2 +-
17 gst-libs/gst/mpegts/Makefile.am | 2 +-
18 4 files changed, 4 insertions(+), 4 deletions(-)
19
20diff --git a/gst-libs/gst/allocators/Makefile.am b/gst-libs/gst/allocators/Makefile.am
21index e50d077..623f092 100644
22--- a/gst-libs/gst/allocators/Makefile.am
23+++ b/gst-libs/gst/allocators/Makefile.am
24@@ -37,7 +37,7 @@ GstBadAllocators-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstbadalloca
25 --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-@GST_API_VERSION@` \
26 --library=libgstbadallocators-@GST_API_VERSION@.la \
27 --include=Gst-@GST_API_VERSION@ \
28- --libtool="$(top_builddir)/libtool" \
29+ --libtool="$(LIBTOOL)" \
30 --pkg gstreamer-@GST_API_VERSION@ \
31 --pkg-export gstreamer-badallocators-@GST_API_VERSION@ \
32 --output $@ \
33diff --git a/gst-libs/gst/gl/Makefile.am b/gst-libs/gst/gl/Makefile.am
34index 2ae4773..dfa7a7d 100644
35--- a/gst-libs/gst/gl/Makefile.am
36+++ b/gst-libs/gst/gl/Makefile.am
37@@ -178,7 +178,7 @@ GstGL-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstgl-@GST_API_VERSION@
38 --include=Gst-@GST_API_VERSION@ \
39 --include=GstBase-@GST_API_VERSION@ \
40 --include=GstVideo-@GST_API_VERSION@ \
41- --libtool="$(top_builddir)/libtool" \
42+ --libtool="$(LIBTOOL)" \
43 --pkg gstreamer-@GST_API_VERSION@ \
44 --pkg gstreamer-base-@GST_API_VERSION@ \
45 --pkg gstreamer-video-@GST_API_VERSION@ \
46diff --git a/gst-libs/gst/insertbin/Makefile.am b/gst-libs/gst/insertbin/Makefile.am
47index 1f8ea30..4b98ef6 100644
48--- a/gst-libs/gst/insertbin/Makefile.am
49+++ b/gst-libs/gst/insertbin/Makefile.am
50@@ -45,7 +45,7 @@ GstInsertBin-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstinsertbin-@GS
51 --library=libgstinsertbin-@GST_API_VERSION@.la \
52 --include=Gst-@GST_API_VERSION@ \
53 --include=GstBase-@GST_API_VERSION@ \
54- --libtool="$(top_builddir)/libtool" \
55+ --libtool="$(LIBTOOL)" \
56 --pkg gstreamer-@GST_API_VERSION@ \
57 --pkg gstreamer-base-@GST_API_VERSION@ \
58 --pkg-export gstreamer-insertbin-@GST_API_VERSION@ \
59diff --git a/gst-libs/gst/mpegts/Makefile.am b/gst-libs/gst/mpegts/Makefile.am
60index aeea32e..929d9cc 100644
61--- a/gst-libs/gst/mpegts/Makefile.am
62+++ b/gst-libs/gst/mpegts/Makefile.am
63@@ -79,7 +79,7 @@ GstMpegts-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstmpegts-@GST_API_
64 --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-video-@GST_API_VERSION@` \
65 --library=libgstmpegts-@GST_API_VERSION@.la \
66 --include=Gst-@GST_API_VERSION@ \
67- --libtool="$(top_builddir)/libtool" \
68+ --libtool="$(LIBTOOL)" \
69 --pkg gstreamer-@GST_API_VERSION@ \
70 --pkg gstreamer-video-@GST_API_VERSION@ \
71 --pkg-export gstreamer-mpegts-@GST_API_VERSION@ \
72--
732.4.0
74
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
new file mode 100644
index 00000000..355341e4
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch
@@ -0,0 +1,45 @@
1From c890afb8a542a272acb398e8fc289b790afa08e4 Mon Sep 17 00:00:00 2001
2From: Yuqing Zhu <carol.zhu@nxp.com>
3Date: Sat, 21 Apr 2018 00:51:12 +0800
4Subject: [PATCH] Makefile.am: don't hardcode libtool name when running
5 introspection tools
6
7Do refine base on commit: 7592e793b3906355d76ca9a59f8fea2749ea2a4e
8
9Upstream-Status: Pending [review on oe-core list]
10
11Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
12---
13 gst-libs/gst/insertbin/Makefile.am | 2 +-
14 gst-libs/gst/mpegts/Makefile.am | 2 +-
15 2 files changed, 2 insertions(+), 2 deletions(-)
16
17diff --git a/gst-libs/gst/insertbin/Makefile.am b/gst-libs/gst/insertbin/Makefile.am
18index 1f8ea30..4b98ef6 100644
19--- a/gst-libs/gst/insertbin/Makefile.am
20+++ b/gst-libs/gst/insertbin/Makefile.am
21@@ -45,7 +45,7 @@ GstInsertBin-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstinsertbin-@GS
22 --library=libgstinsertbin-@GST_API_VERSION@.la \
23 --include=Gst-@GST_API_VERSION@ \
24 --include=GstBase-@GST_API_VERSION@ \
25- --libtool="$(top_builddir)/libtool" \
26+ --libtool="$(LIBTOOL)" \
27 --pkg gstreamer-@GST_API_VERSION@ \
28 --pkg gstreamer-base-@GST_API_VERSION@ \
29 --pkg-export gstreamer-insertbin-@GST_API_VERSION@ \
30diff --git a/gst-libs/gst/mpegts/Makefile.am b/gst-libs/gst/mpegts/Makefile.am
31index f264e33..9934a4d 100644
32--- a/gst-libs/gst/mpegts/Makefile.am
33+++ b/gst-libs/gst/mpegts/Makefile.am
34@@ -82,7 +82,7 @@ GstMpegts-@GST_API_VERSION@.gir: $(INTROSPECTION_SCANNER) libgstmpegts-@GST_API_
35 --add-include-path=`PKG_CONFIG_PATH="$(GST_PKG_CONFIG_PATH)" $(PKG_CONFIG) --variable=girdir gstreamer-video-@GST_API_VERSION@` \
36 --library=libgstmpegts-@GST_API_VERSION@.la \
37 --include=Gst-@GST_API_VERSION@ \
38- --libtool="$(top_builddir)/libtool" \
39+ --libtool="$(LIBTOOL)" \
40 --pkg gstreamer-@GST_API_VERSION@ \
41 --pkg gstreamer-video-@GST_API_VERSION@ \
42 --pkg-export gstreamer-mpegts-@GST_API_VERSION@ \
43--
442.7.4
45
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch
new file mode 100644
index 00000000..ad863298
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad-1.14.imx/configure-allow-to-disable-libssh2.patch
@@ -0,0 +1,61 @@
1From f59c5269f92d59a5296cbfeeb682d42095cd88ad Mon Sep 17 00:00:00 2001
2From: Wenzong Fan <wenzong.fan@windriver.com>
3Date: Thu, 18 Sep 2014 02:24:07 -0400
4Subject: [PATCH] gstreamer1.0-plugins-bad: allow to disable libssh2
5
6libssh2 is automatically linked to if present, this undetermined
7dependency may cause build errors like:
8
9 .../x86_64-poky-linux/4.9.0/ld: cannot find -lssh2
10
11libssh2 isn't an oe-core recipe, so allow to disable it from
12configure.
13
14Upstream-Status: Pending
15
16Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
17---
18 configure.ac | 23 +++++++++++++++++------
19 1 file changed, 17 insertions(+), 6 deletions(-)
20
21Index: gst-plugins-bad-1.12.3/configure.ac
22===================================================================
23--- gst-plugins-bad-1.12.3.orig/configure.ac
24+++ gst-plugins-bad-1.12.3/configure.ac
25@@ -2139,6 +2139,15 @@ AG_GST_CHECK_FEATURE(CHROMAPRINT, [chrom
26 ])
27
28 dnl *** Curl ***
29+AC_ARG_ENABLE([libssh2],
30+ [ --enable-libssh2 enable LIBSSH2 support @<:@default=auto@:>@],
31+ [case "${enableval}" in
32+ yes) NEED_SSH2=yes ;;
33+ no) NEED_SSH2=no ;;
34+ auto) NEED_SSH2=auto ;;
35+ *) AC_MSG_ERROR([bad value ${enableval} for --enable-libssh2]) ;;
36+ esac],[NEED_SSH2=auto])
37+
38 translit(dnm, m, l) AM_CONDITIONAL(USE_CURL, true)
39 AG_GST_CHECK_FEATURE(CURL, [Curl plugin], curl, [
40 PKG_CHECK_MODULES(CURL, libcurl >= 7.35.0, [
41@@ -2161,12 +2170,14 @@ AG_GST_CHECK_FEATURE(CURL, [Curl plugin]
42 ])
43 AC_SUBST(CURL_CFLAGS)
44 AC_SUBST(CURL_LIBS)
45- PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
46- HAVE_SSH2="yes"
47- AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
48- ], [
49- HAVE_SSH2="no"
50- ])
51+ if test "x$NEED_SSH2" != "xno"; then
52+ PKG_CHECK_MODULES(SSH2, libssh2 >= 1.4.3, [
53+ HAVE_SSH2="yes"
54+ AC_DEFINE(HAVE_SSH2, 1, [Define if libssh2 is available])
55+ ], [
56+ HAVE_SSH2="no"
57+ ])
58+ fi
59 AM_CONDITIONAL(USE_SSH2, test "x$HAVE_SSH2" = "xyes")
60 AC_SUBST(SSH2_CFLAGS)
61 AC_SUBST(SSH2_LIBS)
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.12.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
index b5623ed0..313d4da1 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.12.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.14.imx.bb
@@ -6,35 +6,26 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=73a5855a8119deb017f5f13cf327095d \
6DEPENDS_append_imxgpu2d = " virtual/libg2d" 6DEPENDS_append_imxgpu2d = " virtual/libg2d"
7DEPENDS_append_mx8 = " libdrm" 7DEPENDS_append_mx8 = " libdrm"
8 8
9PACKAGECONFIG_GL_imxgpu2d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl x11', 'opengl', '', d)}"
10PACKAGECONFIG_GL_imxgpu3d = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
11
12PACKAGECONFIG_append_mx6q = " opencv" 9PACKAGECONFIG_append_mx6q = " opencv"
13PACKAGECONFIG_append_mx6qp = " opencv" 10PACKAGECONFIG_append_mx6qp = " opencv"
14PACKAGECONFIG_append_mx8 = " opencv kms" 11PACKAGECONFIG_append_mx8 = " opencv kms"
15PACKAGECONFIG_remove_mx6sl = " gles2"
16 12
17#revert poky fido commit:cdc2c8aeaa96b07dfc431a4cf0bf51ef7f8802a3: move EGL to Wayland
18PACKAGECONFIG[gles2] = "--enable-gles2 --enable-egl,--disable-gles2 --disable-egl,virtual/libgles2 virtual/egl"
19PACKAGECONFIG[wayland] = "--enable-wayland --disable-x11,--disable-wayland,wayland-native wayland wayland-protocols libdrm" 13PACKAGECONFIG[wayland] = "--enable-wayland --disable-x11,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
20 14
21# Disable introspection to fix [GstGL-1.0.gir] Error 15# Disable introspection to fix [GstGL-1.0.gir] Error
22EXTRA_OECONF_append = " --disable-introspection" 16EXTRA_OECONF_append = " --disable-introspection"
23 17
24EXTRA_OECONF_remove = " --disable-sdl --disable-nas --disable-libvisual --disable-xvid --disable-mimic \
25 --disable-pvr --disable-sdltest --disable-wininet --disable-timidity \
26 --disable-linsys --disable-sndio --disable-apexsink --disable-libssh2 \
27"
28 18
29GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https" 19GST1.0-PLUGINS-BAD_SRC ?= "gitsm://source.codeaurora.org/external/imx/gst-plugins-bad.git;protocol=https"
30SRCBRANCH = "MM_04.03.05_1804_L4.9.88_MX7ULP_GA" 20SRCBRANCH = "MM_04.04.00_1805_L4.9.88_MX8QXP_BETA2"
31 21
32SRC_URI = " \ 22SRC_URI = " \
33 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \ 23 ${GST1.0-PLUGINS-BAD_SRC};branch=${SRCBRANCH} \
24 file://configure-allow-to-disable-libssh2.patch \
34 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \ 25 file://0001-Makefile.am-don-t-hardcode-libtool-name-when-running.patch \
35" 26"
36 27
37SRCREV = "3bf09ef9cda8220b53459b45fe5384a99a7b1c6b" 28SRCREV = "07ad0bb676a16c2dffb0f0e415a873f0924cfdc0"
38 29
39DEFAULT_PREFERENCE = "-1" 30DEFAULT_PREFERENCE = "-1"
40 31
@@ -48,33 +39,27 @@ FILES_${PN}-opengl += "/usr/share/*.fs"
48PACKAGE_ARCH_imxpxp = "${MACHINE_SOCARCH}" 39PACKAGE_ARCH_imxpxp = "${MACHINE_SOCARCH}"
49PACKAGE_ARCH_mx8 = "${MACHINE_SOCARCH}" 40PACKAGE_ARCH_mx8 = "${MACHINE_SOCARCH}"
50 41
51# Fix libgstbadion-1.0.so.0 which is under built directory cannot be found
52do_compile_prepend () {
53 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/ion/.libs"
54}
55
56S = "${WORKDIR}/git" 42S = "${WORKDIR}/git"
57 43
58LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+" 44LICENSE = "GPLv2+ & LGPLv2+ & LGPLv2.1+"
59 45
60DEPENDS += "gstreamer1.0-plugins-base libpng jpeg" 46DEPENDS += "gstreamer1.0-plugins-base jpeg"
61 47
62inherit gettext bluetooth 48inherit gettext bluetooth
63 49
64# opengl packageconfig factored out to make it easy for distros
65# and BSP layers to pick either (desktop) opengl, gles2, or no GL
66PACKAGECONFIG_GL ?= "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2 egl', '', d)}"
67
68# gtk is not in the PACKAGECONFIG variable by default until
69# the transition to gtk+3 is finished
70PACKAGECONFIG ??= " \ 50PACKAGECONFIG ??= " \
71 ${GSTREAMER_ORC} \ 51 ${GSTREAMER_ORC} \
72 ${PACKAGECONFIG_GL} \
73 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ 52 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
74 ${@bb.utils.contains('DISTRO_FEATURES', 'directfb', 'directfb', '', d)} \ 53 ${@bb.utils.filter('DISTRO_FEATURES', 'directfb vulkan', d)} \
75 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland egl', '', d)} \ 54 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \
76 bz2 curl dash dtls hls rsvg sbc smoothstreaming sndfile uvch264 webp \ 55 ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gl', '', d)} \
56 bz2 curl dash dtls hls rsvg sbc smoothstreaming sndfile ttml uvch264 webp \
77" 57"
58
59# the gl packageconfig enables OpenGL elements that haven't been ported
60# to -base yet. They depend on the gstgl library in -base, so we do
61# not add GL dependencies here, since these are taken care of in -base.
62
78PACKAGECONFIG[assrender] = "--enable-assrender,--disable-assrender,libass" 63PACKAGECONFIG[assrender] = "--enable-assrender,--disable-assrender,libass"
79PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,${BLUEZ}" 64PACKAGECONFIG[bluez] = "--enable-bluez,--disable-bluez,${BLUEZ}"
80PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2" 65PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
@@ -83,22 +68,21 @@ PACKAGECONFIG[dash] = "--enable-dash,--disable-dash,libxml2"
83PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394" 68PACKAGECONFIG[dc1394] = "--enable-dc1394,--disable-dc1394,libdc1394"
84PACKAGECONFIG[directfb] = "--enable-directfb,--disable-directfb,directfb" 69PACKAGECONFIG[directfb] = "--enable-directfb,--disable-directfb,directfb"
85PACKAGECONFIG[dtls] = "--enable-dtls,--disable-dtls,openssl" 70PACKAGECONFIG[dtls] = "--enable-dtls,--disable-dtls,openssl"
86PACKAGECONFIG[egl] = "--enable-egl,--disable-egl,virtual/egl"
87PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac" 71PACKAGECONFIG[faac] = "--enable-faac,--disable-faac,faac"
88PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2" 72PACKAGECONFIG[faad] = "--enable-faad,--disable-faad,faad2"
89PACKAGECONFIG[flite] = "--enable-flite,--disable-flite,flite-alsa" 73PACKAGECONFIG[flite] = "--enable-flite,--disable-flite,flite-alsa"
90PACKAGECONFIG[fluidsynth] = "--enable-fluidsynth,--disable-fluidsynth,fluidsynth" 74PACKAGECONFIG[fluidsynth] = "--enable-fluidsynth,--disable-fluidsynth,fluidsynth"
91PACKAGECONFIG[gles2] = "--enable-gles2,--disable-gles2,virtual/libgles2"
92PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
93PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=nettle,--disable-hls,nettle" 75PACKAGECONFIG[hls] = "--enable-hls --with-hls-crypto=nettle,--disable-hls,nettle"
76PACKAGECONFIG[gl] = "--enable-gl,--disable-gl,"
94PACKAGECONFIG[kms] = "--enable-kms,--disable-kms,libdrm" 77PACKAGECONFIG[kms] = "--enable-kms,--disable-kms,libdrm"
78PACKAGECONFIG[libde265] = "--enable-libde265,--disable-libde265,libde265"
95PACKAGECONFIG[libmms] = "--enable-libmms,--disable-libmms,libmms" 79PACKAGECONFIG[libmms] = "--enable-libmms,--disable-libmms,libmms"
96PACKAGECONFIG[libssh2] = "--enable-libssh2,--disable-libssh2,libssh2" 80PACKAGECONFIG[libssh2] = "--enable-libssh2,--disable-libssh2,libssh2"
97PACKAGECONFIG[modplug] = "--enable-modplug,--disable-modplug,libmodplug" 81PACKAGECONFIG[modplug] = "--enable-modplug,--disable-modplug,libmodplug"
98PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon" 82PACKAGECONFIG[neon] = "--enable-neon,--disable-neon,neon"
99PACKAGECONFIG[openal] = "--enable-openal,--disable-openal,openal-soft" 83PACKAGECONFIG[openal] = "--enable-openal,--disable-openal,openal-soft"
100PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv" 84PACKAGECONFIG[opencv] = "--enable-opencv,--disable-opencv,opencv"
101PACKAGECONFIG[opengl] = "--enable-opengl,--disable-opengl,virtual/libgl libglu" 85PACKAGECONFIG[openh264] = "--enable-openh264,--disable-openh264,openh264"
102PACKAGECONFIG[openjpeg] = "--enable-openjpeg,--disable-openjpeg,openjpeg" 86PACKAGECONFIG[openjpeg] = "--enable-openjpeg,--disable-openjpeg,openjpeg"
103# the opus encoder/decoder elements are now in the -base package, 87# the opus encoder/decoder elements are now in the -base package,
104# but the opus parser remains in -bad 88# but the opus parser remains in -bad
@@ -107,41 +91,41 @@ PACKAGECONFIG[resindvd] = "--enable-resindvd,--disable-resindvd,libdvdrea
107PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg" 91PACKAGECONFIG[rsvg] = "--enable-rsvg,--disable-rsvg,librsvg"
108PACKAGECONFIG[rtmp] = "--enable-rtmp,--disable-rtmp,rtmpdump" 92PACKAGECONFIG[rtmp] = "--enable-rtmp,--disable-rtmp,rtmpdump"
109PACKAGECONFIG[sbc] = "--enable-sbc,--disable-sbc,sbc" 93PACKAGECONFIG[sbc] = "--enable-sbc,--disable-sbc,sbc"
110PACKAGECONFIG[schroedinger] = "--enable-schro,--disable-schro,schroedinger"
111PACKAGECONFIG[smoothstreaming] = "--enable-smoothstreaming,--disable-smoothstreaming,libxml2" 94PACKAGECONFIG[smoothstreaming] = "--enable-smoothstreaming,--disable-smoothstreaming,libxml2"
112PACKAGECONFIG[sndfile] = "--enable-sndfile,--disable-sndfile,libsndfile1" 95PACKAGECONFIG[sndfile] = "--enable-sndfile,--disable-sndfile,libsndfile1"
113PACKAGECONFIG[srtp] = "--enable-srtp,--disable-srtp,libsrtp" 96PACKAGECONFIG[srtp] = "--enable-srtp,--disable-srtp,libsrtp"
97PACKAGECONFIG[tinyalsa] = "--enable-tinyalsa,--disable-tinyalsa,tinyalsa"
98PACKAGECONFIG[ttml] = "--enable-ttml,--disable-ttml,libxml2 pango cairo"
114PACKAGECONFIG[uvch264] = "--enable-uvch264,--disable-uvch264,libusb1 libgudev" 99PACKAGECONFIG[uvch264] = "--enable-uvch264,--disable-uvch264,libusb1 libgudev"
115PACKAGECONFIG[voaacenc] = "--enable-voaacenc,--disable-voaacenc,vo-aacenc" 100PACKAGECONFIG[voaacenc] = "--enable-voaacenc,--disable-voaacenc,vo-aacenc"
116PACKAGECONFIG[voamrwbenc] = "--enable-voamrwbenc,--disable-voamrwbenc,vo-amrwbenc" 101PACKAGECONFIG[voamrwbenc] = "--enable-voamrwbenc,--disable-voamrwbenc,vo-amrwbenc"
102PACKAGECONFIG[vulkan] = "--enable-vulkan,--disable-vulkan,vulkan"
117PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm" 103PACKAGECONFIG[wayland] = "--enable-wayland,--disable-wayland,wayland-native wayland wayland-protocols libdrm"
118PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp" 104PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp"
105PACKAGECONFIG[webrtc] = "--enable-webrtc,--disable-webrtc,libnice"
106PACKAGECONFIG[webrtcdsp] = "--enable-webrtcdsp,--disable-webrtcdsp,webrtc-audio-processing"
119 107
120# these plugins have no corresponding library in OE-core or meta-openembedded: 108# these plugins have no corresponding library in OE-core or meta-openembedded:
121# openni2 winks direct3d directsound winscreencap acm apple_media iqa 109# openni2 winks direct3d directsound winscreencap acm apple_media iqa
122# android_media avc bs2b chromaprint daala dts fdkaac gme gsm kate ladspa libde265 110# android_media avc bs2b chromaprint daala dts fdkaac gme gsm kate ladspa
123# lv2 mpeg2enc mplex msdk musepack nvenc ofa openh264 opensles soundtouch spandsp 111# lv2 mpeg2enc mplex msdk musepack nvenc ofa openmpt opensles soundtouch
124# spc teletextdec tinyalsa vdpau wasapi x265 zbar webrtcdsp 112# spandsp spc teletextdec vdpau wasapi x265 zbar
125
126# qt5 support is disabled, because it is not present in OE core, and requires more work than
127# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
128# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
129# in a gstreamer1.0-plugins-bad bbappend).
130 113
131EXTRA_OECONF += " \ 114EXTRA_OECONF += " \
132 --enable-decklink \ 115 --enable-decklink \
133 --enable-dvb \ 116 --enable-dvb \
134 --enable-fbdev \ 117 --enable-fbdev \
118 --enable-ipcpipeline \
135 --enable-netsim \ 119 --enable-netsim \
136 --enable-shm \ 120 --enable-shm \
137 --enable-vcd \ 121 --enable-vcd \
138 --disable-acm \ 122 --disable-acm \
139 --disable-android_media \ 123 --disable-android_media \
124 --disable-aom \
140 --disable-apple_media \ 125 --disable-apple_media \
141 --disable-avc \ 126 --disable-avc \
142 --disable-bs2b \ 127 --disable-bs2b \
143 --disable-chromaprint \ 128 --disable-chromaprint \
144 --disable-cocoa \
145 --disable-daala \ 129 --disable-daala \
146 --disable-direct3d \ 130 --disable-direct3d \
147 --disable-directsound \ 131 --disable-directsound \
@@ -152,7 +136,6 @@ EXTRA_OECONF += " \
152 --disable-iqa \ 136 --disable-iqa \
153 --disable-kate \ 137 --disable-kate \
154 --disable-ladspa \ 138 --disable-ladspa \
155 --disable-libde265 \
156 --disable-lv2 \ 139 --disable-lv2 \
157 --disable-mpeg2enc \ 140 --disable-mpeg2enc \
158 --disable-mplex \ 141 --disable-mplex \
@@ -161,19 +144,16 @@ EXTRA_OECONF += " \
161 --disable-nvenc \ 144 --disable-nvenc \
162 --disable-ofa \ 145 --disable-ofa \
163 --disable-openexr \ 146 --disable-openexr \
164 --disable-openh264 \ 147 --disable-openmpt \
165 --disable-openni2 \ 148 --disable-openni2 \
166 --disable-opensles \ 149 --disable-opensles \
167 --disable-qt \
168 --disable-soundtouch \ 150 --disable-soundtouch \
169 --disable-spandsp \ 151 --disable-spandsp \
170 --disable-spc \ 152 --disable-spc \
153 --disable-srt \
171 --disable-teletextdec \ 154 --disable-teletextdec \
172 --disable-tinyalsa \
173 --disable-vdpau \ 155 --disable-vdpau \
174 --disable-vulkan \
175 --disable-wasapi \ 156 --disable-wasapi \
176 --disable-webrtcdsp \
177 --disable-wildmidi \ 157 --disable-wildmidi \
178 --disable-winks \ 158 --disable-winks \
179 --disable-winscreencap \ 159 --disable-winscreencap \
@@ -181,19 +161,13 @@ EXTRA_OECONF += " \
181 --disable-zbar \ 161 --disable-zbar \
182 ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--disable-yadif", "", d)} \ 162 ${@bb.utils.contains("TUNE_FEATURES", "mx32", "--disable-yadif", "", d)} \
183" 163"
184
185export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}" 164export OPENCV_PREFIX = "${STAGING_DIR_TARGET}${prefix}"
186 165
187ARM_INSTRUCTION_SET_armv4 = "arm" 166ARM_INSTRUCTION_SET_armv4 = "arm"
188ARM_INSTRUCTION_SET_armv5 = "arm" 167ARM_INSTRUCTION_SET_armv5 = "arm"
189 168
190FILES_${PN}-dev += "${libdir}/gstreamer-${LIBV}/include/gst/gl/gstglconfig.h"
191FILES_${PN}-freeverb += "${datadir}/gstreamer-${LIBV}/presets/GstFreeverb.prs" 169FILES_${PN}-freeverb += "${datadir}/gstreamer-${LIBV}/presets/GstFreeverb.prs"
192FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/${LIBV}/opencv*" 170FILES_${PN}-opencv += "${datadir}/gst-plugins-bad/${LIBV}/opencv*"
193FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-${LIBV}/presets/GstVoAmrwbEnc.prs" 171FILES_${PN}-voamrwbenc += "${datadir}/gstreamer-${LIBV}/presets/GstVoAmrwbEnc.prs"
194 172
195do_compile_prepend() {
196 export GIR_EXTRA_LIBS_PATH="${B}/gst-libs/gst/allocators/.libs"
197}
198
199COMPATIBLE_MACHINE = "(mx6|mx7|mx8)" 173COMPATIBLE_MACHINE = "(mx6|mx7|mx8)"