summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-10-30 17:49:06 -0300
committerGitHub <noreply@github.com>2023-10-30 17:49:06 -0300
commit37bd435c44dbd8dc38d633b109f131952b9e221f (patch)
tree996112444bb8572a251a0680db4fc1ae96613fc9
parent56ae548e93d5395eca5b6532688658258cdc39fb (diff)
parent655210018c7ab23b2c48dffdd47f16a516bd40c5 (diff)
downloadmeta-freescale-37bd435c44dbd8dc38d633b109f131952b9e221f.tar.gz
Merge pull request #1677 from zandrey/feat/upgrade-fslc-mainline-core-packages
Upgrade Kernel to 6.6.y + LTS Kernel 6.1.y + U-Boot 2023.10
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2023.10.inc (renamed from recipes-bsp/u-boot/u-boot-fslc-common_2023.04.inc)6
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.10.bb (renamed from recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.04.bb)0
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2023.10.bb (renamed from recipes-bsp/u-boot/u-boot-fslc_2023.04.bb)0
-rw-r--r--recipes-kernel/linux/linux-fslc-lts_6.1.bb39
-rw-r--r--recipes-kernel/linux/linux-fslc_6.6.bb (renamed from recipes-kernel/linux/linux-fslc_6.1.bb)6
5 files changed, 45 insertions, 6 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2023.04.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2023.10.inc
index 36f0b87a..1b8a720b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2023.04.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2023.10.inc
@@ -10,10 +10,10 @@ DEPENDS += "flex-native bison-native"
10 10
11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https" 11SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH};protocol=https"
12 12
13SRCREV = "7341fbb267e0cdb031c6ba6aa6572fe4be75d3c6" 13SRCREV = "105a9c8cc0a8551195e2a5ac8812802f12604ff6"
14SRCBRANCH = "2023.04+fslc" 14SRCBRANCH = "2023.10+fslc"
15 15
16PV = "2023.04+git${SRCPV}" 16PV = "2023.10+git${SRCPV}"
17 17
18S = "${WORKDIR}/git" 18S = "${WORKDIR}/git"
19B = "${WORKDIR}/build" 19B = "${WORKDIR}/build"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.04.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.10.bb
index b7e4ca76..b7e4ca76 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2023.10.bb
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2023.04.bb b/recipes-bsp/u-boot/u-boot-fslc_2023.10.bb
index eba8876a..eba8876a 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2023.04.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2023.10.bb
diff --git a/recipes-kernel/linux/linux-fslc-lts_6.1.bb b/recipes-kernel/linux/linux-fslc-lts_6.1.bb
new file mode 100644
index 00000000..51202796
--- /dev/null
+++ b/recipes-kernel/linux/linux-fslc-lts_6.1.bb
@@ -0,0 +1,39 @@
1# Copyright (C) 2012-2019 O.S. Systems Software LTDA.
2# Released under the MIT license (see COPYING.MIT for the terms)
3#
4# SPDX-License-Identifier: MIT
5#
6
7SUMMARY = "FSL Community BSP Linux LTS based kernel with backported features and fixes"
8DESCRIPTION = "Linux kernel based on LTS kernel used by FSL Community BSP in order to \
9provide support for some backported features and fixes, or because it was applied in upstream \
10and will not become part of a LTS version, or because it is not applicable for \
11upstreaming in any form."
12
13require linux-imx.inc
14
15SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=https"
16
17# PV is defined in the base in linux-imx.inc file and uses the LINUX_VERSION definition
18# required by kernel-yocto.bbclass.
19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.1.60"
23
24KBRANCH = "6.1.x+fslc"
25SRCREV = "62808a9f302b57493a3c8251a7e83e1dbfb75c88"
26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
29KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
30KBUILD_DEFCONFIG:mx6-generic-bsp = "imx_v6_v7_defconfig"
31KBUILD_DEFCONFIG:mx7-generic-bsp = "imx_v6_v7_defconfig"
32KBUILD_DEFCONFIG:mx8-generic-bsp = "defconfig"
33KBUILD_DEFCONFIG:mx9-generic-bsp = "defconfig"
34KBUILD_DEFCONFIG:mxs-generic-bsp = "mxs_defconfig"
35KBUILD_DEFCONFIG:vf-generic-bsp = "imx_v6_v7_defconfig"
36
37LOCALVERSION = "-fslc"
38
39COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-kernel/linux/linux-fslc_6.1.bb b/recipes-kernel/linux/linux-fslc_6.6.bb
index ecdc3c88..3365f778 100644
--- a/recipes-kernel/linux/linux-fslc_6.1.bb
+++ b/recipes-kernel/linux/linux-fslc_6.6.bb
@@ -19,10 +19,10 @@ SRC_URI = "git://github.com/Freescale/linux-fslc.git;branch=${KBRANCH};protocol=
19# 19#
20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and 20# LINUX_VERSION define should match to the kernel version referenced by SRC_URI and
21# should be updated once patchlevel is merged. 21# should be updated once patchlevel is merged.
22LINUX_VERSION = "6.1.57" 22LINUX_VERSION = "6.6"
23 23
24KBRANCH = "6.1.x+fslc" 24KBRANCH = "6.6.x+fslc"
25SRCREV = "2c0a3c104b3104e0244b32ac25151f699ac960c3" 25SRCREV = "34836895e19e910f736b06d7dbe522f4a33857f8"
26 26
27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 27KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"
28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig" 28KBUILD_DEFCONFIG:mx5-generic-bsp = "imx_v6_v7_defconfig"