summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2020-05-25 19:02:52 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-26 15:18:26 -0300
commit306b6419fa71077560f7b8f539c417ff60e109bb (patch)
treea64f2d291cef98d1bf3f8f18f4fe74433b7b2bcc
parent0a5343f1e05b336220cf158f5e8e456e0b6092e0 (diff)
downloadmeta-freescale-306b6419fa71077560f7b8f539c417ff60e109bb.tar.gz
rcw: compile only for needed boards
Instead of default compile stage, which compiles for all built-in boards, compile those boards which are needed (based on machine configuration). Since BOARDS is a list either, do not run make for each target board but handle all of them in one run. Signed-off-by: Jens Rehsack <sno@netbsd.org>
-rw-r--r--recipes-bsp/rcw/rcw_git.bb9
1 files changed, 5 insertions, 4 deletions
diff --git a/recipes-bsp/rcw/rcw_git.bb b/recipes-bsp/rcw/rcw_git.bb
index ad24ea33..b137ccb2 100644
--- a/recipes-bsp/rcw/rcw_git.bb
+++ b/recipes-bsp/rcw/rcw_git.bb
@@ -21,11 +21,12 @@ BOARD_TARGETS_ls2088ardb="${M} ${M}_rev1.1"
21BOARD_TARGETS_ls1088ardb-pb="ls1088ardb" 21BOARD_TARGETS_ls1088ardb-pb="ls1088ardb"
22BOARD_TARGETS_lx2160ardb = "${M} ${M}_rev2" 22BOARD_TARGETS_lx2160ardb = "${M} ${M}_rev2"
23 23
24do_compile () {
25 oe_runmake BOARDS="${BOARD_TARGETS}" DESTDIR=${D}/boot/rcw/
26}
27
24do_install () { 28do_install () {
25 for BT in ${BOARD_TARGETS} 29 oe_runmake BOARDS="${BOARD_TARGETS}" DESTDIR=${D}/boot/rcw/ install
26 do
27 oe_runmake BOARDS=${BT} DESTDIR=${D}/boot/rcw/ install
28 done
29} 30}
30 31
31do_deploy () { 32do_deploy () {