summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-04-19 16:50:40 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2020-04-20 16:17:28 -0300
commit291d71881ac61153d99992f5322e15635d9cd66d (patch)
treeb14beabec23e6202515c044d3f7cb0141d83de11
parent8e115ab460032de8a3495588b642ca82892f93b1 (diff)
downloadmeta-freescale-291d71881ac61153d99992f5322e15635d9cd66d.tar.gz
cryptodev: upgrade to 1.10
Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc21
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb5
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb16
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb10
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb21
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb8
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb26
-rw-r--r--recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc26
-rw-r--r--recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch66
-rw-r--r--recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch24
-rw-r--r--recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch50
-rw-r--r--recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch22
-rw-r--r--recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch28
13 files changed, 134 insertions, 189 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc b/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc
new file mode 100644
index 00000000..bb785831
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-1.10.inc
@@ -0,0 +1,21 @@
1HOMEPAGE = "http://cryptodev-linux.org/"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6python() {
7 d.appendVar('PROVIDES', ' ' + d.getVar('BPN').replace('-qoriq', ''))
8 pkgs = d.getVar('PACKAGES').split()
9 for p in pkgs:
10 if '-qoriq' in p:
11 d.appendVar("RPROVIDES_" + p, ' ' + p.replace('-qoriq', ''))
12 d.appendVar("RCONFLICTS_" + p, ' ' + p.replace('-qoriq', ''))
13 d.appendVar("RREPLACES_" + p, ' ' + p.replace('-qoriq', ''))
14}
15
16SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cryptodev-linux;protocol=https;nobranch=1"
17SRCREV = "f3007431120a1b4ae983c2b9ea09051311aa5e2f"
18
19S = "${WORKDIR}/git"
20
21CLEANBROKEN = "1"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb
new file mode 100644
index 00000000..c2cbc71b
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.10.bb
@@ -0,0 +1,5 @@
1require recipes-kernel/cryptodev/cryptodev-linux_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4BBCLASSEXTEND = ""
5COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb
deleted file mode 100644
index 58db5053..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-linux_1.9.bb
+++ /dev/null
@@ -1,16 +0,0 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A /dev/crypto device driver header file"
4
5PROVIDES = "cryptodev-linux"
6
7do_compile[noexec] = "1"
8
9# Just install cryptodev.h which is the only header file needed to be exported
10do_install() {
11 install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
12}
13
14ALLOW_EMPTY_${PN} = "1"
15
16COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb
new file mode 100644
index 00000000..86078c57
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.10.bb
@@ -0,0 +1,10 @@
1require recipes-kernel/cryptodev/cryptodev-module_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4inherit qoriq_build_64bit_kernel
5
6SRC_URI += " \
7file://0001-Disable-installing-header-file-provided-by-another-p.patch \
8"
9
10COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb
deleted file mode 100644
index 412bb0e5..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-module_1.9.bb
+++ /dev/null
@@ -1,21 +0,0 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A /dev/crypto device driver kernel module"
4
5PROVIDES = "cryptodev-module"
6
7inherit module qoriq_build_64bit_kernel
8
9# Header file provided by a separate package
10DEPENDS += "cryptodev-linux"
11
12EXTRA_OEMAKE='KERNEL_DIR="${STAGING_KERNEL_DIR}" DESTDIR="${D}"'
13
14SRC_URI_append = " \
15file://0001-Disable-installing-header-file-provided-by-another-p.patch \
16"
17
18RCONFLICTS_${PN} = "ocf-linux"
19RREPLACES_${PN} = "ocf-linux"
20
21COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb
new file mode 100644
index 00000000..784c38b7
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.10.bb
@@ -0,0 +1,8 @@
1require recipes-kernel/cryptodev/cryptodev-tests_${PV}.bb
2require cryptodev-qoriq-${PV}.inc
3
4SRC_URI += " \
5file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
6"
7
8COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb b/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb
deleted file mode 100644
index f7d0b61b..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq-tests_1.9.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1require cryptodev-qoriq_${PV}.inc
2
3SUMMARY = "A test suite for /dev/crypto device driver"
4
5DEPENDS = "openssl"
6
7PROVIDES = "cryptodev-tests"
8
9EXTRA_OEMAKE='KERNEL_DIR="${STAGING_EXECPREFIXDIR}" DESTDIR="${D}"'
10
11SRC_URI_append = " \
12file://0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch \
13"
14
15do_compile() {
16 oe_runmake testprogs
17}
18
19do_install() {
20 oe_runmake install_tests
21}
22
23FILES_${PN}-dbg += "${bindir}/tests_cryptodev/.debug"
24FILES_${PN} = "${bindir}/tests_cryptodev/*"
25
26COMPATIBLE_MACHINE = "(qoriq)"
diff --git a/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc b/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
deleted file mode 100644
index ad54fc9e..00000000
--- a/recipes-kernel/cryptodev/cryptodev-qoriq_1.9.inc
+++ /dev/null
@@ -1,26 +0,0 @@
1HOMEPAGE = "http://cryptodev-linux.org/"
2
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6python() {
7 pkgs = d.getVar('PACKAGES').split()
8 for p in pkgs:
9 if 'cryptodev-qoriq' in p:
10 d.appendVar("RPROVIDES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
11 d.appendVar("RCONFLICTS_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
12 d.appendVar("RREPLACES_%s" % p, p.replace('cryptodev-qoriq', 'cryptodev'))
13}
14
15FILESEXTRAPATHS_prepend := "${THISDIR}/yocto_patches:"
16
17SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/cryptodev-linux;nobranch=1"
18SRCREV = "479e6e7f071e252c0c37ea38d38fdb4cd808f496"
19
20# NOTE: remove this patch and all traces of DISTRO_FEATURE c29x_pkc
21# if pkc-host does not need customized cryptodev patches anymore
22#SRC_URI_append = "${@bb.utils.contains('DISTRO_FEATURES', 'c29x_pkc', ' file://0001-don-t-advertise-RSA-keygen.patch', '', d)}"
23
24S = "${WORKDIR}/git"
25
26CLEANBROKEN = "1"
diff --git a/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
new file mode 100644
index 00000000..84fd27e6
--- /dev/null
+++ b/recipes-kernel/cryptodev/files/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
@@ -0,0 +1,66 @@
1From 1980a8f4779a955e73285e7a0d86549b69bea5c8 Mon Sep 17 00:00:00 2001
2From: Yu Zongchun <b40527@freescale.com>
3Date: Sun, 28 Apr 2013 14:39:22 +0800
4Subject: [PATCH] Add the compile and install rules for cryptodev tests folder
5
6This is required to install the cryptodev tests folder to rootfs
7
8Signed-off-by: Yu Zongchun <b40527@freescale.com>
9
10Upstream-Status: Pending
11
12---
13 Makefile | 6 ++++++
14 tests/Makefile | 8 ++++++++
15 2 files changed, 14 insertions(+), 0 deletions(-)
16
17Index: git/Makefile
18===================================================================
19--- git.orig/Makefile
20+++ git/Makefile
21@@ -35,6 +35,9 @@ modules_install:
22 $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
23 install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
24
25+install_tests:
26+ make -C tests install DESTDIR=$(PREFIX)
27+
28 clean:
29 $(MAKE) $(KERNEL_MAKE_OPTS) clean
30 rm -f $(hostprogs) *~
31@@ -43,6 +46,9 @@ clean:
32 check:
33 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
34
35+testprogs:
36+ KERNEL_DIR=$(KERNEL_DIR) make -C tests testprogs
37+
38 CPOPTS =
39 ifneq ($(SHOW_TYPES),)
40 CPOPTS += --show-types
41Index: git/tests/Makefile
42===================================================================
43--- git.orig/tests/Makefile
44+++ git/tests/Makefile
45@@ -23,6 +23,12 @@ bindir = $(execprefix)/bin
46
47 all: $(hostprogs)
48
49+install:
50+ install -d $(DESTDIR)/usr/bin/tests_cryptodev
51+ for bin in $(hostprogs); do \
52+ install -m 755 $${bin} $(DESTDIR)/usr/bin/tests_cryptodev/; \
53+ done
54+
55 check: $(hostprogs)
56 ./cipher
57 ./hmac
58@@ -38,6 +44,8 @@ install:
59 install -m 755 $$prog $(DESTDIR)/$(bindir); \
60 done
61
62+testprogs: $(hostprogs)
63+
64 clean:
65 rm -f *.o *~ $(hostprogs)
66
diff --git a/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch b/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
new file mode 100644
index 00000000..885b5823
--- /dev/null
+++ b/recipes-kernel/cryptodev/files/0001-Disable-installing-header-file-provided-by-another-p.patch
@@ -0,0 +1,24 @@
1From 8a884f55bd1527baa82fab68c186ba546273860c Mon Sep 17 00:00:00 2001
2From: Denys Dmytriyenko <denys@ti.com>
3Date: Sun, 6 Apr 2014 19:51:39 -0400
4Subject: [PATCH] Disable installing header file provided by another package
5
6Signed-off-by: Denys Dmytriyenko <denys@ti.com>
7
8Upstream-Status: Inappropriate [ OE specific ]
9---
10 Makefile | 1 -
11 1 file changed, 1 deletion(-)
12
13diff --git a/Makefile b/Makefile
14index 5a080e0..bf02396 100644
15--- a/Makefile
16+++ b/Makefile
17@@ -33,7 +33,6 @@ install: modules_install
18
19 modules_install:
20 $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
21- install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
22
23 clean:
24 $(MAKE) $(KERNEL_MAKE_OPTS) clean
diff --git a/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch b/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
deleted file mode 100644
index 1e7f5843..00000000
--- a/recipes-kernel/cryptodev/yocto_patches/0001-Add-the-compile-and-install-rules-for-cryptodev-test.patch
+++ /dev/null
@@ -1,50 +0,0 @@
1From 03257bf2aff37b78496ccc1b58a87e7baaea042a Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Mon, 22 Feb 2016 12:17:52 +0200
4Subject: [PATCH 2/2] Add the compile and install rules for cryptodev tests
5
6(original patch Signed-off-by: Yu Zongchun <b40527@freescale.com>)
7Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
8
9Upstream-Status: Inappropriate [ OE specific ]
10---
11 Makefile | 6 ++++++
12 tests/Makefile | 4 ++--
13 2 files changed, 8 insertions(+), 2 deletions(-)
14
15diff --git a/Makefile b/Makefile
16index 06202bd..a598b12 100644
17--- a/Makefile
18+++ b/Makefile
19@@ -42,6 +42,12 @@ clean:
20 check:
21 CFLAGS=$(CRYPTODEV_CFLAGS) KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests check
22
23+testprogs:
24+ KERNEL_DIR=$(KERNEL_DIR) $(MAKE) -C tests all
25+
26+install_tests:
27+ $(MAKE) -C tests install
28+
29 CPOPTS =
30 ifneq ($(SHOW_TYPES),)
31 CPOPTS += --show-types
32diff --git a/tests/Makefile b/tests/Makefile
33index 5e3111d..cda971c 100644
34--- a/tests/Makefile
35+++ b/tests/Makefile
36@@ -35,9 +35,9 @@ check: $(hostprogs)
37 ./cipher-aead
38
39 install:
40- install -d $(DESTDIR)/$(bindir)
41+ install -d $(DESTDIR)/$(bindir)/tests_cryptodev
42 for prog in $(hostprogs); do \
43- install -m 755 $$prog $(DESTDIR)/$(bindir); \
44+ install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \
45 done
46
47 clean:
48--
492.7.0
50
diff --git a/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch b/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch
deleted file mode 100644
index 35aad600..00000000
--- a/recipes-kernel/cryptodev/yocto_patches/0001-Disable-installing-header-file-provided-by-another-p.patch
+++ /dev/null
@@ -1,22 +0,0 @@
1From eedfa57953d2d6255d53cb098c3f81cbde9187f7 Mon Sep 17 00:00:00 2001
2From: Cristian Stoica <cristian.stoica@nxp.com>
3Date: Mon, 22 Feb 2016 11:47:27 +0200
4Subject: [PATCH 1/2] Disable installing header file provided by another
5 package
6
7(original patch Signed-off-by: Denys Dmytriyenko <denys@ti.com>)
8Signed-off-by: Cristian Stoica <cristian.stoica@nxp.com>
9
10Upstream-Status: Inappropriate [ OE specific ]
11
12
13--- a/Makefileold 2017-04-18 14:54:40.588438842 +0800
14+++ b/Makefile 2017-04-18 14:55:40.308436774 +0800
15@@ -33,7 +33,6 @@
16
17 modules_install:
18 $(MAKE) $(KERNEL_MAKE_OPTS) modules_install
19- install -m 644 -D crypto/cryptodev.h $(DESTDIR)/$(includedir)/crypto/cryptodev.h
20
21 clean:
22 $(MAKE) $(KERNEL_MAKE_OPTS) clean
diff --git a/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch b/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch
deleted file mode 100644
index 4f92dbab..00000000
--- a/recipes-kernel/cryptodev/yocto_patches/0003-update-the-install-path-for-cryptodev-tests.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 5b0d2cf5abaaa3bffb4a9e874dba88bdab15b69d Mon Sep 17 00:00:00 2001
2From: Ting Liu <ting.liu@nxp.com>
3Date: Mon, 20 Feb 2017 22:43:00 +0800
4Subject: [PATCH] update the install path for cryptodev tests
5
6Signed-off-by: Ting Liu <ting.liu@nxp.com>
7---
8 tests/Makefile | 4 ++--
9 1 file changed, 2 insertions(+), 2 deletions(-)
10
11diff --git a/tests/Makefile b/tests/Makefile
12index dd7d5ff..e1c5039 100644
13--- a/tests/Makefile
14+++ b/tests/Makefile
15@@ -37,8 +37,8 @@ install:
16 for prog in $(hostprogs); do \
17 install -m 755 $$prog $(DESTDIR)/$(bindir)/tests_cryptodev/; \
18 done
19- install -m 755 speed_multi.sh $(DESTDIR)/$(bindir)
20- install -m 755 run_crypto_tests.sh $(DESTDIR)/$(bindir)
21+ install -m 755 speed_multi.sh $(DESTDIR)/$(bindir)/tests_cryptodev/
22+ install -m 755 run_crypto_tests.sh $(DESTDIR)/$(bindir)/tests_cryptodev/
23
24 clean:
25 rm -f *.o *~ $(hostprogs)
26--
271.9.2
28