diff options
author | Daiane Angolini <daiane.angolini@foundries.io> | 2023-07-25 13:31:06 -0300 |
---|---|---|
committer | Daiane Angolini <daiane.angolini@foundries.io> | 2023-07-25 13:32:16 -0300 |
commit | 28d88005535248c686d49ee9f35dd924270d41a2 (patch) | |
tree | f61f416bc4820a4036b7a6c06b5e81b17717ae6b | |
parent | 4b8c4612f4dda57489d8f465387e05c87decfc05 (diff) | |
download | meta-freescale-28d88005535248c686d49ee9f35dd924270d41a2.tar.gz |
linux-imx: Add patch to fix build issue
Fix the warning (treated as error):
ignal' due to enum/integer mismatch; have 'gceSTATUS(struct _gckOS *, void *)' {aka 'enum _gceSTATUS(struct _gckOS *, void *)'} [-Werror=enum-int-mismatch]
| 5675 | _QuerySignal(IN gckOS Os, IN gctSIGNAL Signal)
| | ^~~~~~~~~~~~
| In file included from /(...)tmp/work-shared/imx93-11x11-lpddr4x-evk/kernel-source/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_os.c:56:
| /(...)/buildw/tmp/work-shared/imx93-11x11-lpddr4x-evk/kernel-source/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h:341:1: note: previous declaration of '_QuerySignal' with type 'gctBOOL(struct _gckOS *, void *)' {aka 'int(struct _gckOS *, void *)'}
| 341 | _QuerySignal(IN gckOS Os, IN gctSIGNAL Signal);
| | ^~~~~~~~~~~~
| cc1: all warnings being treated as errors
Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io>
-rw-r--r-- | recipes-kernel/linux/linux-imx/drivers-mxc-gpu-viv-Fix-enum-int-mismatch-warning.patch | 37 | ||||
-rw-r--r-- | recipes-kernel/linux/linux-imx_6.1.bb | 4 |
2 files changed, 40 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx/drivers-mxc-gpu-viv-Fix-enum-int-mismatch-warning.patch b/recipes-kernel/linux/linux-imx/drivers-mxc-gpu-viv-Fix-enum-int-mismatch-warning.patch new file mode 100644 index 00000000..a917a243 --- /dev/null +++ b/recipes-kernel/linux/linux-imx/drivers-mxc-gpu-viv-Fix-enum-int-mismatch-warning.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 168e36d8879e3f5c4cf57ed74c10f6c134e45638 Mon Sep 17 00:00:00 2001 | ||
2 | From: Daiane Angolini <daiane.angolini@foundries.io> | ||
3 | Date: Tue, 25 Jul 2023 10:54:45 -0300 | ||
4 | Subject: [PATCH] drivers:mxc-gpu-viv: Fix enum-int-mismatch warning | ||
5 | |||
6 | Fix the warning (treated as error): | ||
7 | |||
8 | ignal' due to enum/integer mismatch; have 'gceSTATUS(struct _gckOS *, void *)' {aka 'enum _gceSTATUS(struct _gckOS *, void *)'} [-Werror=enum-int-mismatch] | ||
9 | | 5675 | _QuerySignal(IN gckOS Os, IN gctSIGNAL Signal) | ||
10 | | | ^~~~~~~~~~~~ | ||
11 | | In file included from /(...)tmp/work-shared/imx93-11x11-lpddr4x-evk/kernel-source/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_os.c:56: | ||
12 | | /(...)/buildw/tmp/work-shared/imx93-11x11-lpddr4x-evk/kernel-source/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h:341:1: note: previous declaration of '_QuerySignal' with type 'gctBOOL(struct _gckOS *, void *)' {aka 'int(struct _gckOS *, void *)'} | ||
13 | | 341 | _QuerySignal(IN gckOS Os, IN gctSIGNAL Signal); | ||
14 | | | ^~~~~~~~~~~~ | ||
15 | | cc1: all warnings being treated as errors | ||
16 | |||
17 | Signed-off-by: Daiane Angolini <daiane.angolini@foundries.io> | ||
18 | --- | ||
19 | drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h | 2 +- | ||
20 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
21 | |||
22 | diff --git a/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h b/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h | ||
23 | index 61edf03571443..b4c1cbf414846 100644 | ||
24 | --- a/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h | ||
25 | +++ b/drivers/mxc/gpu-viv/hal/os/linux/kernel/gc_hal_kernel_linux.h | ||
26 | @@ -337,7 +337,7 @@ _ConvertLogical2Physical(IN gckOS Os, | ||
27 | IN PLINUX_MDL Mdl, | ||
28 | OUT gctPHYS_ADDR_T *Physical); | ||
29 | |||
30 | -gctBOOL | ||
31 | +gceSTATUS | ||
32 | _QuerySignal(IN gckOS Os, IN gctSIGNAL Signal); | ||
33 | |||
34 | static inline gctINT | ||
35 | -- | ||
36 | 2.34.1 | ||
37 | |||
diff --git a/recipes-kernel/linux/linux-imx_6.1.bb b/recipes-kernel/linux/linux-imx_6.1.bb index 8b1e6045..574ba04d 100644 --- a/recipes-kernel/linux/linux-imx_6.1.bb +++ b/recipes-kernel/linux/linux-imx_6.1.bb | |||
@@ -12,7 +12,9 @@ i.MX Family Reference Boards. It includes support for many IPs such as GPU, VPU | |||
12 | 12 | ||
13 | require recipes-kernel/linux/linux-imx.inc | 13 | require recipes-kernel/linux/linux-imx.inc |
14 | 14 | ||
15 | SRC_URI += "file://ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch" | 15 | SRC_URI += "file://ARM-imx_v7_defconfig-Remove-KERNEL_LZO-config.patch \ |
16 | file://drivers-mxc-gpu-viv-Fix-enum-int-mismatch-warning.patch \ | ||
17 | " | ||
16 | 18 | ||
17 | SRCBRANCH = "lf-6.1.y" | 19 | SRCBRANCH = "lf-6.1.y" |
18 | LOCALVERSION = "-6.1.22-2.0.0" | 20 | LOCALVERSION = "-6.1.22-2.0.0" |