summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTing Liu <ting.liu@nxp.com>2020-06-08 20:16:21 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2020-06-10 17:13:09 -0300
commit1ee015e6e308ca1fa6d185015fdb2b828dc2c611 (patch)
tree84d967ecfed2317c6d6b01b1c50169213936a69d
parentd9251dbd836d762fff82257b8053beb24e745ca1 (diff)
downloadmeta-freescale-1ee015e6e308ca1fa6d185015fdb2b828dc2c611.tar.gz
atf: use var RCW_FOLDER to allow selecting rcw folder
Generally, rcw are deployed to ${DEPLOY_DIR_IMAGE}/rcw/${MACHINE}/. But there are some machines that don't follow this rule. For example, lx2160ardb deployed RCW in folder lx2160ardb_rev2 for boards with Rev2 processor, but folder lx2160ardb for boards with Rev1 processor. As there are only difference on RCW for them, use variable RCW_FOLDER to allow selecting rcw folder for building atf targets. For exmaple, to build atf which supports lx2160ardb with Rev2 processor: RCW_FOLDER_lx2160ardb = "lx2160ardb_rev2" Signed-off-by: Ting Liu <ting.liu@nxp.com>
-rw-r--r--recipes-bsp/atf/atf_git.bb11
1 files changed, 7 insertions, 4 deletions
diff --git a/recipes-bsp/atf/atf_git.bb b/recipes-bsp/atf/atf_git.bb
index ff55ca0c..dcc3689a 100644
--- a/recipes-bsp/atf/atf_git.bb
+++ b/recipes-bsp/atf/atf_git.bb
@@ -27,6 +27,9 @@ PLATFORM_ls1088ardb-pb = "ls1088ardb"
27PLATFORM_ADDITIONAL_TARGET ??= "" 27PLATFORM_ADDITIONAL_TARGET ??= ""
28PLATFORM_ADDITIONAL_TARGET_ls1012afrwy = "ls1012afrwy_512mb" 28PLATFORM_ADDITIONAL_TARGET_ls1012afrwy = "ls1012afrwy_512mb"
29 29
30RCW_FOLDER ?= "${MACHINE}"
31RCW_FOLDER_ls1088ardb-pb = "ls1088ardb"
32
30# requires CROSS_COMPILE set by hand as there is no configure script 33# requires CROSS_COMPILE set by hand as there is no configure script
31export CROSS_COMPILE="${TARGET_PREFIX}" 34export CROSS_COMPILE="${TARGET_PREFIX}"
32export ARCH="arm64" 35export ARCH="arm64"
@@ -148,9 +151,9 @@ do_compile() {
148 ;; 151 ;;
149 esac 152 esac
150 153
151 if [ -f "${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg}" ]; then 154 if [ -f "${DEPLOY_DIR_IMAGE}/rcw/${RCW_FOLDER}/${rcwimg}" ]; then
152 oe_runmake V=1 -C ${S} realclean 155 oe_runmake V=1 -C ${S} realclean
153 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} 156 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${RCW_FOLDER}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt}
154 cp -r ${S}/build/${PLATFORM}/release/bl2_${d}*.pbl ${S} 157 cp -r ${S}/build/${PLATFORM}/release/bl2_${d}*.pbl ${S}
155 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S} 158 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}
156 if [ "${BUILD_FUSE}" = "true" ]; then 159 if [ "${BUILD_FUSE}" = "true" ]; then
@@ -159,7 +162,7 @@ do_compile() {
159 162
160 if [ -n "${PLATFORM_ADDITIONAL_TARGET}" ]; then 163 if [ -n "${PLATFORM_ADDITIONAL_TARGET}" ]; then
161 oe_runmake V=1 -C ${S} realclean 164 oe_runmake V=1 -C ${S} realclean
162 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM_ADDITIONAL_TARGET} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} 165 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM_ADDITIONAL_TARGET} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${RCW_FOLDER}/${rcwimg} BL33=${bl33} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt}
163 cp -r ${S}/build/${PLATFORM_ADDITIONAL_TARGET}/release/bl2_qspi${secext}.pbl ${S}/bl2_${d}${secext}_${PLATFORM_ADDITIONAL_TARGET}.pbl 166 cp -r ${S}/build/${PLATFORM_ADDITIONAL_TARGET}/release/bl2_qspi${secext}.pbl ${S}/bl2_${d}${secext}_${PLATFORM_ADDITIONAL_TARGET}.pbl
164 cp -r ${S}/build/${PLATFORM_ADDITIONAL_TARGET}/release/fip.bin ${S}/fip_${PLATFORM_ADDITIONAL_TARGET}.bin 167 cp -r ${S}/build/${PLATFORM_ADDITIONAL_TARGET}/release/fip.bin ${S}/fip_${PLATFORM_ADDITIONAL_TARGET}.bin
165 if [ "${BUILD_FUSE}" = "true" ]; then 168 if [ "${BUILD_FUSE}" = "true" ]; then
@@ -168,7 +171,7 @@ do_compile() {
168 fi 171 fi
169 if [ -n "${uefiboot}" -a -f "${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot}" ]; then 172 if [ -n "${uefiboot}" -a -f "${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot}" ]; then
170 oe_runmake V=1 -C ${S} realclean 173 oe_runmake V=1 -C ${S} realclean
171 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${PLATFORM}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt} 174 oe_runmake V=1 -C ${S} all fip pbl PLAT=${PLATFORM} BOOT_MODE=${d} RCW=${DEPLOY_DIR_IMAGE}/rcw/${RCW_FOLDER}/${rcwimg} BL33=${DEPLOY_DIR_IMAGE}/uefi/${PLATFORM}/${uefiboot} ${bl32opt} ${spdopt} ${secureopt} ${fuseopt} ${otaopt}
172 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin 175 cp -r ${S}/build/${PLATFORM}/release/fip.bin ${S}/fip_uefi.bin
173 fi 176 fi
174 fi 177 fi