summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2019-05-23 13:08:39 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2019-09-12 14:45:07 -0300
commit1e2ff11ab06320e69e617d80f11e2f8094b931fc (patch)
treef25f3a615674c8113bc374a5e8ac28d13047eba2
parentb1781d2ea8b7fe8023a5e624671cb183e22142bd (diff)
downloadmeta-freescale-1e2ff11ab06320e69e617d80f11e2f8094b931fc.tar.gz
weston: Upgrade to 5.0.0.imx
Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
-rw-r--r--recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch33
-rw-r--r--recipes-graphics/wayland/weston/0001-make-error-portable.patch6
-rw-r--r--recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch30
-rw-r--r--recipes-graphics/wayland/weston_5.0.0.imx.bb (renamed from recipes-graphics/wayland/weston_4.0.0.imx.bb)7
4 files changed, 21 insertions, 55 deletions
diff --git a/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch b/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch
deleted file mode 100644
index 6f676048..00000000
--- a/recipes-graphics/wayland/weston/0001-g2d-renderer-Fix-open-function-build-break.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 7857e5aa2459b2746e062ae59ae0240c4af7af5d Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Mon, 29 Oct 2018 21:40:32 +0000
4Subject: [PATCH] g2d-renderer: Fix open function build break
5
6| from ../git/libweston/g2d-renderer.c:40:
7| In function 'open',
8| inlined from 'g2d_renderer_create' at ../git/libweston/g2d-renderer.c:1629:2:
9| /home/r60874/upstream/fsl-xwayland/tmp/work/cortexa9t2hf-neon-mx6qdl-fsl-linux-gnueabi/weston/4.0.0.imx-r0/recipe- sysroot/usr/include/bits/fcntl2.h:50:4: error: call to '__open_missing_mode' declared with attribute error: open wit h O_CREAT or O_TMPFILE in second argument needs 3 arguments
10| __open_missing_mode ();
11| ^~~~~~~~~~~~~~~~~~~~~~
12| Makefile:5266: recipe for target 'libweston/g2d_renderer_la-g2d-renderer.lo' failed
13
14Upstream-Status: Inappropriate [i.MX-specific]
15
16Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
17---
18 libweston/g2d-renderer.c | 4 ++--
19 1 file changed, 2 insertions(+), 2 deletions(-)
20
21Index: git/libweston/g2d-renderer.c
22===================================================================
23--- git.orig/libweston/g2d-renderer.c
24+++ git/libweston/g2d-renderer.c
25@@ -1626,7 +1626,7 @@ g2d_renderer_create(struct weston_compos
26 path = malloc(strlen(dir) + 40);
27 strcpy(path, dir);
28 strcat(path, "/use-g2d-renderer");
29- close(open(path, O_CREAT | O_RDWR));
30+ close(open(path, O_CREAT | O_RDWR, 0600));
31 free(path);
32
33 return 0;
diff --git a/recipes-graphics/wayland/weston/0001-make-error-portable.patch b/recipes-graphics/wayland/weston/0001-make-error-portable.patch
index 09ec1559..c15e6928 100644
--- a/recipes-graphics/wayland/weston/0001-make-error-portable.patch
+++ b/recipes-graphics/wayland/weston/0001-make-error-portable.patch
@@ -1,4 +1,4 @@
1From ad1d2161c811cff25d1684c33611f300adb753bc Mon Sep 17 00:00:00 2001 1From 6ef33e86557c59b31c9b731c0360ec1d404cc801 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 29 May 2015 20:56:00 -0700 3Date: Fri, 29 May 2015 20:56:00 -0700
4Subject: [PATCH] make error() portable 4Subject: [PATCH] make error() portable
@@ -18,7 +18,7 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com>
18 create mode 100644 libweston/weston-error.h 18 create mode 100644 libweston/weston-error.h
19 19
20diff --git a/configure.ac b/configure.ac 20diff --git a/configure.ac b/configure.ac
21index 7aebbdb..dc9c802 100644 21index 9d98e84..8f6b80d 100644
22--- a/configure.ac 22--- a/configure.ac
23+++ b/configure.ac 23+++ b/configure.ac
24@@ -109,6 +109,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[], 24@@ -109,6 +109,8 @@ AC_CHECK_DECL(CLOCK_MONOTONIC,[],
@@ -57,7 +57,7 @@ index 0000000..2089d02
57+#endif 57+#endif
58+ 58+
59diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c 59diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c
60index 1adcf21..166bf3b 100644 60index bf73e0d..9064439 100644
61--- a/libweston/weston-launch.c 61--- a/libweston/weston-launch.c
62+++ b/libweston/weston-launch.c 62+++ b/libweston/weston-launch.c
63@@ -33,7 +33,6 @@ 63@@ -33,7 +33,6 @@
diff --git a/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch b/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
index d648538b..3e4e772b 100644
--- a/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
+++ b/recipes-graphics/wayland/weston/0001-weston-launch-Provide-a-default-version-that-doesn-t.patch
@@ -1,4 +1,4 @@
1From b98b9dbda902225cdd972b5bff6a641c36cc7e90 Mon Sep 17 00:00:00 2001 1From d5fb8567868866665502106def90017243a968a8 Mon Sep 17 00:00:00 2001
2From: Tom Hochstein <tom.hochstein@nxp.com> 2From: Tom Hochstein <tom.hochstein@nxp.com>
3Date: Wed, 22 Feb 2017 15:53:30 +0200 3Date: Wed, 22 Feb 2017 15:53:30 +0200
4Subject: [PATCH] weston-launch: Provide a default version that doesn't require PAM 4Subject: [PATCH] weston-launch: Provide a default version that doesn't require PAM
@@ -21,10 +21,10 @@ Signed-off-by: Denys Dmytriyenko <denys@ti.com>
21 2 files changed, 27 insertions(+), 2 deletions(-) 21 2 files changed, 27 insertions(+), 2 deletions(-)
22 22
23diff --git a/configure.ac b/configure.ac 23diff --git a/configure.ac b/configure.ac
24index dc9c802..48cf5cb 100644 24index 8f6b80d..603fcb3 100644
25--- a/configure.ac 25--- a/configure.ac
26+++ b/configure.ac 26+++ b/configure.ac
27@@ -451,13 +451,17 @@ AC_ARG_ENABLE(resize-optimization, 27@@ -494,13 +494,17 @@ AC_ARG_ENABLE(resize-optimization,
28 AS_IF([test "x$enable_resize_optimization" = "xyes"], 28 AS_IF([test "x$enable_resize_optimization" = "xyes"],
29 [AC_DEFINE([USE_RESIZE_POOL], [1], [Use resize memory pool as a performance optimization])]) 29 [AC_DEFINE([USE_RESIZE_POOL], [1], [Use resize memory pool as a performance optimization])])
30 30
@@ -44,7 +44,7 @@ index dc9c802..48cf5cb 100644
44 fi 44 fi
45 45
46 AM_CONDITIONAL(HAVE_PANGO, test "x$have_pango" = "xyes") 46 AM_CONDITIONAL(HAVE_PANGO, test "x$have_pango" = "xyes")
47@@ -702,6 +706,7 @@ AC_MSG_RESULT([ 47@@ -748,6 +752,7 @@ AC_MSG_RESULT([
48 Enable developer documentation ${enable_devdocs} 48 Enable developer documentation ${enable_devdocs}
49 49
50 weston-launch utility ${enable_weston_launch} 50 weston-launch utility ${enable_weston_launch}
@@ -53,7 +53,7 @@ index dc9c802..48cf5cb 100644
53 systemd notify support ${enable_systemd_notify} 53 systemd notify support ${enable_systemd_notify}
54 54
55diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c 55diff --git a/libweston/weston-launch.c b/libweston/weston-launch.c
56index 166bf3b..6fb9232 100644 56index 9064439..c6abe92 100644
57--- a/libweston/weston-launch.c 57--- a/libweston/weston-launch.c
58+++ b/libweston/weston-launch.c 58+++ b/libweston/weston-launch.c
59@@ -51,7 +51,9 @@ 59@@ -51,7 +51,9 @@
@@ -77,7 +77,7 @@ index 166bf3b..6fb9232 100644
77 int tty; 77 int tty;
78 int ttynr; 78 int ttynr;
79 int sock[2]; 79 int sock[2];
80@@ -189,6 +193,7 @@ weston_launch_allowed(struct weston_launch *wl) 80@@ -191,6 +195,7 @@ weston_launch_allowed(struct weston_launch *wl)
81 return false; 81 return false;
82 } 82 }
83 83
@@ -85,7 +85,7 @@ index 166bf3b..6fb9232 100644
85 static int 85 static int
86 pam_conversation_fn(int msg_count, 86 pam_conversation_fn(int msg_count,
87 const struct pam_message **messages, 87 const struct pam_message **messages,
88@@ -229,6 +234,7 @@ setup_pam(struct weston_launch *wl) 88@@ -231,6 +236,7 @@ setup_pam(struct weston_launch *wl)
89 89
90 return 0; 90 return 0;
91 } 91 }
@@ -93,7 +93,7 @@ index 166bf3b..6fb9232 100644
93 93
94 static int 94 static int
95 setup_launcher_socket(struct weston_launch *wl) 95 setup_launcher_socket(struct weston_launch *wl)
96@@ -422,6 +428,7 @@ quit(struct weston_launch *wl, int status) 96@@ -424,6 +430,7 @@ quit(struct weston_launch *wl, int status)
97 close(wl->signalfd); 97 close(wl->signalfd);
98 close(wl->sock[0]); 98 close(wl->sock[0]);
99 99
@@ -101,7 +101,7 @@ index 166bf3b..6fb9232 100644
101 if (wl->new_user) { 101 if (wl->new_user) {
102 err = pam_close_session(wl->ph, 0); 102 err = pam_close_session(wl->ph, 0);
103 if (err) 103 if (err)
104@@ -429,6 +436,7 @@ quit(struct weston_launch *wl, int status) 104@@ -431,6 +438,7 @@ quit(struct weston_launch *wl, int status)
105 err, pam_strerror(wl->ph, err)); 105 err, pam_strerror(wl->ph, err));
106 pam_end(wl->ph, err); 106 pam_end(wl->ph, err);
107 } 107 }
@@ -109,7 +109,7 @@ index 166bf3b..6fb9232 100644
109 109
110 if (ioctl(wl->tty, KDSKBMUTE, 0) && 110 if (ioctl(wl->tty, KDSKBMUTE, 0) &&
111 ioctl(wl->tty, KDSKBMODE, wl->kb_mode)) 111 ioctl(wl->tty, KDSKBMODE, wl->kb_mode))
112@@ -608,6 +616,7 @@ setup_session(struct weston_launch *wl, char **child_argv) 112@@ -610,6 +618,7 @@ setup_session(struct weston_launch *wl, char **child_argv)
113 setenv("HOME", wl->pw->pw_dir, 1); 113 setenv("HOME", wl->pw->pw_dir, 1);
114 setenv("SHELL", wl->pw->pw_shell, 1); 114 setenv("SHELL", wl->pw->pw_shell, 1);
115 115
@@ -117,7 +117,7 @@ index 166bf3b..6fb9232 100644
117 env = pam_getenvlist(wl->ph); 117 env = pam_getenvlist(wl->ph);
118 if (env) { 118 if (env) {
119 for (i = 0; env[i]; ++i) { 119 for (i = 0; env[i]; ++i) {
120@@ -616,6 +625,7 @@ setup_session(struct weston_launch *wl, char **child_argv) 120@@ -618,6 +627,7 @@ setup_session(struct weston_launch *wl, char **child_argv)
121 } 121 }
122 free(env); 122 free(env);
123 } 123 }
@@ -125,7 +125,7 @@ index 166bf3b..6fb9232 100644
125 125
126 /* 126 /*
127 * We open a new session, so it makes sense 127 * We open a new session, so it makes sense
128@@ -683,8 +693,10 @@ static void 128@@ -685,8 +695,10 @@ static void
129 help(const char *name) 129 help(const char *name)
130 { 130 {
131 fprintf(stderr, "Usage: %s [args...] [-- [weston args..]]\n", name); 131 fprintf(stderr, "Usage: %s [args...] [-- [weston args..]]\n", name);
@@ -136,7 +136,7 @@ index 166bf3b..6fb9232 100644
136 fprintf(stderr, " -t, --tty Start session on alternative tty,\n" 136 fprintf(stderr, " -t, --tty Start session on alternative tty,\n"
137 " e.g. -t /dev/tty4, requires -u option.\n"); 137 " e.g. -t /dev/tty4, requires -u option.\n");
138 fprintf(stderr, " -v, --verbose Be verbose\n"); 138 fprintf(stderr, " -v, --verbose Be verbose\n");
139@@ -698,7 +710,9 @@ main(int argc, char *argv[]) 139@@ -700,7 +712,9 @@ main(int argc, char *argv[])
140 int i, c; 140 int i, c;
141 char *tty = NULL; 141 char *tty = NULL;
142 struct option opts[] = { 142 struct option opts[] = {
@@ -146,7 +146,7 @@ index 166bf3b..6fb9232 100644
146 { "tty", required_argument, NULL, 't' }, 146 { "tty", required_argument, NULL, 't' },
147 { "verbose", no_argument, NULL, 'v' }, 147 { "verbose", no_argument, NULL, 'v' },
148 { "help", no_argument, NULL, 'h' }, 148 { "help", no_argument, NULL, 'h' },
149@@ -710,9 +724,13 @@ main(int argc, char *argv[]) 149@@ -712,9 +726,13 @@ main(int argc, char *argv[])
150 while ((c = getopt_long(argc, argv, "u:t:vh", opts, &i)) != -1) { 150 while ((c = getopt_long(argc, argv, "u:t:vh", opts, &i)) != -1) {
151 switch (c) { 151 switch (c) {
152 case 'u': 152 case 'u':
@@ -160,7 +160,7 @@ index 166bf3b..6fb9232 100644
160 break; 160 break;
161 case 't': 161 case 't':
162 tty = optarg; 162 tty = optarg;
163@@ -753,8 +771,10 @@ main(int argc, char *argv[]) 163@@ -755,8 +773,10 @@ main(int argc, char *argv[])
164 if (setup_tty(&wl, tty) < 0) 164 if (setup_tty(&wl, tty) < 0)
165 exit(EXIT_FAILURE); 165 exit(EXIT_FAILURE);
166 166
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_5.0.0.imx.bb
index e8d74fd4..11da2872 100644
--- a/recipes-graphics/wayland/weston_4.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_5.0.0.imx.bb
@@ -3,11 +3,11 @@ DESCRIPTION = "Weston is the reference implementation of a Wayland compositor"
3HOMEPAGE = "http://wayland.freedesktop.org" 3HOMEPAGE = "http://wayland.freedesktop.org"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=d79ee9e66bb0f95d3386a7acae780b70 \
6 file://libweston/compositor.c;endline=26;md5=e342df749174a8ee11065583157c7a38" 6 file://libweston/compositor.c;endline=26;md5=f47553ae598090444273db00adfb5b66"
7 7
8DEFAULT_PREFERENCE = "-1" 8DEFAULT_PREFERENCE = "-1"
9 9
10SRCBRANCH = "weston-imx-4.0" 10SRCBRANCH = "weston-imx-5.0"
11SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \ 11SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \
12 file://weston.ini \ 12 file://weston.ini \
13 file://weston.png \ 13 file://weston.png \
@@ -15,9 +15,8 @@ SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=http
15 file://0001-make-error-portable.patch \ 15 file://0001-make-error-portable.patch \
16 file://xwayland.weston-start \ 16 file://xwayland.weston-start \
17 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \ 17 file://0001-weston-launch-Provide-a-default-version-that-doesn-t.patch \
18 file://0001-g2d-renderer-Fix-open-function-build-break.patch \
19" 18"
20SRCREV = "866072b52751e5023651dd9322baa513e1f74fe6" 19SRCREV = "fb563901657b296c7c7c86d26602a622429e334f"
21S = "${WORKDIR}/git" 20S = "${WORKDIR}/git"
22 21
23UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html" 22UPSTREAM_CHECK_URI = "https://wayland.freedesktop.org/releases.html"