summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristinel Panfir <cristinel.panfir@nxp.com>2019-12-02 15:36:29 +0200
committerOtavio Salvador <otavio@ossystems.com.br>2019-12-03 11:52:54 -0300
commit14bbd7362200698816ae7589c4ebc4925b725ce9 (patch)
treeb594699e9d48c7c9d2cbb0ddae65618a4628d724
parent64d58e36978e7227b8907f2b2be0ec5a643cdf70 (diff)
downloadmeta-freescale-14bbd7362200698816ae7589c4ebc4925b725ce9.tar.gz
linux-imx-headers: Update to version 4.19.35
Signed-off-by: Cristinel Panfir <cristinel.panfir@nxp.com>
-rw-r--r--recipes-kernel/linux/linux-imx-headers_4.14.98.bb57
-rw-r--r--recipes-kernel/linux/linux-imx-headers_4.19.35.bb57
2 files changed, 57 insertions, 57 deletions
diff --git a/recipes-kernel/linux/linux-imx-headers_4.14.98.bb b/recipes-kernel/linux/linux-imx-headers_4.14.98.bb
deleted file mode 100644
index e55a795b..00000000
--- a/recipes-kernel/linux/linux-imx-headers_4.14.98.bb
+++ /dev/null
@@ -1,57 +0,0 @@
1# Copyright 2017-2018 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Installs i.MX-specific kernel headers"
5DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
6New headers are installed in ${includedir}/imx."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9
10SRCBRANCH = "imx_4.14.98_2.0.0_ga"
11LOCALVERSION = "-imx"
12SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCREV = "dfc78102d29f81d9316b281a3b8af3dff95174c8"
14
15S = "${WORKDIR}/git"
16
17do_compile[noexec] = "1"
18
19IMX_UAPI_HEADERS = " \
20 dma-buf.h \
21 hantrodec.h \
22 hx280enc.h \
23 ion.h \
24 ipu.h \
25 isl29023.h \
26 mxc_asrc.h \
27 mxc_dcic.h \
28 mxc_mlb.h \
29 mxc_sim_interface.h \
30 mxc_v4l2.h \
31 mxcfb.h \
32 pxp_device.h \
33 pxp_dma.h \
34 videodev2.h \
35"
36
37do_install() {
38 # We install all headers inside of B so we can copy only the
39 # whitelisted ones, and there is no risk of a new header to be
40 # installed by mistake.
41 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
42
43 # FIXME: The ion.h is still on staging so "promote" it for now
44 cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
45
46 # Install whitelisted headers only
47 for h in ${IMX_UAPI_HEADERS}; do
48 install -D -m 0644 ${B}${includedir}/linux/$h \
49 ${D}${includedir}/imx/linux/$h
50 done
51}
52
53ALLOW_EMPTY_${PN} = "1"
54
55PACKAGE_ARCH = "${MACHINE_SOCARCH}"
56COMPATIBLE_HOST_imx = ".*"
57COMPATIBLE_HOST ?= "(none)"
diff --git a/recipes-kernel/linux/linux-imx-headers_4.19.35.bb b/recipes-kernel/linux/linux-imx-headers_4.19.35.bb
new file mode 100644
index 00000000..5d1b1a2f
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-headers_4.19.35.bb
@@ -0,0 +1,57 @@
1# Copyright 2017-20189 NXP
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Installs i.MX-specific kernel headers"
5DESCRIPTION = "Installs i.MX-specific kernel headers to userspace. \
6New headers are installed in ${includedir}/imx."
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
9
10SRCBRANCH = "imx_4.19.35_1.1.0"
11LOCALVERSION = "-1.1.0"
12SRC_URI = "git://source.codeaurora.org/external/imx/linux-imx.git;protocol=https;branch=${SRCBRANCH}"
13SRCREV = "a51dda8feec03e8c675230786d64ee050944dbfd"
14
15S = "${WORKDIR}/git"
16
17do_compile[noexec] = "1"
18
19IMX_UAPI_HEADERS = " \
20 dma-buf.h \
21 hantrodec.h \
22 hx280enc.h \
23 ion.h \
24 ipu.h \
25 isl29023.h \
26 mxc_asrc.h \
27 mxc_dcic.h \
28 mxc_mlb.h \
29 mxc_sim_interface.h \
30 mxc_v4l2.h \
31 mxcfb.h \
32 pxp_device.h \
33 pxp_dma.h \
34 videodev2.h \
35"
36
37do_install() {
38 # We install all headers inside of B so we can copy only the
39 # whitelisted ones, and there is no risk of a new header to be
40 # installed by mistake.
41 oe_runmake headers_install INSTALL_HDR_PATH=${B}${exec_prefix}
42
43 # FIXME: The ion.h is still on staging so "promote" it for now
44 cp ${S}/drivers/staging/android/uapi/ion.h ${B}${includedir}/linux
45
46 # Install whitelisted headers only
47 for h in ${IMX_UAPI_HEADERS}; do
48 install -D -m 0644 ${B}${includedir}/linux/$h \
49 ${D}${includedir}/imx/linux/$h
50 done
51}
52
53ALLOW_EMPTY_${PN} = "1"
54
55PACKAGE_ARCH = "${MACHINE_SOCARCH}"
56COMPATIBLE_HOST_imx = ".*"
57COMPATIBLE_HOST ?= "(none)"