summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>2020-05-09 20:48:52 +0000
committerOtavio Salvador <otavio@ossystems.com.br>2020-05-09 18:00:05 -0300
commit08491c86615cdd48736b3b783ed3770a50fd06fd (patch)
tree7b81ffd0a555a9499d9c6ed5cd6ce6323f81de4b
parentb94e9f9e3dc925da19a17df545afb83d9ccc2339 (diff)
downloadmeta-freescale-08491c86615cdd48736b3b783ed3770a50fd06fd.tar.gz
gstreamer1.0-plugins-bad: update opencv patch to 4.3.0
OpenCV has been upgraded upstream to 4.3.0 and current build of gstreamer1.0-plugins-bad is broken as the previous patch required version to be < 4.2.0 Backport the patch from upsteam to allow compilation with OpenCV 4.3.0 and replace the patch in the layer. Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch34
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch43
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb2
3 files changed, 35 insertions, 44 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch
new file mode 100644
index 00000000..a9e1bd00
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0001-opencv-allow-compilation-against-4.3.x.patch
@@ -0,0 +1,34 @@
1From cfb196925312b3c3d7a19dbb9a3ce64d20d66409 Mon Sep 17 00:00:00 2001
2From: Andrey Zhizhikin <andrey.z@gmail.com>
3Date: Sat, 9 May 2020 19:56:51 +0000
4Subject: [PATCH] opencv: allow compilation against 4.3.x
5
6Backport upstream commit 4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef to NXP
7fork of gstreamer1.0-plugins-bad.
8
9Original commit link:
10https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/-/commit/4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef
11
12Upstream-Status: Backport [4cf362e2df0fb809ea0f21dd4a6fbb8b46ca54ef]
13
14Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
15---
16 ext/opencv/meson.build | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
20index d0ce1d3ee..05b142edc 100644
21--- a/ext/opencv/meson.build
22+++ b/ext/opencv/meson.build
23@@ -65,7 +65,7 @@ if opencv_found
24 endif
25 endforeach
26 else
27- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false)
28+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.4.0'], required : false)
29 opencv_found = opencv_dep.found()
30 if opencv_found
31 foreach h : libopencv4_headers
32--
332.17.1
34
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
deleted file mode 100644
index 62705dd4..00000000
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad/0002-opencv-allow-compilation-against-4.1.x.patch
+++ /dev/null
@@ -1,43 +0,0 @@
1From eb404fd917fa3ab7ffa9433c9975ee49cfc9c41f Mon Sep 17 00:00:00 2001
2From: Nicola Murino <nicola.murino@gmail.com>
3Date: Tue, 23 Apr 2019 09:06:13 +0200
4Subject: [PATCH 1/2] opencv: allow compilation against 4.1.x
5
6Upstream-Status: Backport [https://gitlab.freedesktop.org/gstreamer/gst-plugins-bad/commit/49a2baebf58d9288f75964fc40a547fde510a840]
7
8(cherry picked from commit 49a2baebf58d9288f75964fc40a547fde510a840)
9Signed-off-by: Andrey Zhizhikin <andrey.zhizhikin@leica-geosystems.com>
10---
11 configure.ac | 2 +-
12 ext/opencv/meson.build | 2 +-
13 2 files changed, 2 insertions(+), 2 deletions(-)
14
15diff --git a/configure.ac b/configure.ac
16index 26f72eb0d..9e12d39a0 100644
17--- a/configure.ac
18+++ b/configure.ac
19@@ -1852,7 +1852,7 @@ AG_GST_CHECK_FEATURE(OPENCV, [opencv plugins], opencv, [
20 HAVE_OPENCV="yes"
21 fi
22 ], [
23- PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.1.0] , [
24+ PKG_CHECK_MODULES([OPENCV], [opencv4 >= 4.0.0 opencv4 < 4.2.0] , [
25 AC_PROG_CXX
26 AC_LANG([C++])
27 OLD_CPPFLAGS=$CPPFLAGS
28diff --git a/ext/opencv/meson.build b/ext/opencv/meson.build
29index d0ce1d3ee..f38b55dfe 100644
30--- a/ext/opencv/meson.build
31+++ b/ext/opencv/meson.build
32@@ -65,7 +65,7 @@ if opencv_found
33 endif
34 endforeach
35 else
36- opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.1.0'], required : false)
37+ opencv_dep = dependency('opencv4', version : ['>= 4.0.0', '< 4.2.0'], required : false)
38 opencv_found = opencv_dep.found()
39 if opencv_found
40 foreach h : libopencv4_headers
41--
422.17.1
43
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
index e64d29fa..59aeca11 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-bad_1.16.imx.bb
@@ -20,7 +20,7 @@ SRC_URI = " \
20 file://0001-ext-wayland-fix-meson-build-in-nxp-fork.patch \ 20 file://0001-ext-wayland-fix-meson-build-in-nxp-fork.patch \
21 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \ 21 file://0001-meson-build-gir-even-when-cross-compiling-if-introsp.patch \
22 file://0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch \ 22 file://0001-meson-fix-build-with-opencv-enabled-and-opencv4.-Fix.patch \
23 file://0002-opencv-allow-compilation-against-4.1.x.patch \ 23 file://0001-opencv-allow-compilation-against-4.3.x.patch \
24 file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \ 24 file://opencv-resolve-missing-opencv-data-dir-in-yocto-buil.patch \
25 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \ 25 file://fix-maybe-uninitialized-warnings-when-compiling-with-Os.patch \
26 file://avoid-including-sys-poll.h-directly.patch \ 26 file://avoid-including-sys-poll.h-directly.patch \