summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChunrong Guo <chunrong.guo@nxp.com>2017-11-09 15:13:06 +0800
committerOtavio Salvador <otavio@ossystems.com.br>2017-11-10 13:59:35 -0200
commit07e344d4ef22d6f88d297c55e09b112157b0cff8 (patch)
tree7b4c47c9cea151b7c630d360f162624b4ada6215
parentb5f2a417b8e783b77b295ff91e52dcd361a497d0 (diff)
downloadmeta-freescale-07e344d4ef22d6f88d297c55e09b112157b0cff8.tar.gz
ceetm: update recipes
*Fix wrong md5sum of license file fix the below error: |ERROR: ceetm-git-r0 do_populate_lic: QA Issue: ceetm: The LIC_FILES_CHKSUM does not | match for file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287 *Change git repository URL *Update to f58304d This includes the following changes: f58304d - Update Copyright owners 6fe89a0 - ceetm: use IPROUTE2_DIR in build include path for LSDK 896094f - ceetm: update include path for LSDK/flex-builder 74f2393 - ceetm: fix small compiler warnings 20be45f - ceetm: restructure sources for LSDK integration *Add iproute2 on DEPENDS because ceetms compile depend heard file in iproute2-dbg package *Update EXTRA_OEMAKE set *Fix the installation directory fix the below error: |cp: cannot stat 'aarch64-qoriq-poky-linux/ceetm/git-r0/git/bin/q_ceetm.so': No such file or directory *Update COMPATIBLE_MACHINE for ls2088a and ls1088a Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-kernel/ceetm/ceetm_git.bb14
1 files changed, 8 insertions, 6 deletions
diff --git a/recipes-kernel/ceetm/ceetm_git.bb b/recipes-kernel/ceetm/ceetm_git.bb
index 44ca577e..e56b74da 100644
--- a/recipes-kernel/ceetm/ceetm_git.bb
+++ b/recipes-kernel/ceetm/ceetm_git.bb
@@ -1,22 +1,24 @@
1DESCRIPTION = "CEETM TC QDISC" 1DESCRIPTION = "CEETM TC QDISC"
2LICENSE = "GPLv2 & BSD" 2LICENSE = "GPLv2 & BSD"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b5881ecf398da8a03a3f4c501e29d287" 3LIC_FILES_CHKSUM = "file://COPYING;md5=dde0931a586dd5b30076639e29ba3a7b"
4 4
5SRC_URI = "git://git.freescale.com/ppc/sdk/ceetm.git;branch=sdk-v2.0.x" 5SRC_URI = "git://github.com/qoriq-open-source/ceetm.git;nobranch=1"
6SRCREV = "a237e094c3316a55727b855d15480e664545316a" 6SRCREV = "f58304d7e2185003d0f4ff604bc8e4316d463a03"
7
8DEPENDS = "iproute2"
7 9
8S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
9 11
10EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SYSROOT=${STAGING_DIR_TARGET}" 12EXTRA_OEMAKE = 'CC="${CC}" LD="${CC}" IPROUTE2_DIR="{STAGING_DIR_TARGET}"'
11 13
12do_install(){ 14do_install(){
13 mkdir -p ${D}/${libdir}/tc 15 mkdir -p ${D}/${libdir}/tc
14 cp ${S}/bin/q_ceetm.so ${D}/${libdir}/tc/ 16 cp ${S}/q_ceetm.so ${D}/${libdir}/tc/
15} 17}
16 18
17FILES_${PN} += "${libdir}/tc" 19FILES_${PN} += "${libdir}/tc"
18INHIBIT_PACKAGE_STRIP = "1" 20INHIBIT_PACKAGE_STRIP = "1"
19 21
20COMPATIBLE_MACHINE = "(b4|t1|t2|t4|ls1043a|ls1046a)" 22COMPATIBLE_MACHINE = "(b4|t1|t2|t4|ls1043a|ls1046a|ls2088a|ls1088a)"
21PACKAGE_ARCH = "${MACHINE_SOCARCH}" 23PACKAGE_ARCH = "${MACHINE_SOCARCH}"
22 24