diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-09-12 20:41:23 -0700 |
---|---|---|
committer | github-actions[bot] <github-actions[bot]@users.noreply.github.com> | 2022-09-13 10:18:48 +0000 |
commit | 0615a60349ecc9adc07ff41346849e0a1cb20c82 (patch) | |
tree | bb106e690bbcd053503d6cb15b8cf9e41af6a7c8 | |
parent | f9efb4d22669cdade59fe78db524c37fbc67becf (diff) | |
download | meta-freescale-0615a60349ecc9adc07ff41346849e0a1cb20c82.tar.gz |
gstreamer1.0-plugins-base: Fix build with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com>
(cherry picked from commit 8324178f01ddf4b2da9e0b7bcbc4abde0b8c6aa8)
2 files changed, 49 insertions, 0 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch new file mode 100644 index 00000000..19057147 --- /dev/null +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base/0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From 071fd005ad6572767d7441c97549b1c904719944 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Mon, 12 Sep 2022 20:29:25 -0700 | ||
4 | Subject: [PATCH] gstallocatorphymem.c: Typecast result of gst_phymem_get_phy | ||
5 | to guintptr | ||
6 | |||
7 | This fixes a warning/error found with clang-15 | ||
8 | |||
9 | Upstream-Status: Pending | ||
10 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
11 | --- | ||
12 | gst-libs/gst/allocators/gstallocatorphymem.c | 2 +- | ||
13 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
14 | |||
15 | --- a/gst-libs/gst/allocators/gstallocatorphymem.c | ||
16 | +++ b/gst-libs/gst/allocators/gstallocatorphymem.c | ||
17 | @@ -225,7 +225,7 @@ static guintptr | ||
18 | gst_allocator_phymem_get_phys_addr (GstPhysMemoryAllocator * allocator, | ||
19 | GstMemory * mem) | ||
20 | { | ||
21 | - return gst_phymem_get_phy (mem); | ||
22 | + return (guintptr)gst_phymem_get_phy (mem); | ||
23 | } | ||
24 | |||
25 | static void | ||
26 | --- a/gst-libs/gst/gl/gstglphymemory.c | ||
27 | +++ b/gst-libs/gst/gl/gstglphymemory.c | ||
28 | @@ -337,7 +337,7 @@ gst_gl_physical_memory_setup_buffer (Gst | ||
29 | GST_VIDEO_INFO_HEIGHT (info), | ||
30 | viv_fmt, | ||
31 | memblk->vaddr, | ||
32 | - memblk->paddr, | ||
33 | + (guint)memblk->paddr, | ||
34 | FALSE | ||
35 | }; | ||
36 | |||
37 | --- a/gst/subparse/gstssaparse.c | ||
38 | +++ b/gst/subparse/gstssaparse.c | ||
39 | @@ -24,7 +24,9 @@ | ||
40 | #include "config.h" | ||
41 | #endif | ||
42 | |||
43 | +#include <ctype.h> /* isspace() */ | ||
44 | #include <stdlib.h> /* atoi() */ | ||
45 | +#include <stdio.h> /* sscanf() */ | ||
46 | #include <string.h> | ||
47 | |||
48 | #include "gstssaparse.h" | ||
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb index 3fce3a58..ba1b9787 100644 --- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb +++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-base_1.20.0.imx.bb | |||
@@ -17,6 +17,7 @@ SRC_URI = "https://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-ba | |||
17 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ | 17 | file://0001-ENGR00312515-get-caps-from-src-pad-when-query-caps.patch \ |
18 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ | 18 | file://0003-viv-fb-Make-sure-config.h-is-included.patch \ |
19 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ | 19 | file://0002-ssaparse-enhance-SSA-text-lines-parsing.patch \ |
20 | file://0001-gstallocatorphymem.c-Typecast-result-of-gst_phymem_g.patch \ | ||
20 | " | 21 | " |
21 | SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204" | 22 | SRC_URI[sha256sum] = "96d8a6413ba9394fbec1217aeef63741a729d476a505a797c1d5337d8fa7c204" |
22 | 23 | ||