summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2021-04-16 15:12:25 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2021-04-16 15:12:25 -0300
commitaa2ee360b2bb0278bffb92f474fbfbf300ad7968 (patch)
treec67396b8c3d44c0717e030418831a2f8112bbeeb
parent33653d391b7f8bd9f932e613da46c2f61f2fc336 (diff)
downloadmeta-freescale-topic/drop-native-tools.tar.gz
u-boot-imx-tools: Drop i.MX specific toolstopic/drop-native-tools
We are building same tools as the original U-Boot thus we should rely on them. This is critical as native tools cannot vary between machines as there are no clear reason to convert this to be a cross tool as we build no machine specific code. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/include/imx-base.inc5
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb15
2 files changed, 0 insertions, 20 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 14008927..16d48da9 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -67,15 +67,10 @@ UBOOT_SUFFIX ?= "${UBOOT_SUFFIX_pn-${IMX_DEFAULT_BOOTLOADER}}"
67# wic based images. 67# wic based images.
68SPL_BINARY ??= "${@get_spl_binary(d)}" 68SPL_BINARY ??= "${@get_spl_binary(d)}"
69 69
70IMX_DEFAULT_UBOOTTOOLS = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-tools', 'u-boot-tools', d)}"
71IMX_DEFAULT_MFGTOOL = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-mfgtool', 'u-boot-fslc', d)}" 70IMX_DEFAULT_MFGTOOL = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-mfgtool', 'u-boot-fslc', d)}"
72 71
73PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}" 72PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}"
74PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_MFGTOOL}" 73PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_MFGTOOL}"
75PREFERRED_PROVIDER_u-boot-tools-native ??= "${IMX_DEFAULT_UBOOTTOOLS}-native"
76PREFERRED_PROVIDER_nativesdk-u-boot-tools ??= "nativesdk-${IMX_DEFAULT_UBOOTTOOLS}"
77PREFERRED_PROVIDER_u-boot-mkimage-native ??= "${IMX_DEFAULT_UBOOTTOOLS}-native"
78PREFERRED_PROVIDER_nativesdk-u-boot-mkimage ??= "nativesdk-${IMX_DEFAULT_UBOOTTOOLS}"
79PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}" 74PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}"
80 75
81PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native" 76PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native"
diff --git a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb b/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb
deleted file mode 100644
index d1e9512c..00000000
--- a/recipes-bsp/u-boot/u-boot-imx-tools_2020.04.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1require recipes-bsp/u-boot/u-boot-tools.inc
2require u-boot-imx-common.inc
3
4PROVIDES_append_class-target = " ${MLPREFIX}u-boot-tools"
5PROVIDES_append_class-native = " u-boot-tools-native"
6PROVIDES_append_class-nativesdk = " nativesdk-u-boot-tools"
7
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10# Set recipe as incompatible by default
11COMPATIBLE_MACHINE = "(^$)"
12
13# Whitelist its use for i.MX based machines
14COMPATIBLE_MACHINE_use-mainline-bsp = "(.)"
15COMPATIBLE_MACHINE_use-nxp-bsp = "(.)"