summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2023-02-11 17:32:16 -0300
committerOtavio Salvador <otavio@ossystems.com.br>2023-04-12 20:09:28 -0300
commit88399694f0d4bd8da30b562ba69a6e9d76d5046c (patch)
treef0176429493ef7e01f5158ae8e9628d78ad4f9d0
parent56ba9c32d6b3029fb1c2b3fc8ea8778d62f396a8 (diff)
downloadmeta-freescale-rework/remove-mfgtool-specific-recipes.tar.gz
linux-*-mfgtool, u-boot-*-mfgtool: Remove specific recipesrework/remove-mfgtool-specific-recipes
The use of a specific recipes are not need anymore. For the U-Boot specific case, the UBOOT_CONFIG mechanism allows multiple binaries using different configurations so we can remove this recipes and default to the IMX_DEFAULT_BOOTLOADER as provider. The Linux specific case is completely unnecessary as the USB gadget is supported in all versions we support. Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--conf/machine/include/imx-base.inc4
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb8
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2023.01.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb13
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2022.04.bb2
-rw-r--r--recipes-bsp/u-boot/u-boot-mfgtool.inc21
-rw-r--r--recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb15
-rw-r--r--recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb15
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_6.1.bb15
-rw-r--r--recipes-kernel/linux/linux-imx.inc3
-rw-r--r--recipes-kernel/linux/linux-mfgtool.inc7
11 files changed, 6 insertions, 99 deletions
diff --git a/conf/machine/include/imx-base.inc b/conf/machine/include/imx-base.inc
index 7ff2741d..0959dfe3 100644
--- a/conf/machine/include/imx-base.inc
+++ b/conf/machine/include/imx-base.inc
@@ -75,10 +75,8 @@ UBOOT_SUFFIX ?= "${UBOOT_SUFFIX:pn-${IMX_DEFAULT_BOOTLOADER}}"
75# wic based images. 75# wic based images.
76SPL_BINARY ??= "${@get_spl_binary(d)}" 76SPL_BINARY ??= "${@get_spl_binary(d)}"
77 77
78IMX_DEFAULT_MFGTOOL = "${@bb.utils.contains('IMX_DEFAULT_BOOTLOADER', 'u-boot-imx','u-boot-imx-mfgtool', 'u-boot-fslc', d)}"
79
80PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}" 78PREFERRED_PROVIDER_u-boot ??= "${IMX_DEFAULT_BOOTLOADER}"
81PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_MFGTOOL}" 79PREFERRED_PROVIDER_u-boot-mfgtool ??= "${IMX_DEFAULT_BOOTLOADER}"
82PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}" 80PREFERRED_PROVIDER_virtual/bootloader ??= "${IMX_DEFAULT_BOOTLOADER}"
83 81
84PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native" 82PREFERRED_PROVIDER_u-boot-mxsboot-native ??= "u-boot-fslc-mxsboot-native"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb
deleted file mode 100644
index 2e79166b..00000000
--- a/recipes-bsp/u-boot/u-boot-fslc-mfgtool_2023.01.bb
+++ /dev/null
@@ -1,8 +0,0 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright 2017-2019 NXP
4
5FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-fslc:"
6
7require u-boot-fslc_${PV}.bb
8require u-boot-mfgtool.inc
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
index f6164a76..eba8876a 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2023.01.bb
@@ -10,7 +10,7 @@ inherit ${@oe.utils.ifelse(d.getVar('UBOOT_PROVIDES_BOOT_CONTAINER') == '1', 'im
10 10
11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native" 11DEPENDS += "bc-native dtc-native python3-setuptools-native gnutls-native"
12 12
13PROVIDES += "u-boot" 13PROVIDES += "u-boot u-boot-mfgtool"
14 14
15B = "${WORKDIR}/build" 15B = "${WORKDIR}/build"
16 16
diff --git a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb
deleted file mode 100644
index d9d5b9d5..00000000
--- a/recipes-bsp/u-boot/u-boot-imx-mfgtool_2022.04.bb
+++ /dev/null
@@ -1,13 +0,0 @@
1# Copyright (C) 2014 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright 2017-2019 NXP
4
5# Re-use the u-boot-imx recipe and its files
6require u-boot-imx_${PV}.bb
7FILESEXTRAPATHS:prepend := "${THISDIR}/u-boot-imx:"
8
9require u-boot-mfgtool.inc
10
11UUU_BOOTLOADER_TAGGED = ""
12UUU_BOOTLOADER_TAGGED:mx6-nxp-bsp = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
13UUU_BOOTLOADER_TAGGED:mx7-nxp-bsp = "u-boot-mfgtool-tagged.${UBOOT_SUFFIX}"
diff --git a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
index c8119fdb..e76c29c6 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2022.04.bb
@@ -5,7 +5,7 @@
5require recipes-bsp/u-boot/u-boot.inc 5require recipes-bsp/u-boot/u-boot.inc
6require u-boot-imx-common_${PV}.inc 6require u-boot-imx-common_${PV}.inc
7 7
8PROVIDES += "u-boot" 8PROVIDES += "u-boot u-boot-mfgtool"
9 9
10inherit uuu_bootloader_tag 10inherit uuu_bootloader_tag
11 11
diff --git a/recipes-bsp/u-boot/u-boot-mfgtool.inc b/recipes-bsp/u-boot/u-boot-mfgtool.inc
deleted file mode 100644
index 92d055bf..00000000
--- a/recipes-bsp/u-boot/u-boot-mfgtool.inc
+++ /dev/null
@@ -1,21 +0,0 @@
1# Produces a Manufacturing Tool compatible U-Boot
2#
3# This makes a separated binary set for Manufacturing Tool use
4# without clobbering the U-Boot used for normal use.
5#
6# This file must to be included after the original u-boot.inc file,
7# as it overrides the need values.
8#
9# Copyright (C) 2014 O.S. Systems Software LTDA.
10
11# Adjust provides
12PROVIDES = "u-boot-mfgtool"
13
14# Use 'mfgtool' config
15UBOOT_CONFIG = "mfgtool"
16
17# Add 'mfgtool' suffix
18UBOOT_IMAGE = "u-boot-${MACHINE}-mfgtool-${PV}-${PR}.${UBOOT_SUFFIX}"
19UBOOT_SYMLINK = "u-boot-${MACHINE}-mfgtool.${UBOOT_SUFFIX}"
20SPL_IMAGE = "${SPL_BINARYNAME}-${MACHINE}-mfgtool-${PV}-${PR}"
21SPL_SYMLINK = "${SPL_BINARYNAME}-mfgtool-${MACHINE}"
diff --git a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb b/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb
deleted file mode 100644
index 95dd72fb..00000000
--- a/recipes-kernel/linux/linux-fslc-lts-mfgtool_5.15.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3
4SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc-lts_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb b/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb
deleted file mode 100644
index 09d35c91..00000000
--- a/recipes-kernel/linux/linux-fslc-mfgtool_6.1.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3
4SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
5DESCRIPTION = "Linux Kernel provided and supported by the Freescale Community \
6that produces a Manufacturing Tool compatible Linux Kernel to be used in updater \
7environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-fslc:"
10require linux-fslc_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb b/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb
deleted file mode 100644
index 26298fd9..00000000
--- a/recipes-kernel/linux/linux-imx-mfgtool_6.1.bb
+++ /dev/null
@@ -1,15 +0,0 @@
1# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
2# Copyright (C) 2014-2016 Freescale Semiconductor
3# Copyright (C) 2017-2023 NXP
4
5SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
6DESCRIPTION = "Linux Kernel provided and supported by NXP that produces a \
7Manufacturing Tool compatible Linux Kernel to be used in updater environment"
8
9FILESEXTRAPATHS:prepend := "${THISDIR}/linux-imx:"
10require linux-imx_${PV}.bb
11require linux-mfgtool.inc
12
13KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
14MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
15do_package[vardepsexclude] = "DATETIME"
diff --git a/recipes-kernel/linux/linux-imx.inc b/recipes-kernel/linux/linux-imx.inc
index b386e058..1a37bf20 100644
--- a/recipes-kernel/linux/linux-imx.inc
+++ b/recipes-kernel/linux/linux-imx.inc
@@ -11,6 +11,9 @@ LOCALVERSION ?= ""
11SCMVERSION ?= "y" 11SCMVERSION ?= "y"
12SRCBRANCH ?= "" 12SRCBRANCH ?= ""
13 13
14# Allow use of kernel as linux-mfgtool provider.
15PROVIDES += "linux-mfgtool"
16
14# Set the PV to the correct kernel version to satisfy the kernel version sanity check 17# Set the PV to the correct kernel version to satisfy the kernel version sanity check
15PV = "${LINUX_VERSION}+git${SRCPV}" 18PV = "${LINUX_VERSION}+git${SRCPV}"
16 19
diff --git a/recipes-kernel/linux/linux-mfgtool.inc b/recipes-kernel/linux/linux-mfgtool.inc
deleted file mode 100644
index 93a27d8c..00000000
--- a/recipes-kernel/linux/linux-mfgtool.inc
+++ /dev/null
@@ -1,7 +0,0 @@
1# Produces a Manufacturing Tool compatible Linux Kernel
2#
3# Copyright (C) 2014, 2015, 2018 O.S. Systems Software LTDA.
4
5PROVIDES = "linux-mfgtool"
6
7KERNEL_PACKAGE_NAME = "linux-mfgtool"