summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWalter Schweizer <walter.schweizer@siemens.com>2023-02-03 15:27:04 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2023-02-05 20:33:25 +0000
commit2d3157e6deb01c84ae5d9f0bb839227a400a9f03 (patch)
tree0fb5a2793209461452e3d122f0252ce6e3a88712
parent12861dcfb747c3a471663d095b56e36b6f45cb1c (diff)
downloadmeta-freescale-backport-1407-to-kirkstone.tar.gz
imx-cst: fix build issue for Ubuntu 22.04(LTS)backport-1407-to-kirkstone
On Ubuntu 22.04(LTS) cst fails to link with libcrypto. NXP uses weaken to solve a conflict in linking. The linker in Ubuntu seems to ignore weak symbols does not link libcrypto at all. The patch fixes the conflict in the code itself. It restricts the scope of err_msg to the module. Signed-off-by: Walter Schweizer <walter.schweizer@siemens.com> (cherry picked from commit c731dcbe2ddbaa57c37e4ec8362752c9b96ab13d)
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch56
-rw-r--r--dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb5
2 files changed, 60 insertions, 1 deletions
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch b/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
new file mode 100644
index 00000000..a3f5c828
--- /dev/null
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/files/0001-fix-err-msg-linking.patch
@@ -0,0 +1,56 @@
1NXP uses weaken to solve conflict in linking.
2On Ubuntu 22.04(LTS) this fails to link cst with libcrypto.
3
4The patch fixes the conflict in the code itself.
5It restricts the scope of err_msg to the module.
6
7Upstream-Status: Inappropriate [i.MX specific]
8Signed-off-by: Walter Schweizer <walter.schweizer@siemens.com>
9----
10diff --git a/code/cst/code/build/make/rules.mk b/code/cst/code/build/make/rules.mk
11index 1c0842b..9c46cc4 100644
12--- a/code/cst/code/build/make/rules.mk
13+++ b/code/cst/code/build/make/rules.mk
14@@ -25,11 +25,11 @@ LFLAGS := -t
15 %.a:
16 @echo "Create archive $@"
17 $(AR) $(ARFLAGS) $@ $^
18-ifneq ($(OSTYPE),mingw32)
19-ifneq ($(OSTYPE),osx)
20- $(OBJCOPY) --weaken $@
21-endif
22-endif
23+#ifneq ($(OSTYPE),mingw32)
24+#ifneq ($(OSTYPE),osx)
25+# $(OBJCOPY) --weaken $@
26+#endif
27+#endif
28
29 %.exe:
30 @echo "Link $@"
31diff --git a/code/cst/code/front_end/src/acst.c b/code/cst/code/front_end/src/acst.c
32index fb1e8aa..1e993ee 100644
33--- a/code/cst/code/front_end/src/acst.c
34+++ b/code/cst/code/front_end/src/acst.c
35@@ -65,7 +65,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
36 /*===========================================================================
37 LOCAL VARIABLES
38 =============================================================================*/
39-char err_msg[MAX_ERR_MSG_BYTES];
40+static char err_msg[MAX_ERR_MSG_BYTES];
41
42 /*===========================================================================
43 LOCAL FUNCTION PROTOTYPES
44diff --git a/code/cst/code/front_end/src/misc_helper.c b/code/cst/code/front_end/src/misc_helper.c
45index 678dc17..9014b2a 100644
46--- a/code/cst/code/front_end/src/misc_helper.c
47+++ b/code/cst/code/front_end/src/misc_helper.c
48@@ -60,7 +60,7 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
49 /*===========================================================================
50 LOCAL VARIABLES
51 =============================================================================*/
52-char err_msg[MAX_ERR_MSG_BYTES];
53+static char err_msg[MAX_ERR_MSG_BYTES];
54
55 /*===========================================================================
56 LOCAL FUNCTION PROTOTYPES
diff --git a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb
index 317ca379..5f808a97 100644
--- a/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb
+++ b/dynamic-layers/openembedded-layer/recipes-devtools/cst/imx-cst_3.3.1.bb
@@ -9,7 +9,10 @@ DEPENDS = "byacc-native flex-native openssl"
9 9
10# tag=debian/3.3.1+dfsg-2 10# tag=debian/3.3.1+dfsg-2
11SRCREV = "e2c687a856e6670e753147aacef42d0a3c07891a" 11SRCREV = "e2c687a856e6670e753147aacef42d0a3c07891a"
12SRC_URI = "git://gitlab.apertis.org/pkg/imx-code-signing-tool.git;protocol=https;branch=apertis/v2022pre" 12SRC_URI = " \
13 file://0001-fix-err-msg-linking.patch \
14 git://gitlab.apertis.org/pkg/imx-code-signing-tool.git;protocol=https;branch=apertis/v2022pre \
15"
13 16
14S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
15 18