summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Krummenacher <max.krummenacher@toradex.com>2022-11-24 17:59:00 +0100
committergithub-actions[bot] <github-actions[bot]@users.noreply.github.com>2022-11-25 19:46:41 +0000
commit483e89b6e900daa70ea7abefda84909258eab57e (patch)
tree29d182bfd8328aa0df6d2c06861c5e8419682bd7
parenta263884753a4b452f4f90b4981d21d199401ed9d (diff)
downloadmeta-freescale-483e89b6e900daa70ea7abefda84909258eab57e.tar.gz
isp-imx: prevent oe qa warning
As the recipe installs the file 'by hand' rather than using `make install` make sure that the binaries get their final RPATH set during do_compile rather than relying on the CMake produced RPATH magic in `make install`. | WARNING: isp-imx-4.2.2.19.0-r0 do_package_qa: QA Issue: File /usr/lib/libmedia_server.so in package isp-imx contains reference to TMPDIR | File /opt/imx8-isp/bin/isp_media_server in package isp-imx contains reference to TMPDIR [buildpaths] With this the 'INSANE_SKIP:${PN} = "rpaths"' is also no longer needed as the following error is also gone: | ERROR: isp-imx-4.2.2.19.0-r0 do_package_qa: QA Issue: package isp-imx contains bad RPATH $ORIGIN:/.../isp-imx-4.2.2.19.0/dewarp/proprietories/hal/lib: in file .../packages-split/isp-imx/usr/lib/libmedia_server.so | package isp-imx contains bad RPATH $ORIGIN/.../isp-imx-4.2.2.19.0/dewarp/proprietories/hal/lib in file .../packages-split/isp-imx/opt/imx8-isp/bin/isp_media_server [rpaths] Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> (cherry picked from commit 58ccfda536668e7108111493a4f328e0e42b2cae)
-rw-r--r--recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb b/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
index ae96299a..19d0cba7 100644
--- a/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
+++ b/recipes-bsp/isp-imx/isp-imx_4.2.2.19.0.bb
@@ -25,6 +25,7 @@ SYSTEMD_SERVICE:${PN} = "imx8-isp.service"
25EXTRA_OECMAKE += " \ 25EXTRA_OECMAKE += " \
26 -DSDKTARGETSYSROOT=${STAGING_DIR_HOST} \ 26 -DSDKTARGETSYSROOT=${STAGING_DIR_HOST} \
27 -DCMAKE_BUILD_TYPE=release \ 27 -DCMAKE_BUILD_TYPE=release \
28 -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON \
28 -DISP_VERSION=ISP8000NANO_V1802 \ 29 -DISP_VERSION=ISP8000NANO_V1802 \
29 -DPLATFORM=ARM64 \ 30 -DPLATFORM=ARM64 \
30 -DAPPMODE=V4L2 \ 31 -DAPPMODE=V4L2 \
@@ -83,8 +84,6 @@ FILES_SOLIBS_VERSIONED = " \
83FILES:${PN} += "/opt ${libdir}/lib*${SOLIBSDEV}" 84FILES:${PN} += "/opt ${libdir}/lib*${SOLIBSDEV}"
84FILES:${PN}-dev += "${FILES_SOLIBS_VERSIONED}" 85FILES:${PN}-dev += "${FILES_SOLIBS_VERSIONED}"
85 86
86INSANE_SKIP:${PN} = "rpaths"
87
88RDEPENDS:${PN} = "libdrm" 87RDEPENDS:${PN} = "libdrm"
89 88
90COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)" 89COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp)"