summaryrefslogtreecommitdiffstats
path: root/recipes-test/udt/udt_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/udt/udt_git.bb')
-rw-r--r--recipes-test/udt/udt_git.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/recipes-test/udt/udt_git.bb b/recipes-test/udt/udt_git.bb
new file mode 100644
index 0000000..a2fa358
--- /dev/null
+++ b/recipes-test/udt/udt_git.bb
@@ -0,0 +1,46 @@
1SUMMARY = "UDP-based Data Transfer"
2DESCRIPTION = "UDT is a reliable UDP based application level data transport protocol for distributed data intensive applications over wide area high-speed networks."
3HOMEPAGE = "http://udt.sourceforge.net/"
4SECTION = "net/utils"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=567e8c8da655afbe9ad8ec73696cc31e"
7
8SRCREV = "6b4216d8a4c9b8e1e9413ad6cf473f71e7b80502"
9SRC_URI = "git://git.code.sf.net/p/udt/git \
10 file://0001-Makefile-use-g-from-environment-if-available.patch;striplevel=2 \
11 file://0002-Makefile-Add-support-for-building-on-powerpc64.patch;striplevel=2 \
12 file://0003-Makefile-Add-support-for-building-on-ARM7.patch;striplevel=2 \
13 "
14
15S = "${WORKDIR}/git/udt4"
16B = "${S}"
17
18FILES_${PN} = "${bindir}/sendfile ${bindir}/recvfile ${libdir}/libudt.so"
19FILES_${PN}-dbg = "${bindir}/.debug/* ${libdir}/.debug/*"
20FILES_${PN}-dev = ""
21
22# UDT has a non-standard way of representing architectures
23def get_udt_arch(bb, d):
24 target_arch = bb.data.getVar('TARGET_ARCH', d, 1)
25 arch_map = {
26 'i386': 'IA32',
27 'x86_64': 'AMD64',
28 'powerpc': 'POWERPC',
29 'powerpc64': 'POWERPC64',
30 'ia64': 'IA64',
31 'arm': 'ARM7',
32 }
33 # Let non-existant arches trigger a KeyError
34 return arch_map[target_arch]
35
36do_compile() {
37 make -C ${S} os=LINUX arch=${@get_udt_arch(bb, d)}
38}
39
40do_install() {
41 install -m 0755 -d ${D}/${bindir}
42 install -m 0755 ${S}/app/sendfile ${D}/${bindir}
43 install -m 0755 ${S}/app/recvfile ${D}/${bindir}
44 install -m 0755 -d ${D}/${libdir}
45 install -m 0755 ${S}/src/libudt.so ${D}/${libdir}
46}