summaryrefslogtreecommitdiffstats
path: root/recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch')
-rw-r--r--recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch44
1 files changed, 44 insertions, 0 deletions
diff --git a/recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch b/recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch
new file mode 100644
index 0000000..c7c1b02
--- /dev/null
+++ b/recipes-test/udt/files/0001-Makefile-use-g-from-environment-if-available.patch
@@ -0,0 +1,44 @@
1From 7a8fce8a763f4ce5d750916cc0aae0c47e6d0a1b Mon Sep 17 00:00:00 2001
2From: Josep Puigdemont <josep.puigdemont@enea.com>
3Date: Thu, 8 May 2014 14:49:21 +0200
4Subject: [PATCH 1/2] Makefile: use g++ from environment if available
5
6Signed-off-by: Josep Puigdemont <josep.puigdemont@enea.com>
7
8Upstream-Status: Pending
9---
10 udt4/app/Makefile | 6 +++++-
11 udt4/src/Makefile | 6 +++++-
12 2 files changed, 10 insertions(+), 2 deletions(-)
13
14diff --git a/udt4/app/Makefile b/udt4/app/Makefile
15index 9d16c0f..0ee2562 100644
16--- a/udt4/app/Makefile
17+++ b/udt4/app/Makefile
18@@ -1,4 +1,8 @@
19-C++ = g++
20+ifndef CXX
21+ C++ = g++
22+else
23+ C++ = $(CXX)
24+endif
25
26 ifndef os
27 os = LINUX
28diff --git a/udt4/src/Makefile b/udt4/src/Makefile
29index bc1e049..1f64b8d 100644
30--- a/udt4/src/Makefile
31+++ b/udt4/src/Makefile
32@@ -1,4 +1,8 @@
33-C++ = g++
34+ifndef CXX
35+ C++ = g++
36+else
37+ C++ = $(CXX)
38+endif
39
40 ifndef os
41 os = LINUX
42--
431.9.0
44