summaryrefslogtreecommitdiffstats
path: root/recipes-test/autotest
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/autotest')
-rw-r--r--recipes-test/autotest/autotest.inc17
-rw-r--r--recipes-test/autotest/autotest_0.16.0.bb7
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes-test/autotest/autotest.inc b/recipes-test/autotest/autotest.inc
new file mode 100644
index 0000000..c9ac55e
--- /dev/null
+++ b/recipes-test/autotest/autotest.inc
@@ -0,0 +1,17 @@
1SUMMARY = "Autotest framework"
2DESCRIPTION = "Autotest - fully automated testing under linux."
3HOMEPAGE = "http://autotest.github.io"
4SECTION = "console/tests"
5LICENSE = "GPLv2 & BSD & LGPLv2+ & MIT"
6
7SRC_URI = "https://github.com/autotest/autotest/archive/${PV}.tar.gz"
8
9FILES_${PN} += "/opt /etc/profile.d/autotest.sh"
10
11do_install() {
12 install -d ${D}/opt/${PN}
13 cp -r ${B}/* ${D}/opt/${PN}
14
15 mkdir -p ${D}/etc/profile.d/
16 echo "export AUTOTEST_PATH=/opt/${PN}" > ${D}/etc/profile.d/autotest.sh
17}
diff --git a/recipes-test/autotest/autotest_0.16.0.bb b/recipes-test/autotest/autotest_0.16.0.bb
new file mode 100644
index 0000000..d81b39f
--- /dev/null
+++ b/recipes-test/autotest/autotest_0.16.0.bb
@@ -0,0 +1,7 @@
1require autotest.inc
2
3SRC_URI[md5sum] = "505936dcf2e81daad3231f23ccea1153"
4SRC_URI[sha256sum] = "8008c2a8d8456cf007d3089a8590dd6d28d51e57c4d4ebaf7d3b3ac3e2dc422e"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=46bdd99511e3434a768b5e0998fe295a \
7 file://LGPL_LICENSE;md5=18b09a20dd186af4fd60f1a08311628c"