summaryrefslogtreecommitdiffstats
path: root/recipes-extra/virt-manager/virt-manager_1.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extra/virt-manager/virt-manager_1.0.0.bb')
-rw-r--r--recipes-extra/virt-manager/virt-manager_1.0.0.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/recipes-extra/virt-manager/virt-manager_1.0.0.bb b/recipes-extra/virt-manager/virt-manager_1.0.0.bb
new file mode 100644
index 0000000..21ad3bb
--- /dev/null
+++ b/recipes-extra/virt-manager/virt-manager_1.0.0.bb
@@ -0,0 +1,72 @@
1SUMMARY = "virt-manager"
2DESCRIPTION = "virt-manager"
3HOMEPAGE = "http://virt-manager.org"
4SECTION = "devel"
5
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8
9SRC_URI = "https://fedorahosted.org/released/virt-manager/virt-manager-${PV}.tar.gz"
10SRC_URI[sha256sum] = "2b2f59f7fccd2fcfbaf4306e33342e5d2be8f0ddd71af9eeca0c1f215e1e29aa"
11SRC_URI[md5sum] = "8a0585de48d8060a5394aae912342c95"
12
13sharedir = "${datadir}"
14
15FILES_${PN} = " \
16 ${bindir}/virt-clone \
17 ${bindir}/virt-image \
18 ${bindir}/virt-install \
19 ${bindir}/virt-convert \
20 ${bindir}/virt-xml \
21 ${sharedir}/virt-manager/virt-clone \
22 ${sharedir}/virt-manager/virt-image \
23 ${sharedir}/virt-manager/virt-install \
24 ${sharedir}/virt-manager/virt-convert \
25 ${sharedir}/virt-manager/virt-xml \
26 ${sharedir}/virt-manager/virtinst \
27 ${sharedir}/virt-manager/virtconv \
28 ${sharedir}/virt-manager/virtcli \
29 \
30 ${sharedir}/virt-manager/virt-manager \
31 ${sharedir}/virt-manager/virtManager \
32 ${sharedir}/virt-manager/ui \
33 ${sharedir}/virt-manager/icons \
34 ${sharedir}/icons \
35 ${sharedir}/appdata \
36 ${sharedir}/applications \
37 ${sharedir}/glib-2.0 \
38 ${@base_contains('DISTRO_FEATURES', 'x11', '${bindir}/virt-manager', '', d)} \
39 "
40
41DEPENDS = "nativesdk-perl"
42
43RDEPENDS_${PN} = " \
44 libvirt-python \
45 python-urlgrabber \
46 libxml2-python \
47 ${@base_contains('DISTRO_FEATURES', 'x11', 'python-pygtk', '', d)} \
48 "
49
50
51do_configure() {
52 python setup.py configure
53}
54
55do_build() {
56 python setup.py build --prefix=${prefix}
57}
58
59# virt-manager is the only command that requires graphical libraries. The
60# package does however not supply a --no-graphics argument or such to the
61# install program, which is understandable since distutils (which is
62# undocumented to a large degree) seems to be called with the complete file
63# list before the argument parsing is performed. To avoid that this command is
64# available when the package is built as part of a non-x11 distro, remove the
65# /usr/bin/virt-manager file.
66
67REMOVE_COMMAND = "${@base_contains('DISTRO_FEATURES', 'x11', '', 'rm ${D}${bindir}/virt-manager', d)}"
68do_install() {
69 python setup.py install --prefix=${prefix} --root=${D}
70
71 sh -c "${REMOVE_COMMAND}"
72}