summaryrefslogtreecommitdiffstats
path: root/recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb')
-rw-r--r--recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb b/recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb
new file mode 100644
index 0000000..97dab20
--- /dev/null
+++ b/recipes-extra/python-urlgrabber/python-urlgrabber_3.10.1.bb
@@ -0,0 +1,37 @@
1DESCRIPTION = "urlgrabber is a pure python package that drastically simplifies the fetching of files."
2
3HOMEPAGE = "http://urlgrabber.baseurl.org/"
4SECTION = "devel/python"
5PRIORITY = "optional"
6LICENSE = "LGPL2.1+"
7PR = "r1"
8
9LIC_FILES_CHKSUM = "file://LICENSE;md5=68ad62c64cc6c620126241fd429e68fe"
10
11SRC_URI = "http://urlgrabber.baseurl.org/download/urlgrabber-${PV}.tar.gz \
12 file://pycurl-curl.patch"
13
14S = "${WORKDIR}/urlgrabber-${PV}"
15
16SRC_URI[md5sum] = "1f5dc63805623cc473e06204fd240bb2"
17SRC_URI[sha256sum] = "06b13ff8d527dba3aee04069681b2c09c03117592d5485a80ae4b807cdf33476"
18
19RDEPENDS_${PN} = "python-pycurl"
20
21inherit distutils
22
23FILES_${PN} += "/usr/share/libexec"
24
25# setup.py will try to include the urlgrabber package, which fails since we
26# don't have pycurl in the native sysroot. It's included just to get the
27# version and description text strings for inclusion in the package. Avoid this
28# by dynamically creating a version of urlgrabber that does not include the
29# actual urlgrabber features, that setup.py can include.
30do_patch() {
31 # Create a non-importing version of urlgrabber for the setup script
32 mkdir ${S}/urlgrabber_version
33 sed 's/^from grabber import.*//' ${S}/urlgrabber/__init__.py > ${S}/urlgrabber_version/__init__.py
34
35 # Make sure the setup script uses the version-only urlgrabber
36 sed -i 's/import urlgrabber/&_version/' ${S}/setup.py
37}