summaryrefslogtreecommitdiffstats
path: root/recipes-append/libxml/libxml2_2.9.1.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-append/libxml/libxml2_2.9.1.bbappend')
-rw-r--r--recipes-append/libxml/libxml2_2.9.1.bbappend26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-append/libxml/libxml2_2.9.1.bbappend b/recipes-append/libxml/libxml2_2.9.1.bbappend
new file mode 100644
index 0000000..98745d8
--- /dev/null
+++ b/recipes-append/libxml/libxml2_2.9.1.bbappend
@@ -0,0 +1,26 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
2
3SRC_URI += "file://configure-Add-with-python-install-dir.patch"
4
5PACKAGES += "${PN}-python ${PN}-python-staticdev ${PN}-python-dbg"
6
7DEPENDS += "python-dev"
8
9FILES_${PN}-python = " \
10 ${PYTHON_SITEPACKAGES_DIR}/libxml2mod.so \
11 ${PYTHON_SITEPACKAGES_DIR}/drv_libxml2.py \
12 ${PYTHON_SITEPACKAGES_DIR}/libxml2.py \
13 "
14FILES_${PN}-python-staticdev += " \
15 ${PYTHON_SITEPACKAGES_DIR}/libxml2mod.a \
16 ${PYTHON_SITEPACKAGES_DIR}/libxml2mod.la \
17 "
18FILES_${PN}-python-dbg += " \
19 ${PYTHON_SITEPACKAGES_DIR}/.debug/libxml2mod.so \
20 "
21
22# +: --with-catalog, --with-python-install-dir
23EXTRA_OECONF = "--with-python=${STAGING_BINDIR}/python --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} --without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
24
25# +: --with-python-install-dir
26EXTRA_OECONF_linuxstdbase = "--with-python=${STAGING_BINDIR}/python --with-python-install-dir=${PYTHON_SITEPACKAGES_DIR} --with-debug --with-legacy --with-catalog --with-docbook --with-c14n --without-lzma"