summaryrefslogtreecommitdiffstats
path: root/recipes-test/test-nohz-stability
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-test/test-nohz-stability')
-rwxr-xr-xrecipes-test/test-nohz-stability/files/test-nohz-stability37
-rw-r--r--recipes-test/test-nohz-stability/test-nohz-stability.bb21
2 files changed, 58 insertions, 0 deletions
diff --git a/recipes-test/test-nohz-stability/files/test-nohz-stability b/recipes-test/test-nohz-stability/files/test-nohz-stability
new file mode 100755
index 0000000..b65fd96
--- /dev/null
+++ b/recipes-test/test-nohz-stability/files/test-nohz-stability
@@ -0,0 +1,37 @@
1#!/bin/sh
2
3partitioning_done=false
4
5cleanup () {
6 $partitioning_done && partrt undo
7 exit $1
8}
9
10cd /opt/ltp || cleanup 1
11
12# Perform partitioning, if not already done
13if [ ! -d /sys/fs/cgroup/cpuset/rt ]; then
14 partrt create $(list2mask --nohz) || cleanup 1
15 partitioning_done=true
16fi
17
18echo
19echo "*******"
20echo "* NRT *"
21echo "*******"
22echo
23
24partrt run rt stress -i 1 || cleanup 1 &
25CHILD_PID=$!
26partrt run nrt systest-runner || cleanup 1
27kill $CHILD_PID || cleanup 1
28
29echo
30echo "******"
31echo "* RT *"
32echo "******"
33echo
34
35partrt run rt systest-runner || cleanup 1
36
37cleanup 0
diff --git a/recipes-test/test-nohz-stability/test-nohz-stability.bb b/recipes-test/test-nohz-stability/test-nohz-stability.bb
new file mode 100644
index 0000000..5c2405a
--- /dev/null
+++ b/recipes-test/test-nohz-stability/test-nohz-stability.bb
@@ -0,0 +1,21 @@
1
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4INHIBIT_DEFAULT_DEPS = "1"
5
6SRC_URI = "file://${PN} \
7 "
8
9FILES_${PN} += "${bindir}/${PN}"
10
11RDEPENDS_${PN} = "ltp packagegroup-enea-rt-tools systest-runner"
12
13do_install () {
14 install -D ${WORKDIR}/${PN} ${D}${bindir}/${PN}
15}
16
17# Only a script, no need for patch, configure, compile or build
18do_patch[noexec] = "1"
19do_configure[noexec] = "1"
20do_compile[noexec] = "1"
21do_build[noexec] = "1"