summaryrefslogtreecommitdiffstats
path: root/recipes-extended/ltp/ltp/regen-makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/ltp/ltp/regen-makefile.patch')
-rw-r--r--recipes-extended/ltp/ltp/regen-makefile.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes-extended/ltp/ltp/regen-makefile.patch b/recipes-extended/ltp/ltp/regen-makefile.patch
new file mode 100644
index 0000000..3e114a1
--- /dev/null
+++ b/recipes-extended/ltp/ltp/regen-makefile.patch
@@ -0,0 +1,22 @@
1Fix the dependencies for linux_syscall_numbers.h where in a parallel build it was
2finding the temporary file linux_syscall_numbers.h.[pid].sh (where sh is an
3architecture name). Instead don't wildcard *.sh as the only .sh we care about
4here is regen.sh, so hard-code that.
5
6Upstream-Status: Pending
7Signed-off-by: Ross Burton <ross.burton@intel.com>
8
9diff --git a/testcases/kernel/include/Makefile b/testcases/kernel/include/Makefile
10index db21a2a..585eb5e 100644
11--- a/testcases/kernel/include/Makefile
12+++ b/testcases/kernel/include/Makefile
13@@ -28,7 +28,7 @@ INSTALL_DIR := $(includedir)
14
15 MAKE_TARGETS := linux_syscall_numbers.h
16
17-linux_syscall_numbers.h: $(wildcard $(abs_srcdir)/*.sh $(abs_srcdir)/*.in)
18- $(SHELL) "$(abs_srcdir)/regen.sh"
19+linux_syscall_numbers.h: $(abs_srcdir)/regen.sh $(wildcard $(abs_srcdir)/*.in)
20+ $(SHELL) "$<"
21
22 include $(top_srcdir)/include/mk/generic_leaf_target.mk