summaryrefslogtreecommitdiffstats
path: root/recipes-test/oftest
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
commit1b6242fc583a6b871304fb995af6dc211b58f69b (patch)
treeb5d434d90dedae24792906aa304897c23a134386 /recipes-test/oftest
downloadmeta-ip-daisy-enea.tar.gz
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-test/oftest')
-rw-r--r--recipes-test/oftest/oftest_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-test/oftest/oftest_git.bb b/recipes-test/oftest/oftest_git.bb
new file mode 100644
index 0000000..299c693
--- /dev/null
+++ b/recipes-test/oftest/oftest_git.bb
@@ -0,0 +1,27 @@
1SUMMARY = "OFTest"
2DESCRIPTION = "OFTest - an OpenFlow test framework for switches"
3HOMEPAGE = "http://www.projectfloodlight.org/oftest"
4SECTION = "networking"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=7ad8e1e5f1c3d0004a6d449dbce36efe"
7
8PR = "1"
9PV = "0"
10RDEPENDS_${PN} = "python-scapy"
11
12inherit autotools
13
14SRCREV = "47544e410531732ee3603c5dfd255770009a9d96"
15SRC_URI = "git://github.com/floodlight/oftest \
16 "
17
18S = "${WORKDIR}/git"
19B = "${S}"
20
21PACKAGES = "${PN}"
22FILES_${PN} += "/opt/${PN}"
23
24do_install() {
25 install -d ${D}/opt/${PN}
26 cp -r ${S}/* ${D}/opt/${PN}
27}