summaryrefslogtreecommitdiffstats
path: root/recipes-core/numad/numad_0.6.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
commit1b6242fc583a6b871304fb995af6dc211b58f69b (patch)
treeb5d434d90dedae24792906aa304897c23a134386 /recipes-core/numad/numad_0.6.bb
downloadmeta-ip-1b6242fc583a6b871304fb995af6dc211b58f69b.tar.gz
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-core/numad/numad_0.6.bb')
-rw-r--r--recipes-core/numad/numad_0.6.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/recipes-core/numad/numad_0.6.bb b/recipes-core/numad/numad_0.6.bb
new file mode 100644
index 0000000..a6e8ad6
--- /dev/null
+++ b/recipes-core/numad/numad_0.6.bb
@@ -0,0 +1,51 @@
1SUMMARY = "NUMA load distributing daemon"
2DESCRIPTION = 'A user-level daemon that monitors NUMA topology and processes resource \
3consumption to facilitate good NUMA resource access of applications/virtual machines \
4to improve performance and minimize cost of remote memory latencies.'
5HOMEPAGE = "https://git.fedorahosted.org/git/numad.git"
6SECTION = "console/utils"
7
8LICENSE = "LGPLv2.1"
9
10LIC_FILES_CHKSUM = "file://numad.c;beginline=1;endline=19;md5=fc770296e974bef07ddd7033725c8e29"
11
12SRC_URI = "git://git.fedorahosted.org/git/numad.git;protocol=https;branch=master \
13 file://Makefile.patch \
14 file://test.patch \
15 file://run-ptest \
16 file://numad.init.patch \
17 file://numad.conf.patch"
18
19SRCREV = "b621838bf9c8203e87137eca28e19bcc381cde2a"
20
21S = "${WORKDIR}/git"
22
23#clear .LIBPATTERNS instead of using VPATH="${STAGING_LIBDIR}:${STAGING_DIR_HOST}/${base_libdir}"
24EXTRA_OEMAKE = 'prefix=${D}/usr TEST_DESTDIR=${D}${PTEST_PATH} .LIBPATTERNS=""'
25
26do_install () {
27 oe_runmake install
28 install -d ${D}${sysconfdir}/init.d
29 install -m 0755 ${S}/numad.init ${D}${sysconfdir}/init.d
30 install -m 0644 ${S}/numad.conf ${D}${sysconfdir}
31}
32
33inherit update-rc.d ptest
34
35DEPENDS_${PN}-ptest += "numactl"
36RDEPENDS_${PN}-ptest += "libnuma"
37
38INITSCRIPT_NAME = "numad.init"
39#INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."
40INITSCRIPT_PARAMS = "stop 20 5 2 . stop 20 0 1 6 ."
41
42#wait for numa.h
43do_compile_ptest_base[depends] += "numactl:do_populate_sysroot"
44
45do_install_ptest () {
46 oe_runmake test-install
47}
48
49do_compile_ptest () {
50 oe_runmake test
51}