summaryrefslogtreecommitdiffstats
path: root/recipes-core/numad/numad-0.6/Makefile.patch
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 13:48:23 +0200
commit1b6242fc583a6b871304fb995af6dc211b58f69b (patch)
treeb5d434d90dedae24792906aa304897c23a134386 /recipes-core/numad/numad-0.6/Makefile.patch
downloadmeta-ip-daisy-enea.tar.gz
initial commit for Enea Linux 4.0daisy-enea
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-core/numad/numad-0.6/Makefile.patch')
-rw-r--r--recipes-core/numad/numad-0.6/Makefile.patch50
1 files changed, 50 insertions, 0 deletions
diff --git a/recipes-core/numad/numad-0.6/Makefile.patch b/recipes-core/numad/numad-0.6/Makefile.patch
new file mode 100644
index 0000000..f6a564d
--- /dev/null
+++ b/recipes-core/numad/numad-0.6/Makefile.patch
@@ -0,0 +1,50 @@
1Add 'test-install' rule.
2Allow 'prefix' variable to be overloaded.
3
4Signed-off-by: Radu Patriu <radu.patriu@enea.com>
5Upstream-Status: Pending
6
7Index: numad/Makefile
8===================================================================
9--- numad.orig/Makefile 2014-05-13 00:17:16.094991993 +0300
10+++ numad/Makefile 2014-05-13 00:22:22.318986948 +0300
11@@ -22,21 +22,23 @@
12 BENCH_CFLAGS += -ftree-vectorize
13 endif
14
15-CLEANFILES := numad.o numad .depend .depend.X empty.c empty.o
16+CLEANFILES := numad.o numad .depend .depend.X empty.c empty.o test.o test
17
18-SOURCES := numad.c
19+SOURCES := numad.c test.c
20
21-prefix := /usr
22+prefix ?= /usr
23 docdir := ${prefix}/share/doc
24
25 all: numad
26
27 numad: numad.o -lpthread -lrt
28
29+test: test.o -lnuma
30+
31 AR ?= ar
32 RANLIB ?= ranlib
33
34-.PHONY: install all clean html depend
35+.PHONY: install all clean html depend -lpthread -lrt -lnuma
36
37 # BB_FIXME MANPAGES := numa.3 numactl.8 numastat.8 migratepages.8 migspeed.8
38
39@@ -46,6 +48,11 @@
40 install -m 0755 numad ${prefix}/bin
41 install -m 0644 numad.8 ${prefix}/share/man/man8
42
43+TEST_DESTDIR ?= ${prefix}/lib/numad/ptest
44+test-install: test
45+ install -d ${TEST_DESTDIR}
46+ install test ${TEST_DESTDIR}
47+
48 clean:
49 rm -f ${CLEANFILES}
50 @rm -rf html