summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq-sdk.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq-sdk.bbappend')
-rw-r--r--recipes-kernel/linux/linux-qoriq-sdk.bbappend68
1 files changed, 68 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-qoriq-sdk.bbappend b/recipes-kernel/linux/linux-qoriq-sdk.bbappend
new file mode 100644
index 0000000..e89f659
--- /dev/null
+++ b/recipes-kernel/linux/linux-qoriq-sdk.bbappend
@@ -0,0 +1,68 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3
4SRC_URI += "file://add-no-error-uninitialized.patch \
5 file://b4860-hard_irq_disable-bug.patch \
6 file://Check_correct_namespace_when_spoofing_pid_over_SCM_RIGHTS.patch \
7 file://0001-sdhci-fix-Timeout-error-messages.patch \
8 file://HID_CVE_patches/0001-HID-validate-HID-report-id-size.patch \
9 file://HID_CVE_patches/0002-HID-provide-a-helper-for-validating-hid-reports.patch \
10 file://HID_CVE_patches/0003-HID-zeroplus-validate-output-report-details.patch \
11 file://HID_CVE_patches/0006-HID-pantherlord-validate-output-report-details.patch \
12 file://HID_CVE_patches/0007-HID-LG-validate-HID-output-report-details.patch \
13 file://HID_CVE_patches/0008-HID-lenovo-tpkbd-validate-output-report-details.patch \
14 file://HID_CVE_patches/0009-HID-logitech-dj-validate-output-report-details.patch \
15 file://HID_CVE_patches/0010-HID-ntrig-validate-feature-report-details.patch \
16 file://HID_CVE_patches/0012-HID-sensor-hub-validate-feature-report-details.patch \
17 file://HID_CVE_patches/0013-HID-picolcd_core-validate-output-report-details.patch \
18 file://HID_CVE_patches/0014-HID-check-for-NULL-field-when-setting-values.patch \
19 file://powerpc-fsl-booke64-Set-vmemmap_psize-to-4K.patch \
20 "
21
22SRC_URI_append_p2041rdb = " \
23 file://disable-cpu-hotplug.patcher \
24 "
25KERNEL_FEATURES="\
26 cfg/00013-localversion \
27 cfg/00006-with_modules \
28 cfg/00001-embedded \
29 cfg/00012-preempt \
30 cfg/00002-root_nfs \
31 cfg/00029-devtmpfs \
32 cfg/00021-bootlogd \
33 cfg/00022-mtd_tests \
34 cfg/00030-latencytop \
35 cfg/00026-ltp \
36 cfg/00003-fuse \
37 cfg/00034-cpusets \
38 "
39
40KERNEL_FEATURES_append_p4080ds="cfg/00032-dpa"
41KERNEL_FEATURES_append_p2041rdb="cfg/00032-dpa"
42KERNEL_FEATURES_append_p2020rdb="cfg/00015-uio"
43
44STAGING_KERNEL_FEATURES = "${KERNEL_FEATURES} \
45 cfg/00020-debug \
46 cfg/00033-kprobes \
47 cfg/00007-oprofile \
48 cfg/00019-i2c \
49 cfg/00027-lttng \
50 cfg/00025-powertop \
51 cfg/00004-systemtap \
52 cfg/00014-kgdb \
53 "
54
55STAGING_KERNEL_FEATURES_RT_p4080ds="${STAGING_KERNEL_FEATURES} \
56 cfg/00018-rt \
57 "
58
59require recipes-kernel/linux/staging-kernel.inc
60require recipes-kernel/linux/pramfs-3.0.inc
61
62
63do_configure_append_p2041rdb() {
64 # patch the final .config file with the supplied "patcher" file,
65 # as this is to any versioned source file
66 cd ${B}
67 patch -p2 < ../disable-cpu-hotplug.patcher
68}