summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-kernel-headers_3.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-kernel-headers_3.0.6.bb')
-rw-r--r--recipes-kernel/linux/linux-kernel-headers_3.0.6.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-kernel-headers_3.0.6.bb b/recipes-kernel/linux/linux-kernel-headers_3.0.6.bb
new file mode 100644
index 0000000..9dfed39
--- /dev/null
+++ b/recipes-kernel/linux/linux-kernel-headers_3.0.6.bb
@@ -0,0 +1,66 @@
1PROVIDES = "linux-libc-headers"
2
3DESCRIPTION = "linux v${PV} kernel headers"
4SECTION = "devel"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d7810fab7487fb0aad327b76f1be7cd7"
7
8PKGSUFFIX = ""
9PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
10
11INHIBIT_DEFAULT_DEPS = "1"
12DEPENDS += "unifdef-native"
13
14RDEPENDS_${PN}-dev = ""
15RPROVIDES_${PN} = "linux-kernel-headers"
16
17RPROVIDES_${PN}-dev += "linux-libc-headers${PKGSUFFIX}-dev"
18RPROVIDES_${PN}-dbg += "linux-libc-headers${PKGSUFFIX}-dbg"
19RRECOMMENDS_${PN}-dbg = "linux-libc-headers${PKGSUFFIX}-dev (= ${EXTENDPKGV})"
20
21require linux-3.0.6.inc
22
23set_arch() {
24 case ${TARGET_ARCH} in
25 arm*) ARCH=arm ;;
26 i*86*) ARCH=i386 ;;
27 ia64*) ARCH=ia64 ;;
28 mips*) ARCH=mips ;;
29 powerpc*) ARCH=powerpc ;;
30 x86_64*) ARCH=x86_64 ;;
31 esac
32}
33
34do_configure () {
35 set_arch
36 oe_runmake allnoconfig ARCH=$ARCH
37}
38
39do_compile () {
40 :
41}
42
43do_install() {
44 set_arch
45 cd ${S}
46 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH}
47
48 # The ..install.cmd conflicts between various configure runs
49 find ${D}${includedir} -name ..install.cmd | xargs rm -f
50}
51
52BBCLASSEXTEND = "nativesdk"
53
54# The following tasks are not required when we just want
55# headers. So we override and stub them out.
56do_kernel_configme() {
57}
58
59do_compile () {
60}
61
62do_validate_branches () {
63}
64
65do_kernel_configcheck () {
66}