summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-bsc913x.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-bsc913x.bb')
-rw-r--r--recipes-kernel/linux/linux-bsc913x.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-bsc913x.bb b/recipes-kernel/linux/linux-bsc913x.bb
new file mode 100644
index 0000000..0840625
--- /dev/null
+++ b/recipes-kernel/linux/linux-bsc913x.bb
@@ -0,0 +1,35 @@
1inherit kernel
2require recipes-kernel/linux/linux-dtb.inc
3
4DESCRIPTION = "Linux kernel headers for Freescale platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7
8# For bsc913x kernel, the defconfig is included locally
9KERNEL_DEFCONFIG="${WORKDIR}/defconfig"
10
11KERNEL_FEATURES="cfg/00013-localversion \
12 cfg/00006-with_modules \
13 cfg/00001-embedded \
14 cfg/00002-root_nfs \
15 cfg/00029-devtmpfs \
16 cfg/00021-bootlogd \
17 cfg/00022-mtd_tests \
18 "
19
20STAGING_KERNEL_FEATURES = "${KERNEL_FEATURES} cfg/00020-debug"
21
22STAGING_KERNEL_FEATURES_append = " \
23 cfg/00033-kprobes \
24 cfg/00007-oprofile \
25 cfg/00019-i2c \
26 "
27
28require recipes-kernel/linux/linux-bsc913x.inc
29require recipes-kernel/linux/staging-kernel.inc
30require recipes-kernel/linux/pramfs-2.6.33.inc
31
32# For linx-mod built
33kernel_do_install_append() {
34 cp -fR ${S}/include/generated/* ${D}/usr/src/kernel/include/generated
35}