summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-bsc913x.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-bsc913x.bb')
-rw-r--r--recipes-kernel/linux/linux-bsc913x.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-bsc913x.bb b/recipes-kernel/linux/linux-bsc913x.bb
new file mode 100644
index 0000000..3a53b8b
--- /dev/null
+++ b/recipes-kernel/linux/linux-bsc913x.bb
@@ -0,0 +1,30 @@
1inherit kernel
2require recipes-kernel/linux/linux-dtb.inc
3
4DESCRIPTION = "Linux kernel headers for Freescale platforms"
5SECTION = "kernel"
6LICENSE = "GPLv2"
7
8# For bsc913x kernel, the defconfig is included locally
9KERNEL_DEFCONFIG="${WORKDIR}/defconfig"
10
11KERNEL_FEATURES="cfg/localversion \
12 cfg/with_modules \
13 cfg/embedded \
14 cfg/root_nfs \
15 cfg/devtmpfs \
16 cfg/bootlogd \
17 cfg/mtd_tests \
18 "
19
20STAGING_KERNEL_FEATURES = "${KERNEL_FEATURES} cfg/debug"
21STAGING_KERNEL_FEATURES_append = " cfg/kprobes cfg/oprofile cfg/i2c"
22
23require recipes-kernel/linux/linux-bsc913x.inc
24require recipes-kernel/linux/staging-kernel.inc
25require recipes-kernel/linux/pramfs-2.6.33.inc
26
27# For linx-mod built
28kernel_do_install_append() {
29 cp -fR ${S}/include/generated/* ${D}/usr/src/kernel/include/generated
30}