summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-bsc913x-headers.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-bsc913x-headers.bb')
-rw-r--r--recipes-kernel/linux/linux-bsc913x-headers.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-bsc913x-headers.bb b/recipes-kernel/linux/linux-bsc913x-headers.bb
new file mode 100644
index 0000000..8078aad
--- /dev/null
+++ b/recipes-kernel/linux/linux-bsc913x-headers.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Linux kernel headers for Freescale platforms"
2SECTION = "devel"
3LICENSE = "GPLv2"
4
5PKGSUFFIX = ""
6PKGSUFFIX_virtclass-nativesdk = "-nativesdk"
7
8INHIBIT_DEFAULT_DEPS = "1"
9DEPENDS += "unifdef-native"
10
11PROVIDES = "linux-libc-headers${PKGSUFFIX} ${PN}"
12RPROVIDES_${PN}-dev += "linux-libc-headers${PKGSUFFIX}-dev"
13RPROVIDES_${PN}-dbg += "linux-libc-headers${PKGSUFFIX}-dbg"
14RDEPENDS_${PN}-dev = ""
15RRECOMMENDS_${PN}-dbg = "linux-libc-headers${PKGSUFFIX}-dev (= ${EXTENDPKGV})"
16
17require recipes-kernel/linux/linux-bsc913x.inc
18
19set_arch() {
20 case ${TARGET_ARCH} in
21 arm*) ARCH=arm ;;
22 i*86*) ARCH=i386 ;;
23 ia64*) ARCH=ia64 ;;
24 mips*) ARCH=mips ;;
25 powerpc*) ARCH=powerpc ;;
26 x86_64*) ARCH=x86_64 ;;
27 esac
28}
29
30do_configure () {
31 set_arch
32 oe_runmake allnoconfig ARCH=$ARCH
33}
34
35do_compile () {
36 :
37}
38
39do_install() {
40 set_arch
41 cd ${S}
42 oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=${ARCH}
43
44 # The ..install.cmd conflicts between various configure runs
45 find ${D}${includedir} -name ..install.cmd | xargs rm -f
46}
47
48BBCLASSEXTEND = "nativesdk"
49
50# The following tasks are not required when we just want
51# headers. So we override and stub them out.
52do_kernel_configme() {
53}
54
55do_compile () {
56}
57
58do_validate_branches () {
59}
60
61do_kernel_configcheck () {
62}