summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-boundary_3.10.17.bbappend')
-rw-r--r--recipes-kernel/linux/linux-boundary_3.10.17.bbappend30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-boundary_3.10.17.bbappend b/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
new file mode 100644
index 0000000..378c595
--- /dev/null
+++ b/recipes-kernel/linux/linux-boundary_3.10.17.bbappend
@@ -0,0 +1,30 @@
1FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
2
3SRC_URI_append = "file://cfg/00014-kgdb.cfg \
4 file://cfg/00027-lttng.cfg \
5 file://cfg/00028-perf.cfg \
6 file://cfg/00025-powertop.cfg \
7 file://cfg/00004-systemtap.cfg \
8 file://cfg/00003-fuse.cfg \
9 file://cfg/00034-cpusets.cfg \
10 file://cfg/00030-latencytop.cfg \
11 "
12#
13# The linux-boundary recipe doesn't implement a method to merge config fragments
14# to the kernel config file, so we need to implement it ourselves.
15#
16
17# returns all the elements from the src uri that are kernel config files
18def find_cfgs(d):
19 sources=src_patches(d, True)
20 sources_list=[]
21 for s in sources:
22 base, ext = os.path.splitext(os.path.basename(s))
23 if ext and ext in ".cfg":
24 sources_list.append(s)
25 return sources_list
26
27# apply kernel configs from the src uri
28kernel_do_configure_prepend() {
29 ${S}/scripts/kconfig/merge_config.sh -m ${S}/.config ${@" ".join(find_cfgs(d))}
30}