summaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/files
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/files')
-rw-r--r--recipes-kernel/linux/files/add-no-error-array-bounds.patch13
-rw-r--r--recipes-kernel/linux/files/add-no-error-uninitialized.patch69
-rw-r--r--recipes-kernel/linux/files/add-no-unused-but-set-variable.patch13
-rw-r--r--recipes-kernel/linux/files/cfg/bootlogd.cfg2
-rw-r--r--recipes-kernel/linux/files/cfg/debug.cfg27
-rw-r--r--recipes-kernel/linux/files/cfg/devtmpfs.cfg2
-rw-r--r--recipes-kernel/linux/files/cfg/dpa.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/e500mc_debug.cfg6
-rw-r--r--recipes-kernel/linux/files/cfg/embedded.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/i2c.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/igb_drv.cfg3
-rw-r--r--recipes-kernel/linux/files/cfg/ikconfig.cfg2
-rw-r--r--recipes-kernel/linux/files/cfg/kgdb.cfg9
-rw-r--r--recipes-kernel/linux/files/cfg/kprobes.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/latencytop.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/localversion.cfg2
-rw-r--r--recipes-kernel/linux/files/cfg/ltp.cfg3
-rw-r--r--recipes-kernel/linux/files/cfg/lttng.cfg20
-rw-r--r--recipes-kernel/linux/files/cfg/mtd_tests.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/oprofile.cfg4
-rw-r--r--recipes-kernel/linux/files/cfg/perf.cfg2
-rw-r--r--recipes-kernel/linux/files/cfg/powertop.cfg13
-rw-r--r--recipes-kernel/linux/files/cfg/pramfs-bsc913x.cfg5
-rw-r--r--recipes-kernel/linux/files/cfg/pramfs.cfg4
-rw-r--r--recipes-kernel/linux/files/cfg/preempt.cfg1
-rw-r--r--recipes-kernel/linux/files/cfg/root_nfs.cfg7
-rw-r--r--recipes-kernel/linux/files/cfg/rt.cfg3
-rw-r--r--recipes-kernel/linux/files/cfg/systemtap.cfg6
-rw-r--r--recipes-kernel/linux/files/cfg/uio.cfg3
-rw-r--r--recipes-kernel/linux/files/cfg/uio_m.cfg3
-rw-r--r--recipes-kernel/linux/files/cfg/with_modules.cfg5
-rw-r--r--recipes-kernel/linux/files/disable_hw_checksum_offload.patch19
-rw-r--r--recipes-kernel/linux/files/enea_image.cfg1
-rw-r--r--recipes-kernel/linux/files/fix_for_CVE-2013-2094.patch36
-rwxr-xr-xrecipes-kernel/linux/files/merge_config.sh142
-rw-r--r--recipes-kernel/linux/files/pramfs-1.2.9-3.0Patched.tar.gzbin0 -> 53380 bytes
-rw-r--r--recipes-kernel/linux/files/pramfs-1.4.2-3.10_patched.tar.gzbin0 -> 508369 bytes
-rw-r--r--recipes-kernel/linux/files/pramfs-2.6.33-1.1.6.tar.gzbin0 -> 23004 bytes
-rw-r--r--recipes-kernel/linux/files/set-keystone2-clock-frequency.patch26
-rw-r--r--recipes-kernel/linux/files/setlocalversion.patch63
40 files changed, 520 insertions, 0 deletions
diff --git a/recipes-kernel/linux/files/add-no-error-array-bounds.patch b/recipes-kernel/linux/files/add-no-error-array-bounds.patch
new file mode 100644
index 0000000..57b3974
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-error-array-bounds.patch
@@ -0,0 +1,13 @@
1Index: git/Makefile
2===================================================================
3--- git.orig/Makefile
4+++ git/Makefile
5@@ -558,7 +558,7 @@ endif # $(dot-config)
6 # Defaults to vmlinux, but the arch makefile usually adds further targets
7 all: vmlinux
8
9-KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+KBUILD_CFLAGS += -Wno-unused-but-set-variable -Wno-error=array-bounds
11
12 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
13 KBUILD_CFLAGS += -Os
diff --git a/recipes-kernel/linux/files/add-no-error-uninitialized.patch b/recipes-kernel/linux/files/add-no-error-uninitialized.patch
new file mode 100644
index 0000000..a70b089
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-error-uninitialized.patch
@@ -0,0 +1,69 @@
1diff --git a/Makefile b/Makefile
2index 183eff3..88fd9c1 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -370,6 +370,7 @@ LINUXINCLUDE := \
6 KBUILD_CPPFLAGS := -D__KERNEL__
7
8 KBUILD_CFLAGS := -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs \
9+ -Wno-error=uninitialized \
10 -fno-strict-aliasing -fno-common \
11 -Werror-implicit-function-declaration \
12 -Wno-format-security \
13diff --git a/arch/powerpc/Makefile b/arch/powerpc/Makefile
14index 0624909..5d13d66 100644
15--- a/arch/powerpc/Makefile
16+++ b/arch/powerpc/Makefile
17@@ -17,6 +17,7 @@ HAS_BIARCH := $(call cc-option-yn, -m32)
18 # Set default 32 bits cross compilers for vdso and boot wrapper
19 CROSS32_COMPILE ?=
20
21+KBUILD_CFLAGS += -Wno-error=uninitialized
22 CROSS32CC := $(CROSS32_COMPILE)gcc
23 CROSS32AR := $(CROSS32_COMPILE)ar
24
25@@ -67,7 +68,6 @@ LDFLAGS_vmlinux-y := -Bstatic
26 LDFLAGS_vmlinux-$(CONFIG_RELOCATABLE) := -pie
27 LDFLAGS_vmlinux := $(LDFLAGS_vmlinux-y)
28
29-LIBGCC := $(shell $(CC) $(KBUILD_CFLAGS) -print-libgcc-file-name)
30
31 ifeq ($(CONFIG_PPC64),y)
32 ifeq ($(call cc-option-yn,-mcmodel=medium),y)
33@@ -176,7 +176,6 @@ core-$(CONFIG_PERF_EVENTS) += arch/powerpc/perf/
34
35 drivers-$(CONFIG_OPROFILE) += arch/powerpc/oprofile/
36
37-libs-y += $(LIBGCC)
38
39 # Default to zImage, override when needed
40 all: zImage
41diff --git a/arch/powerpc/perf/Makefile b/arch/powerpc/perf/Makefile
42index 06dd8d5..8bf06fd 100644
43--- a/arch/powerpc/perf/Makefile
44+++ b/arch/powerpc/perf/Makefile
45@@ -1,4 +1,4 @@
46-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
47+subdir-ccflags-$(CONFIG_PPC_WERROR) := -Wno-error=uninitialized
48
49 obj-$(CONFIG_PERF_EVENTS) += callchain.o
50
51diff --git a/arch/powerpc/sysdev/Makefile b/arch/powerpc/sysdev/Makefile
52index fa63186..d592e84 100644
53--- a/arch/powerpc/sysdev/Makefile
54+++ b/arch/powerpc/sysdev/Makefile
55@@ -1,4 +1,4 @@
56-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
57+subdir-ccflags-$(CONFIG_PPC_WERROR) := -Wno-error=uninitialized
58
59 ccflags-$(CONFIG_PPC64) := $(NO_MINIMAL_TOC)
60
61@@ -67,8 +67,6 @@ endif
62
63 obj-$(CONFIG_PPC_SCOM) += scom.o
64
65-subdir-ccflags-$(CONFIG_PPC_WERROR) := -Werror
66-
67 obj-$(CONFIG_PPC_XICS) += xics/
68
69 obj-$(CONFIG_GE_FPGA) += ge/
diff --git a/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch b/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
new file mode 100644
index 0000000..5133529
--- /dev/null
+++ b/recipes-kernel/linux/files/add-no-unused-but-set-variable.patch
@@ -0,0 +1,13 @@
1diff --git a/Makefile b/Makefile
2index e821f72..cb2fcba 100644
3--- a/Makefile
4+++ b/Makefile
5@@ -526,6 +526,8 @@ endif # $(dot-config)
6 # Defaults vmlinux but it is usually overridden in the arch makefile
7 all: vmlinux
8
9+KBUILD_CFLAGS += -Wno-unused-but-set-variable
10+
11 ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
12 KBUILD_CFLAGS += -Os
13 else
diff --git a/recipes-kernel/linux/files/cfg/bootlogd.cfg b/recipes-kernel/linux/files/cfg/bootlogd.cfg
new file mode 100644
index 0000000..0d83d11
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/bootlogd.cfg
@@ -0,0 +1,2 @@
1CONFIG_LEGACY_PTYS=y
2CONFIG_LEGACY_PTY_COUNT=256
diff --git a/recipes-kernel/linux/files/cfg/debug.cfg b/recipes-kernel/linux/files/cfg/debug.cfg
new file mode 100644
index 0000000..e4b87d5
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/debug.cfg
@@ -0,0 +1,27 @@
1
2CONFIG_STACKTRACE_SUPPORT=n
3CONFIG_TRACE_IRQFLAGS_SUPPORT=y
4CONFIG_LOCKDEP_SUPPORT=n
5
6CONFIG_GENERIC_TBSYNC=y
7CONFIG_GENERIC_BUG=y
8
9CONFIG_PERF_EVENTS=y
10CONFIG_PERF_COUNTERS=y
11
12CONFIG_RCU_TRACE=y
13CONFIG_TREE_RCU_TRACE=y
14
15CONFIG_DEBUG_KERNEL=y
16
17CONFIG_EXT2_FS=y
18CONFIG_EXT3_FS=y
19CONFIG_EXT3_FS_XATTR=y
20CONFIG_SYSFS=y
21CONFIG_TMPFS=y
22CONFIG_DEBUG_FS=y
23
24CONFIG_TRACING_SUPPORT=y
25CONFIG_FTRACE=n
26CONFIG_FTRACE_SYSCALLS=n
27CONFIG_STACK_TRACER=y
diff --git a/recipes-kernel/linux/files/cfg/devtmpfs.cfg b/recipes-kernel/linux/files/cfg/devtmpfs.cfg
new file mode 100644
index 0000000..5e9cf98
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/devtmpfs.cfg
@@ -0,0 +1,2 @@
1CONFIG_DEVTMPFS=y
2CONFIG_DEVTMPFS_MOUNT=y
diff --git a/recipes-kernel/linux/files/cfg/dpa.cfg b/recipes-kernel/linux/files/cfg/dpa.cfg
new file mode 100644
index 0000000..c873cd5
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/dpa.cfg
@@ -0,0 +1 @@
CONFIG_FSL_FM_MAX_FRAME_SIZE=9600
diff --git a/recipes-kernel/linux/files/cfg/e500mc_debug.cfg b/recipes-kernel/linux/files/cfg/e500mc_debug.cfg
new file mode 100644
index 0000000..eaddbaf
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/e500mc_debug.cfg
@@ -0,0 +1,6 @@
1CONFIG_FSL_EMB_PERFMON=y
2CONFIG_FSL_EMB_PERF_EVENT=y
3CONFIG_FSL_EMB_PERF_EVENT_E500=y
4
5CONFIG_PPC_OF=y
6CONFIG_PPC_UDBG_16550=y
diff --git a/recipes-kernel/linux/files/cfg/embedded.cfg b/recipes-kernel/linux/files/cfg/embedded.cfg
new file mode 100644
index 0000000..2f0e6bf
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/embedded.cfg
@@ -0,0 +1 @@
CONFIG_EMBEDDED=y
diff --git a/recipes-kernel/linux/files/cfg/i2c.cfg b/recipes-kernel/linux/files/cfg/i2c.cfg
new file mode 100644
index 0000000..8dbcc3c
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/i2c.cfg
@@ -0,0 +1 @@
CONFIG_I2C_CHARDEV=y
diff --git a/recipes-kernel/linux/files/cfg/igb_drv.cfg b/recipes-kernel/linux/files/cfg/igb_drv.cfg
new file mode 100644
index 0000000..3498fd0
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/igb_drv.cfg
@@ -0,0 +1,3 @@
1CONFIG_IGB=y
2CONFIG_IGB_DCA=y
3CONFIG_IGBVF=y
diff --git a/recipes-kernel/linux/files/cfg/ikconfig.cfg b/recipes-kernel/linux/files/cfg/ikconfig.cfg
new file mode 100644
index 0000000..9e7666c
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/ikconfig.cfg
@@ -0,0 +1,2 @@
1CONFIG_IKCONFIG=y
2CONFIG_IKCONFIG_PROC=y
diff --git a/recipes-kernel/linux/files/cfg/kgdb.cfg b/recipes-kernel/linux/files/cfg/kgdb.cfg
new file mode 100644
index 0000000..f23cfe3
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/kgdb.cfg
@@ -0,0 +1,9 @@
1#depends
2CONFIG_DEBUG_KERNEL=y
3CONFIG_EXPERIMENTAL=y
4
5#configs
6CONFIG_KGDB=y
7CONFIG_KGDB_SERIAL_CONSOLE=y
8CONFIG_KGDB_KDB=y
9CONFIG_MAGIC_SYSRQ=y
diff --git a/recipes-kernel/linux/files/cfg/kprobes.cfg b/recipes-kernel/linux/files/cfg/kprobes.cfg
new file mode 100644
index 0000000..e24be27
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/kprobes.cfg
@@ -0,0 +1 @@
CONFIG_KPROBES=y
diff --git a/recipes-kernel/linux/files/cfg/latencytop.cfg b/recipes-kernel/linux/files/cfg/latencytop.cfg
new file mode 100644
index 0000000..0a42694
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/latencytop.cfg
@@ -0,0 +1 @@
CONFIG_LATENCYTOP=y
diff --git a/recipes-kernel/linux/files/cfg/localversion.cfg b/recipes-kernel/linux/files/cfg/localversion.cfg
new file mode 100644
index 0000000..71481b4
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/localversion.cfg
@@ -0,0 +1,2 @@
1CONFIG_LOCALVERSION_AUTO=n
2CONFIG_DEFAULT_HOSTNAME="(none)"
diff --git a/recipes-kernel/linux/files/cfg/ltp.cfg b/recipes-kernel/linux/files/cfg/ltp.cfg
new file mode 100644
index 0000000..e36a9c2
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/ltp.cfg
@@ -0,0 +1,3 @@
1CONFIG_TUN=y
2CONFIG_KSM=y
3CONFIG_NUMA=y
diff --git a/recipes-kernel/linux/files/cfg/lttng.cfg b/recipes-kernel/linux/files/cfg/lttng.cfg
new file mode 100644
index 0000000..1334194
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/lttng.cfg
@@ -0,0 +1,20 @@
1CONFIG_MODULES=y
2CONFIG_KALLSYMS=y
3CONFIG_HIGH_RES_TIMERS=y
4CONFIG_TRACEPOINTS=y
5CONFIG_FTRACE=y
6CONFIG_PERF_EVENTS=y
7CONFIG_EVENT_TRACING=y
8CONFIG_KPROBES=y
9CONFIG_KRETPROBES=y
10CONFIG_FUNCTION_TRACER=y
11CONFIG_FUNCTION_GRAPH_TRACER=y
12CONFIG_IRQSOFF_TRACER=y
13CONFIG_PREEMPT_TRACER=y
14CONFIG_SCHED_TRACER=y
15CONFIG_NOP_TRACER=y
16CONFIG_CONTEXT_SWITCH_TRACER=y
17CONFIG_GENERIC_TRACER=y
18CONFIG_TRACER_MAX_TRACE=y
19CONFIG_TRACER_SNAPSHOT=y
20CONFIG_STACK_TRACER=n
diff --git a/recipes-kernel/linux/files/cfg/mtd_tests.cfg b/recipes-kernel/linux/files/cfg/mtd_tests.cfg
new file mode 100644
index 0000000..1477bd7
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/mtd_tests.cfg
@@ -0,0 +1 @@
CONFIG_MTD_TESTS=m
diff --git a/recipes-kernel/linux/files/cfg/oprofile.cfg b/recipes-kernel/linux/files/cfg/oprofile.cfg
new file mode 100644
index 0000000..959e94b
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/oprofile.cfg
@@ -0,0 +1,4 @@
1CONFIG_PROFILING=y
2CONFIG_OPROFILE=m
3CONFIG_PROFILE_ALL_BRANCHES=y
4CONFIG_OPROFILE_NMI_TIMER=y
diff --git a/recipes-kernel/linux/files/cfg/perf.cfg b/recipes-kernel/linux/files/cfg/perf.cfg
new file mode 100644
index 0000000..5fddec0
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/perf.cfg
@@ -0,0 +1,2 @@
1CONFIG_CGROUP_PERF=y
2CONFIG_PERF_EVENTS=y
diff --git a/recipes-kernel/linux/files/cfg/powertop.cfg b/recipes-kernel/linux/files/cfg/powertop.cfg
new file mode 100644
index 0000000..655c101
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/powertop.cfg
@@ -0,0 +1,13 @@
1CONFIG_EXPERT=y
2CONFIG_PROC_FS=y
3CONFIG_DEBUG_FS=y
4CONFIG_NO_HZ=y
5CONFIG_HIGH_RES_TIMERS=y
6CONFIG_HPET_TIMER=y
7CONFIG_CPU_FREQ=y
8CONFIG_CPU_FREQ_GOV_ONDEMAND=y
9CONFIG_TIMER_STATS=y
10CONFIG_PERF_EVENTS=y
11CONFIG_TRACEPOINTS=y
12CONFIG_TRACING=y
13CONFIG_X86_MSR=y
diff --git a/recipes-kernel/linux/files/cfg/pramfs-bsc913x.cfg b/recipes-kernel/linux/files/cfg/pramfs-bsc913x.cfg
new file mode 100644
index 0000000..1476224
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/pramfs-bsc913x.cfg
@@ -0,0 +1,5 @@
1CONFIG_MISC_FILESYSTEMS=y
2CONFIG_PRAMFS=y
3CONFIG_PRAMFS_TEST=y
4CONFIG_TEST_MODULE=m
5
diff --git a/recipes-kernel/linux/files/cfg/pramfs.cfg b/recipes-kernel/linux/files/cfg/pramfs.cfg
new file mode 100644
index 0000000..21aabc1
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/pramfs.cfg
@@ -0,0 +1,4 @@
1CONFIG_MISC_FILESYSTEMS=y
2CONFIG_PRAMFS=y
3CONFIG_PRAMFS_XATTR=y
4CONFIG_PRAMFS_TEST_MODULE=m
diff --git a/recipes-kernel/linux/files/cfg/preempt.cfg b/recipes-kernel/linux/files/cfg/preempt.cfg
new file mode 100644
index 0000000..0d9cc42
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/preempt.cfg
@@ -0,0 +1 @@
CONFIG_PREEMPT=y
diff --git a/recipes-kernel/linux/files/cfg/root_nfs.cfg b/recipes-kernel/linux/files/cfg/root_nfs.cfg
new file mode 100644
index 0000000..f8d8748
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/root_nfs.cfg
@@ -0,0 +1,7 @@
1CONFIG_NETWORK_FILESYSTEMS=y
2CONFIG_NFS_USE_KERNEL_DNS=y
3CONFIG_ROOT_NFS=y
4CONFIG_NFS_FS=y
5CONFIG_NFS_V3=y
6CONFIG_NFS_V4=y
7CONFIG_NFSD=y
diff --git a/recipes-kernel/linux/files/cfg/rt.cfg b/recipes-kernel/linux/files/cfg/rt.cfg
new file mode 100644
index 0000000..a15c930
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/rt.cfg
@@ -0,0 +1,3 @@
1CONFIG_PREEMPT_RT_FULL=y
2CONFIG_HZ_1000=y
3CONFIG_HZ=1000
diff --git a/recipes-kernel/linux/files/cfg/systemtap.cfg b/recipes-kernel/linux/files/cfg/systemtap.cfg
new file mode 100644
index 0000000..88c278c
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/systemtap.cfg
@@ -0,0 +1,6 @@
1CONFIG_DEBUG_INFO=y
2CONFIG_KPROBES=y
3CONFIG_RELAY=y
4CONFIG_DEBUG_FS=y
5CONFIG_MODULES=y
6CONFIG_MODULE_UNLOAD=y
diff --git a/recipes-kernel/linux/files/cfg/uio.cfg b/recipes-kernel/linux/files/cfg/uio.cfg
new file mode 100644
index 0000000..b26593e
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/uio.cfg
@@ -0,0 +1,3 @@
1CONFIG_UIO=y
2CONFIG_UIO_PDRV=y
3CONFIG_UIO_PDRV_GENIRQ=y
diff --git a/recipes-kernel/linux/files/cfg/uio_m.cfg b/recipes-kernel/linux/files/cfg/uio_m.cfg
new file mode 100644
index 0000000..d82eee4
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/uio_m.cfg
@@ -0,0 +1,3 @@
1CONFIG_UIO=m
2CONFIG_UIO_PDRV=m
3CONFIG_UIO_PDRV_GENIRQ=m
diff --git a/recipes-kernel/linux/files/cfg/with_modules.cfg b/recipes-kernel/linux/files/cfg/with_modules.cfg
new file mode 100644
index 0000000..f4b3ae2
--- /dev/null
+++ b/recipes-kernel/linux/files/cfg/with_modules.cfg
@@ -0,0 +1,5 @@
1CONFIG_MODULES=y
2# CONFIG_MODULE_FORCE_LOAD is not set
3CONFIG_MODULE_UNLOAD=y
4CONFIG_MODULE_FORCE_UNLOAD=y
5CONFIG_MODVERSIONS=y
diff --git a/recipes-kernel/linux/files/disable_hw_checksum_offload.patch b/recipes-kernel/linux/files/disable_hw_checksum_offload.patch
new file mode 100644
index 0000000..4b318c1
--- /dev/null
+++ b/recipes-kernel/linux/files/disable_hw_checksum_offload.patch
@@ -0,0 +1,19 @@
1Temporarily disable HW checksum offload
2
3Signed-off-by: Tudor Florea <tudor.florea@enea.com>
4Upstream-Status: Pending
5
6
7diff --git a/arch/arm/boot/dts/k2hk-evm.dts b/arch/arm/boot/dts/k2hk-evm.dts
8index 16cf335..7dc9665 100644
9--- a/arch/arm/boot/dts/k2hk-evm.dts
10+++ b/arch/arm/boot/dts/k2hk-evm.dts
11@@ -2521,7 +2521,7 @@
12 };
13 pa: pa@2000000 {
14 label = "keystone-pa";
15- checksum-offload = <1>; /* 1 - HW offload */
16+ checksum-offload = <2>;
17 txhook-order = <10>;
18 txhook-softcsum = <40>;
19 rxhook-order = <10>;
diff --git a/recipes-kernel/linux/files/enea_image.cfg b/recipes-kernel/linux/files/enea_image.cfg
new file mode 100644
index 0000000..146eff5
--- /dev/null
+++ b/recipes-kernel/linux/files/enea_image.cfg
@@ -0,0 +1 @@
CONFIG_RELAY=y
diff --git a/recipes-kernel/linux/files/fix_for_CVE-2013-2094.patch b/recipes-kernel/linux/files/fix_for_CVE-2013-2094.patch
new file mode 100644
index 0000000..1fbad06
--- /dev/null
+++ b/recipes-kernel/linux/files/fix_for_CVE-2013-2094.patch
@@ -0,0 +1,36 @@
1From 8176cced706b5e5d15887584150764894e94e02f Mon Sep 17 00:00:00 2001
2From: Tommi Rantala <tt.rantala@gmail.com>
3Date: Sat, 13 Apr 2013 19:49:14 +0000
4Subject: perf: Treat attr.config as u64 in perf_swevent_init()
5
6Trinity discovered that we fail to check all 64 bits of
7attr.config passed by user space, resulting to out-of-bounds
8access of the perf_swevent_enabled array in
9sw_perf_event_destroy().
10
11Introduced in commit b0a873ebb ("perf: Register PMU
12implementations").
13
14Signed-off-by: Tommi Rantala <tt.rantala@gmail.com>
15Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
16Cc: davej@redhat.com
17Cc: Paul Mackerras <paulus@samba.org>
18Cc: Arnaldo Carvalho de Melo <acme@ghostprotocols.net>
19Link: http://lkml.kernel.org/r/1365882554-30259-1-git-send-email-tt.rantala@gmail.com
20Signed-off-by: Ingo Molnar <mingo@kernel.org>
21---
22diff --git a/kernel/events/core.c b/kernel/events/core.c
23index 7e0962e..4d3124b 100644
24--- a/kernel/events/core.c
25+++ b/kernel/events/core.c
26@@ -5331,7 +5331,7 @@ static void sw_perf_event_destroy(struct perf_event *event)
27
28 static int perf_swevent_init(struct perf_event *event)
29 {
30- int event_id = event->attr.config;
31+ u64 event_id = event->attr.config;
32
33 if (event->attr.type != PERF_TYPE_SOFTWARE)
34 return -ENOENT;
35--
36cgit v0.9.1
diff --git a/recipes-kernel/linux/files/merge_config.sh b/recipes-kernel/linux/files/merge_config.sh
new file mode 100755
index 0000000..33f18d4
--- /dev/null
+++ b/recipes-kernel/linux/files/merge_config.sh
@@ -0,0 +1,142 @@
1#!/bin/sh
2# merge_config.sh - Takes a list of config fragment values, and merges
3# them one by one. Provides warnings on overridden values, and specified
4# values that did not make it to the resulting .config file (due to missed
5# dependencies or config symbol removal).
6#
7# Portions reused from kconf_check and generate_cfg:
8# http://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-tools/tree/tools/kconf_check
9# http://git.yoctoproject.org/cgit/cgit.cgi/yocto-kernel-tools/tree/tools/generate_cfg
10#
11# Copyright (c) 2009-2010 Wind River Systems, Inc.
12# Copyright 2011 Linaro
13#
14# This program is free software; you can redistribute it and/or modify
15# it under the terms of the GNU General Public License version 2 as
16# published by the Free Software Foundation.
17#
18# This program is distributed in the hope that it will be useful,
19# but WITHOUT ANY WARRANTY; without even the implied warranty of
20# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
21# See the GNU General Public License for more details.
22
23
24usage() {
25 echo "Usage: $0 [OPTIONS] [CONFIG [...]]"
26echo " -h display this help text"
27echo " -m only merge the fragments, do not execute the make command"
28echo " -n use allnoconfig instead of alldefconfig"
29echo " -x use allmodconfig instead of alldefconfig"
30echo " -d debug. Don't cleanup temporary files"
31}
32
33MAKE_FLAG=true
34ALLTARGET=alldefconfig
35
36# There are two variables that impact where the .config will be dropped,
37# O= and KBUILD_OUTPUT=. So we'll respect those variables and use them as
38# an output directory as well. These two variables are not propagating
39# automatically to the kernel build, so always explicitly setting O=
40# and passing it to the kernel build ensures that it is respected.
41if [ -n "$KBUILD_OUTPUT" ]; then
42 O=$KBUILD_OUTPUT
43fi
44if [ -z "$O" ]; then
45 O=.
46fi
47
48while true; do
49 case $1 in
50 "-n")
51 ALLTARGET=allnoconfig
52 shift
53 continue
54 ;;
55 "-m")
56 MAKE_FLAG=false
57 shift
58 continue
59 ;;
60 "-d")
61 DEBUG=true
62 shift
63 continue
64 ;;
65 "-h")
66 usage
67 exit
68 ;;
69 *)
70 break
71 ;;
72 esac
73done
74
75clean_up() {
76 rm -f $TMP_FILE
77 exit
78}
79if [ -z "$DEBUG" ]; then
80 trap clean_up SIGHUP SIGINT SIGTERM
81fi
82
83
84MERGE_LIST=$*
85SED_CONFIG_EXP="s/^\(# \)\{0,1\}\(CONFIG_[a-zA-Z0-9_]*\)[= ].*/\2/p"
86TMP_FILE=$(mktemp $O/.tmp.config.XXXXXXXXXX)
87
88# Merge files, printing warnings on overrided values
89for MERGE_FILE in $MERGE_LIST ; do
90 echo "Merging $MERGE_FILE"
91 CFG_LIST=$(sed -n "$SED_CONFIG_EXP" $MERGE_FILE)
92
93 for CFG in $CFG_LIST ; do
94 grep -q -w $CFG $TMP_FILE
95 if [ $? -eq 0 ] ; then
96 PREV_VAL=$(grep -w $CFG $TMP_FILE)
97 NEW_VAL=$(grep -w $CFG $MERGE_FILE)
98 if [ "x$PREV_VAL" != "x$NEW_VAL" ] ; then
99 echo Value of $CFG is redefined by fragment $MERGE_FILE:
100 echo Previous value: $PREV_VAL
101 echo New value: $NEW_VAL
102 echo
103 fi
104 sed -i "/$CFG[ =]/d" $TMP_FILE
105 fi
106 done
107 cat $MERGE_FILE >> $TMP_FILE
108done
109
110if [ "$MAKE_FLAG" = "false" ]; then
111 cp $TMP_FILE $O/.config
112 echo "#"
113 echo "# merged configuration written to $O/.config (needs make)"
114 echo "#"
115 if [ -z "$DEBUG" ]; then
116 clean_up
117 fi
118 exit
119fi
120
121# Use the merged file as the starting point for:
122# alldefconfig: Fills in any missing symbols with Kconfig default
123# allnoconfig: Fills in any missing symbols with # CONFIG_* is not set
124make KCONFIG_ALLCONFIG=$TMP_FILE O=$O $ALLTARGET
125
126
127# Check all specified config values took (might have missed-dependency issues)
128for CFG in $(sed -n "$SED_CONFIG_EXP" $TMP_FILE); do
129
130 REQUESTED_VAL=$(sed -n "$SED_CONFIG_EXP" $TMP_FILE | grep -w -e "$CFG")
131 ACTUAL_VAL=$(sed -n "$SED_CONFIG_EXP" $O/.config | grep -w -e "$CFG")
132 if [ "x$REQUESTED_VAL" != "x$ACTUAL_VAL" ] ; then
133 echo "Value requested for $CFG not in final .config"
134 echo "Requested value: $REQUESTED_VAL"
135 echo "Actual value: $ACTUAL_VAL"
136 echo ""
137 fi
138done
139
140if [ -z "$DEBUG" ]; then
141 clean_up
142fi
diff --git a/recipes-kernel/linux/files/pramfs-1.2.9-3.0Patched.tar.gz b/recipes-kernel/linux/files/pramfs-1.2.9-3.0Patched.tar.gz
new file mode 100644
index 0000000..895b329
--- /dev/null
+++ b/recipes-kernel/linux/files/pramfs-1.2.9-3.0Patched.tar.gz
Binary files differ
diff --git a/recipes-kernel/linux/files/pramfs-1.4.2-3.10_patched.tar.gz b/recipes-kernel/linux/files/pramfs-1.4.2-3.10_patched.tar.gz
new file mode 100644
index 0000000..0d71064
--- /dev/null
+++ b/recipes-kernel/linux/files/pramfs-1.4.2-3.10_patched.tar.gz
Binary files differ
diff --git a/recipes-kernel/linux/files/pramfs-2.6.33-1.1.6.tar.gz b/recipes-kernel/linux/files/pramfs-2.6.33-1.1.6.tar.gz
new file mode 100644
index 0000000..f25bdd4
--- /dev/null
+++ b/recipes-kernel/linux/files/pramfs-2.6.33-1.1.6.tar.gz
Binary files differ
diff --git a/recipes-kernel/linux/files/set-keystone2-clock-frequency.patch b/recipes-kernel/linux/files/set-keystone2-clock-frequency.patch
new file mode 100644
index 0000000..bc9c105
--- /dev/null
+++ b/recipes-kernel/linux/files/set-keystone2-clock-frequency.patch
@@ -0,0 +1,26 @@
1From ba87988727dcd6202a10f435ba24543410c367e0 Mon Sep 17 00:00:00 2001
2From: Valentin Cobelea <valentin.cobelea@enea.com>
3Date: Tue, 8 Oct 2013 16:55:58 +0200
4Subject: [PATCH] LXCR-1831: set the keystone2 rt clock frequency
5
6
7Signed-off-by: Valentin Cobelea <valentin.cobelea@enea.com>
8---
9 arch/arm/boot/dts/k2hk-evm.dts | 1 +
10 1 file changed, 1 insertion(+)
11
12diff --git a/arch/arm/boot/dts/k2hk-evm.dts b/arch/arm/boot/dts/k2hk-evm.dts
13index dc2ee9a..f535286 100644
14--- a/arch/arm/boot/dts/k2hk-evm.dts
15+++ b/arch/arm/boot/dts/k2hk-evm.dts
16@@ -1291,6 +1291,7 @@
17 timer {
18 compatible = "arm,armv7-timer";
19 interrupts = <1 13 0xf08 1 14 0xf08>;
20+ clock-frequency = <134221720>;
21 };
22
23 uart0: serial@02530c00 {
24--
251.7.10.4
26
diff --git a/recipes-kernel/linux/files/setlocalversion.patch b/recipes-kernel/linux/files/setlocalversion.patch
new file mode 100644
index 0000000..f0925de
--- /dev/null
+++ b/recipes-kernel/linux/files/setlocalversion.patch
@@ -0,0 +1,63 @@
1diff -uNr a/Makefile b/Makefile
2--- a/Makefile 2012-05-11 10:45:09.669169201 +0200
3+++ b/Makefile 2012-05-11 10:44:57.285708701 +0200
4@@ -949,6 +949,7 @@
5 # Store (new) KERNELRELASE string in include/config/kernel.release
6 include/config/kernel.release: include/config/auto.conf FORCE
7 $(Q)rm -f $@
8+ $(Q)rm -f .scmversion
9 $(Q)echo "$(KERNELVERSION)$$($(CONFIG_SHELL) $(srctree)/scripts/setlocalversion $(srctree))" > $@
10
11
12@@ -1463,6 +1464,7 @@
13 $(PERL) $(src)/scripts/checkstack.pl $(CHECKSTACK_ARCH)
14
15 kernelrelease:
16+ $(Q)rm -f .scmversion
17 @echo "$(KERNELVERSION)$$($(CONFIG_SHELL) $(srctree)/scripts/setlocalversion $(srctree))"
18
19 kernelversion:
20diff -uNr a/scripts/setlocalversion b/scripts/setlocalversion
21--- a/scripts/setlocalversion 2012-05-11 10:40:11.926141561 +0200
22+++ b/scripts/setlocalversion 2012-05-11 10:43:04.818608594 +0200
23@@ -49,12 +49,6 @@
24 # it, because this version is defined in the top level Makefile.
25 if [ -z "`git describe --exact-match 2>/dev/null`" ]; then
26
27- # If only the short version is requested, don't bother
28- # running further git commands
29- if $short; then
30- echo "+"
31- return
32- fi
33 # If we are past a tagged commit (like
34 # "v2.6.30-rc5-302-g72357d5"), we pretty print it.
35 if atag="`git describe 2>/dev/null`"; then
36@@ -98,11 +92,6 @@
37 fi
38 fi
39
40- # Are there uncommitted changes?
41- # These are represented by + after the changeset id.
42- case "$hgid" in
43- *+|*+\ *) printf '%s' -dirty ;;
44- esac
45
46 # All done with mercurial
47 return
48@@ -163,15 +152,6 @@
49 if test "$CONFIG_LOCALVERSION_AUTO" = "y"; then
50 # full scm version string
51 res="$res$(scm_version)"
52-else
53- # append a plus sign if the repository is not in a clean
54- # annotated or signed tagged state (as git describe only
55- # looks at signed or annotated tags - git tag -a/-s) and
56- # LOCALVERSION= is not specified
57- if test "${LOCALVERSION+set}" != "set"; then
58- scm=$(scm_version --short)
59- res="$res${scm:++}"
60- fi
61 fi
62
63 echo "$res"