summaryrefslogtreecommitdiffstats
path: root/recipes-enea/linx/linx-mod_2.6.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-enea/linx/linx-mod_2.6.6.bb')
-rw-r--r--recipes-enea/linx/linx-mod_2.6.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-enea/linx/linx-mod_2.6.6.bb b/recipes-enea/linx/linx-mod_2.6.6.bb
new file mode 100644
index 0000000..aa38602
--- /dev/null
+++ b/recipes-enea/linx/linx-mod_2.6.6.bb
@@ -0,0 +1,32 @@
1SUMMARY = "LINX for Linux fast IPC"
2DESCRIPTION = "LINX is a distributed communication protocol stack for transparent inter node and interprocess communication for a heterogeneous mix of systems."
3HOMEPAGE = "http://linx.sourceforge.net/"
4
5SECTION = "kernel/modules"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://../../COPYING;md5=59530bdf33659b29e73d4adb9f9f6552"
9
10DEPENDS = "linux-libc-headers linx"
11RRECOMMENDS_${PN} = "linx kmod"
12
13SRC_URI = "http://linux.enea.com/linx/linx-${PV}.tar.gz"
14
15SRC_URI[md5sum] = "f6d7e103eee0807cacf73aa20cf95571"
16SRC_URI[sha256sum] = "a8fa3fe221e883ecb6afaa001652c96080a474b95e8d37c3bcf3e0c2ae618799"
17
18S = "${WORKDIR}/linx-${PV}/net/linx"
19
20inherit module
21
22module_do_compile_prepend () {
23
24 HAS_LOADABLE_MODULES=$(cat ${STAGING_KERNEL_DIR}/.config | grep "CONFIG_MODULES=y")
25
26 if [[ ${#HAS_LOADABLE_MODULES} -eq 0 ]] ; then
27 echo "The specified Linux kernel has no support for pluggable modules (CONFIG_MODULES=y). Enable it before baking this."
28 exit 1
29 fi
30
31 do_make_scripts
32}