summaryrefslogtreecommitdiffstats
path: root/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch')
-rw-r--r--recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch48
1 files changed, 48 insertions, 0 deletions
diff --git a/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch b/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch
new file mode 100644
index 0000000..88a8a54
--- /dev/null
+++ b/recipes-devtools/valgrind/files/disable-power-isa-2.07-check.patch
@@ -0,0 +1,48 @@
1valgrind: Disable Power ISA 2.07 check
2
3The Power ISA 2.07 check fails when not supported by both machine
4architecture and gcc.
5
6Upstream-Status: Inappropriate [disable feature]
7
8Signed-off-by: Gabriel Barbu <gabriel.barbu@enea.com>
9
10--- a/configure.ac 2014-05-05 17:06:29.674630565 +0200
11+++ b/configure.ac 2014-05-06 13:16:47.525598513 +0200
12@@ -1316,18 +1316,25 @@
13 AM_CONDITIONAL(BUILD_DFP_TESTS, test x$ac_gcc_have_dfp_type = xyes)
14
15 # isa 2.07 checking
16-AC_MSG_CHECKING([that assembler knows ISA 2.07 ])
17+AC_ARG_ENABLE([isa_2_07_check],
18+ [AS_HELP_STRING([--disable-isa_2_07_check],
19+ [disable Power ISA 2.07 check])],
20+ [],
21+ [disable_isa_2_07_check=no])
22
23-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
24-]], [[
25- __asm__ __volatile__("mtvsrd 1,2 ");
26-]])], [
27-ac_asm_have_isa_2_07=yes
28-AC_MSG_RESULT([yes])
29-], [
30-ac_asm_have_isa_2_07=no
31-AC_MSG_RESULT([no])
32-])
33+AS_IF([test "x$disable_isa_2_07_check" = xno],
34+ [AC_MSG_CHECKING([that assembler knows ISA 2.07 ])
35+
36+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[
37+ ]], [[
38+ __asm__ __volatile__("mtvsrd 1,2 ");
39+ ]])], [
40+ ac_asm_have_isa_2_07=yes
41+ AC_MSG_RESULT([yes])
42+ ], [
43+ ac_asm_have_isa_2_07=no
44+ AC_MSG_RESULT([no])
45+ ])])
46
47 AM_CONDITIONAL(HAS_ISA_2_07, test x$ac_asm_have_isa_2_07 = xyes)
48