summaryrefslogtreecommitdiffstats
path: root/recipes-append/bash/bash_4.2.bbappend
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-append/bash/bash_4.2.bbappend')
-rw-r--r--recipes-append/bash/bash_4.2.bbappend13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes-append/bash/bash_4.2.bbappend b/recipes-append/bash/bash_4.2.bbappend
new file mode 100644
index 0000000..0b5ad7f
--- /dev/null
+++ b/recipes-append/bash/bash_4.2.bbappend
@@ -0,0 +1,13 @@
1# Fixup for broken ENEA environment with bash under /usr/bin/bash
2# RPM nativesdk packaging breaks for meta-toolchain without this append.
3
4FILES_${PN} += "${base_bindir}/* ${exec_prefix}/bin/*"
5
6do_install_append () {
7 mkdir -p ${D}/usr/bin
8 cd ${D}/usr/bin && ln -sf /bin/bash bash
9}
10
11BBCLASSEXTEND = "native nativesdk"
12
13