summaryrefslogtreecommitdiffstats
path: root/images/enea-image-demo.bb
diff options
context:
space:
mode:
Diffstat (limited to 'images/enea-image-demo.bb')
-rw-r--r--images/enea-image-demo.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/images/enea-image-demo.bb b/images/enea-image-demo.bb
new file mode 100644
index 0000000..6b4c346
--- /dev/null
+++ b/images/enea-image-demo.bb
@@ -0,0 +1,93 @@
1# Uncomment for opkg/dpkg/rpm on available on target
2IMAGE_FSTYPES += "ext2.gz.u-boot ext3 tar.gz"
3IMAGE_FEATURES += "package-management"
4
5IMAGE_FEATURES += "eclipse-debug tools-debug tools-profile dbg-pkgs"
6IMAGE_FEATURES += "ssh-server-dropbear"
7
8ENEA_GPL = " \
9 linx \
10 linx-mod"
11
12ENEA_GPL_qemux86 = ""
13ENEA_GPL_qemuppc = ""
14ENEA_GPL_armv5 = ""
15ENEA_GPL_armv7a = ""
16
17VALGRIND ?= ""
18VALGRIND_powerpc ?= "valgrind"
19VALGRIND_e500v2 ?= ""
20VALGRIND_x86 ?= "valgrind"
21VALGRIND_x86_64 ?= "valgrind"
22VALGRIND_armv7a ?= "valgrind"
23
24IMAGE_INSTALL = " \
25 packagegroup-enea-core-boot \
26 packagegroup-enea-debug \
27 packagegroup-enea-profile \
28 packagegroup-enea-rt-tools \
29 ${ROOTFS_PKGMANAGE_BOOTSTRAP} \
30 babeltrace \
31 bc \
32 beecrypt \
33 chkconfig \
34 cracklib \
35 curl \
36 dhcp-client \
37 eventlog \
38 file \
39 findutils \
40 freetype \
41 fuse \
42 gawk \
43 gettext \
44 gettext-runtime \
45 gnutls \
46 grep \
47 gzip \
48 icu \
49 insserv \
50 kbd \
51 kexec-tools \
52 libgcrypt \
53 libgpg-error \
54 libtasn1 \
55 libuio \
56 logrotate \
57 lsb \
58 lsbinitscripts \
59 ltp \
60 lttng-modules \
61 lttng-tools \
62 mingetty \
63 mtd-utils \
64 net-tools \
65 netbase \
66 openssl \
67 ossp-uuid \
68 pciutils \
69 pkgconfig \
70 pramfs-init \
71 procps \
72 psmisc \
73 rpm \
74 sed \
75 sqlite3 \
76 sudo \
77 tar \
78 tipcutils \
79 udev-extraconf \
80 usbutils \
81 zip \
82 ${ENEA_GPL} \
83 ${VALGRIND} \
84 "
85
86IMAGE_LINGUAS = ""
87
88inherit core-image
89inherit image_types_uboot
90
91IMAGE_ROOTFS_SIZE = "1"
92# Increased the overhead factor to be able to build via nfs.
93IMAGE_OVERHEAD_FACTOR = "2"