summaryrefslogtreecommitdiffstats
path: root/recipes-test/systest-runner/systest-runner.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 17:36:38 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 17:36:38 +0100
commit2a7348129a42f21095fcd62e47a035f78d254130 (patch)
tree544dc8019a8f8cb684ace8674193605e607f9964 /recipes-test/systest-runner/systest-runner.bb
downloadmeta-enea-2a7348129a42f21095fcd62e47a035f78d254130.tar.gz
initial commit of Enea Linux 3.1HEADmaster
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-test/systest-runner/systest-runner.bb')
-rw-r--r--recipes-test/systest-runner/systest-runner.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-test/systest-runner/systest-runner.bb b/recipes-test/systest-runner/systest-runner.bb
new file mode 100644
index 0000000..01fe054
--- /dev/null
+++ b/recipes-test/systest-runner/systest-runner.bb
@@ -0,0 +1,28 @@
1
2LICENSE = "BSD"
3LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
4INHIBIT_DEFAULT_DEPS = "1"
5
6SRC_URI = "file://systest-runner \
7 file://tests/ltp \
8 file://tests/perf-network \
9 file://tests/posixtest \
10 "
11
12STEST_PATH="${libdir}/${PN}"
13
14FILES_${PN} +="${STEST_PATH}"
15FILES_${PN} += "${bindir}/systest-runner"
16
17do_install () {
18 install -D ${WORKDIR}/systest-runner ${D}${bindir}/systest-runner
19 install -d ${D}${STEST_PATH}/tests
20 for file in ${WORKDIR}/tests/* ; do
21 install $file ${D}${STEST_PATH}/tests
22 done
23}
24
25do_patch[noexec] = "1"
26do_configure[noexec] = "1"
27do_compile[noexec] = "1"
28do_build[noexec] = "1"