summaryrefslogtreecommitdiffstats
path: root/recipes-test/ddt-runner/ddt-runner.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2013-12-12 17:36:38 +0100
committerAdrian Dudau <adrian.dudau@enea.com>2013-12-12 17:36:38 +0100
commit2a7348129a42f21095fcd62e47a035f78d254130 (patch)
tree544dc8019a8f8cb684ace8674193605e607f9964 /recipes-test/ddt-runner/ddt-runner.bb
downloadmeta-enea-2a7348129a42f21095fcd62e47a035f78d254130.tar.gz
initial commit of Enea Linux 3.1HEADmaster
Migrated from the internal git server on the dora-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'recipes-test/ddt-runner/ddt-runner.bb')
-rw-r--r--recipes-test/ddt-runner/ddt-runner.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-test/ddt-runner/ddt-runner.bb b/recipes-test/ddt-runner/ddt-runner.bb
new file mode 100644
index 0000000..f6d234e
--- /dev/null
+++ b/recipes-test/ddt-runner/ddt-runner.bb
@@ -0,0 +1,24 @@
1LICENSE = "BSD"
2LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
3INHIBIT_DEFAULT_DEPS = "1"
4
5SRC_URI = "file://ddt-runner \
6 file://scripts"
7
8FILES_${PN} += "${libdir}/${PN}"
9FILES_${PN} += "${bindir}/ddt-runner"
10
11do_install () {
12 install -D ${WORKDIR}/ddt-runner ${D}${bindir}/ddt-runner
13 if [ -d "${WORKDIR}/scripts/${MACHINE}" ]; then
14 install -d ${D}${libdir}/${PN}/scripts
15 for file in ${WORKDIR}/scripts/${MACHINE}/* ; do
16 install $file ${D}${libdir}/${PN}/scripts
17 done
18 fi
19}
20
21do_patch[noexec] = "1"
22do_configure[noexec] = "1"
23do_compile[noexec] = "1"
24do_build[noexec] = "1"